Unnecesarily depends on unity, unity-2d, or gnome-shell

Bug #854058 reported by dobey on 2011-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
gnome-session (Ubuntu)
Medium
Unassigned

Bug Description

This dependency is backwards. These dependencies should be depending on gnome-session instead, as they require it to function properly. If gnome-session is going to have any sort of dependency on them, it should at most be Recommends. I would like to use another window manager instead, but still use gnome-session and other GNOME related features, but I cannot remove these packages and keep gnome-session as it stands. This was not an issue in 11.04 where I could remove the unity packages and keep gnome-session installed.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-session 3.1.91-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Mon Sep 19 13:29:19 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110322.1)
PackageArchitecture: all
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
SourcePackage: gnome-session
UpgradeStatus: Upgraded to oneiric on 2011-09-18 (1 days ago)

dobey (dobey) wrote :
Changed in gnome-session (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.2.1-0ubuntu4

---------------
gnome-session (3.2.1-0ubuntu4) precise; urgency=low

  * Backport some of the Debian changes
  * debian/control.in:
    - drop the Recommends on gnome-power-manager, the code gnome-session uses
      has moved to gnome-settings-daemon
    - drop the build-depends on librsvg2-dev
    - Recommends "unity | unity-2d | gnome-shell" rather than Depends on it,
      some users want to use gnome-session without those (lp: #854058).
  * debian/patches/50_ubuntu_sessions.patch:
    - restore the "no notifications in fallback sessions" for Ubuntu,
      the required components need an autostart .desktop where notify-osd
      doesn't have one, let them be dbus activated rather (lp: #885939)

  [ Michael Biebl ]
  * Remove Depends on policykit-1-gnome from gnome-session as gnome-shell
    provides its own integrated PolicyKit authentication agent.
  * Remove notification-daemon from gnome-session Recommends as gnome-shell
    has an integrated notification system.
  * Make notification-daemon a Depends of the gnome-session-fallback and
    remove debian/patches/13_no_fallback_notification.patch so the session
    manager starts notification-daemon in the fallback case.
  * Bump Standards-Version to 3.9.2. No further changes.
 -- Sebastien Bacher <email address hidden> Tue, 06 Dec 2011 20:07:58 +0100

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers