Ubuntu

Help button does not work for startup applications help

Reported by Vadim Peretokin on 2011-09-01
62
This bug affects 8 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Unassigned
Oneiric
Medium
Unassigned
gnome-session
Fix Released
Medium
gnome-session (Ubuntu)
Low
Michael Terry
Oneiric
Undecided
Michael Terry
Precise
Low
Michael Terry

Bug Description

Just opens help and says this:

Document Not Found
The URI ‘ghelp:user-guide?gosstartsession-2#gosstartsession-2’ does not point to a valid page.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-session-bin 3.1.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CasperVersion: 1.280
Date: Thu Sep 1 02:15:06 2011
ExecutablePath: /usr/bin/gnome-session-properties
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110831)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Vadim Peretokin (vperetokin) wrote :
tags: added: iso-testing
Robert Roth (evfool) on 2011-09-01
Changed in gnome-session (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
importance: Medium → Low
Changed in gnome-session (Ubuntu):
status: Confirmed → Triaged
Jamie Chang (jamie315) on 2011-11-08
affects: gnome-session → oem-priority
Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Changed in oem-priority:
assignee: Canonical Platform QA Team (canonical-platform-qa) → Canonical Desktop Team (canonical-desktop-team)
Steve Magoun (smagoun) on 2011-11-21
Changed in oem-priority:
importance: Undecided → Medium
Changed in gnome-session:
importance: Unknown → Medium
status: Unknown → New
Martin Pitt (pitti) on 2011-11-29
Changed in gnome-session (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in oem-priority:
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in gnome-session (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Terry (mterry)
Michael Terry (mterry) wrote :

Here's a debdiff for precise (I've not uploaded yet because we are in soft-freeze for Alpha 1).

It hides the help button. There is no corresponding help in GNOME 3.2 for this dialog, so makes no sense to have the button.

Michael Terry (mterry) wrote :

I've uploaded an oneiric version of this debdiff to oneiric-proposed. I think this is a worthwhile SRU because it is a very user-visible wart that didn't exist in natty. There's still the regression of no user help for the dialog in oneiric, but that's not fixable. At least we can make it look intentional instead of a broken system.

Changed in gnome-session (Ubuntu Oneiric):
assignee: nobody → Michael Terry (mterry)
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.2.1-0ubuntu2

---------------
gnome-session (3.2.1-0ubuntu2) precise; urgency=low

  * debian/patches/105_hide_session_startup_help.patch:
    - Hide Help button on Startup Applications dialog, as it is broken
      and the help documentation hasn't been written for 3.x yet.
      LP: #838539
 -- Michael Terry <email address hidden> Tue, 29 Nov 2011 13:53:43 -0500

Changed in gnome-session (Ubuntu Precise):
status: Triaged → Fix Released

Hello Vadim, or anyone else affected,

Accepted gnome-session into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-session (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Vadim Peretokin (vperetokin) wrote :

I tested and the fix works. Thanks!

tags: added: verification-done
removed: verification-needed
Changed in oem-priority:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.2.1-0ubuntu1.1

---------------
gnome-session (3.2.1-0ubuntu1.1) oneiric-proposed; urgency=low

  * debian/patches/105_hide_session_startup_help.patch:
    - Hide Help button on Startup Applications dialog, as it is broken
      and the help documentation hasn't been written for 3.x yet.
      LP: #838539
 -- Michael Terry <email address hidden> Tue, 29 Nov 2011 13:53:43 -0500

Changed in gnome-session (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Steve Magoun (smagoun) wrote :

Marking oem-priority tasks Fix Released based on comment #7

Changed in oem-priority:
status: Fix Committed → Fix Released
Changed in gnome-session:
status: New → Confirmed
Changed in gnome-session:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.