Wish: Show warning dialog when shutting down PC and another user logged in

Bug #82530 reported by Kamil Páral
16
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Wishlist
Unassigned

Bug Description

Ubuntu 6.10.
There is no warning dialog, when user wants to shut down/restart PC, and another user is currently logged in. Therefore, all unsaved work of the second user is inevitably lost.

Example scenario:
User Alice logs in. She does some work. After a while, user Bob comes and demands access to the computer. Alice uses the "Switch user" function, so she doesn't have to save and end all work right now.
Bob logs in. He does some work. After he finishes, he forgets about Alice and chooses to "Shut down".
All Alice's work is lost. Nothing has warned Bob that Alice is also currently logged in.

Technical note:
The warning dialog probably would not be required/desired to guard every console and remote connection of other users, but it certainly should guard graphical logins into Gnome.

Microsoft operating systems have this feature and users anticipate the same in Ubuntu.

Please, do not move this issue into enhancement wishlist. This is a bug, because it is something any modern multi-user OS can't be without. Missing of this feature *is* a bug. I have just lost a good amount of work by playing the Alice role involuntarily, so in my point of view, it is a really serious issue.

Revision history for this message
Chris Burgan (cburgan) wrote :

Thanks for the report.

I appreciate the gravity of your situation and that you find this inconvienent. However, it is not a bug but a feature request and as such you should treat it as one. If you strongly desire to have such a feature implemented submit a specification for it.

First check whether the idea is already registered <https://launchpad.net/ubuntu/+specs>, and if so, contact the specification's drafter about your ideas. Otherwise, you can start writing a spec yourself. <https://wiki.ubuntu.com/FeatureSpecifications>

 I agree with you completely that this would be a very handy tool, however this is just the wrong means of getting it acknowledged or implemented.

Revision history for this message
Kamil Páral (kamil.paral) wrote :

OK, I accept it.
The specification doesn't exist at present time. Unfortunatelly I'm not skilled in creating one, and it would take me a lot of time to study through all materials to create a correct specification. Isn't it possible to move this report at least to the Wishlist (I think you can modify Status of this report to the Wishlist entry), so someone may notice it and work on it?

Revision history for this message
laksdjfaasdf (laksdjfaasdf) wrote : Re: Wish: No warning dialog when shutting down PC and another user logged in

Changed the bug to a wish in description as Kamil asked. I'm sorry but I haven't written a specification, yet and have little time at the moment. But I think that this is an important feature, too!

Revision history for this message
Kamil Páral (kamil.paral) wrote :

Hello felix,
it seems to me that only subject of this report has changed. I think it's neccessary to change Importance to "Wishlist" and Status to "Confirmed", if we want someone to notice this...

By the way, issue still valid in Ubuntu 7.04.

Revision history for this message
Kamil Páral (kamil.paral) wrote :

Just tested, still an issue in Ubuntu 7.10 beta. This feature could be perfectly added to the new fast-user-switch applet. Just check if anyone else is still logged in and ask, that's all.

Revision history for this message
Kamil Páral (kamil.paral) wrote :
Revision history for this message
Siegfried Gevatter (rainct) wrote :

(Wishlisted and linked the blueprint to it.)

Changed in gnome-session:
importance: Undecided → Wishlist
Revision history for this message
Michael Nagel (nailor) wrote :

i just found this bug and i'd greatly appreciate if this could be fixed. there seems to be a related brainstorm idea at http://brainstorm.ubuntu.com/idea/3859/ too

Michael Nagel (nailor)
Changed in gnome-session:
status: New → Confirmed
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

gnome-session now uses ConsoleKit to shutdown and restart the machine, and the default CK policy in Ubuntu means that you get a Policykit dialog when attempting to shutdown with multiple users logged in, because you have to authenticate to perform the action. So, this bug is basically fixed now.

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Kamil Páral (kamil.paral) wrote :

It is not exactly user friendly - the dialog is not quite readable for the average end user - but yes, it seems like fixed. Thanks.

Revision history for this message
ktulu77 (ktulu-highwaytoacdc) wrote :

I agree, the message is not understandable for normal users. Several people asked me why he could not shutdown the computer, even if he entered his password on the CK window.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers