Comment 1 for bug 820372

St├ęphane Graber (stgraber) wrote :

IRC log:

17:24 < stgraber> hello, not sure if someone mentioned it here already but ISO testing found bug 820372
17:24 < ubot2> Launchpad bug 820372 in ltsp "default session set to GNOME and fails. Should be Unity" [High,Confirmed] https://launchpad.net/bugs/820372
17:24 < stgraber> which isn't an LTSP bug but a gnome-session one
17:24 < stgraber> LTSP calls /etc/X11/Xsession to start whatever is the default session (no parameter)
17:24 < stgraber> Xsession then starts gnome-session but without a --session= parameter which makes it fail
17:24 < stgraber> I think we had a fix in Natty to make it use a the right "default" session but that apparently got lost somewhere
17:25 < stgraber> was wondering what source package I should move that bug to?
17:25 < cyphermox> stgraber: what I would see was aside from the Ubuntu and Ubuntu 2D entries there was an extra GNOME one that shouldn't be there
17:26 < cyphermox> (outside of ltsp)
17:27 < stgraber> with Edubuntu we have gnome-session-fallback installed so apparently gnome-session starts the fallback session then (instead of unity-3d =>
                  unity-2d => gnome-session-fallback) but on regular Ubuntu, it just fails
17:28 < cyphermox> mmkay, so which case is failing now?
17:29 < stgraber> calling "/etc/X11/Xsession" with no parameter doesn't start the default session on regular Ubuntu
17:29 < stgraber> the same thing on Edubuntu works but starts the session fallback instead of unity (which is wrong too)
17:31 < stgraber> simply calling "/etc/X11/Xsession" from a terminal on your system should reproduce the issue
17:32 < seb128> stgraber, can you check with didrocks when he's around?
17:32 < seb128> stgraber, or better assigned the bug to canonical desktop team
17:32 < seb128> we will sort it
17:41 < stgraber> seb128: ok, will do