invisible logout dialog with xcompmgr

Bug #80343 reported by Marius Gedminas on 2007-01-17
28
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-session

If I have xcompmgr running, and select System -> Log out from the panel menu, I see no fade effect, and no logout dialog. The keyboard and mouse are grabbed and I cannot do anything (other than to click on a dialog full of buttons that I cannot see). Thankfully pressing Esc gives me back the control over my desktop.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use? Marking Low importance because xcompmgr is an option program than user has to install by itself and use to get that problem

Changed in gnome-session:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Marius Gedminas (mgedmin) wrote :

I use Ubuntu Edgy.

I wonder whether the logout dialog only has problems with xcompmgr, or if other composition managers (such as compiz, beryl, or metacity with the compositor enabled) also cause problems.

Note that the screen dimming that is implemented in gksu works fine with xcompmgr.

Changed in gnome-session:
status: Needs Info → Unconfirmed
Sebastien Bacher (seb128) wrote :

Do you still get the bug with Ubuntu 7.04?

Wouter H. (whouweling) wrote :

I can confirm this bug still exists in 7.04 (Feisty)

Sebastien Bacher (seb128) wrote :

how do you use xcompmgr?

Wouter H. (whouweling) wrote :

I added an entry to Gnome->Session->startup-programs, containing: "xcompmgr -c -r 10 -o .50 -l -15 -t -15"

Reason for using Xcompmgr is the good performance relative to Beryl and Compiz on my laptop (Dell D800 Latitude), mostly when opening lots of windows.

Sebastien Bacher (seb128) wrote :

Confirming

Changed in gnome-session:
status: Unconfirmed → Confirmed
Martin Peeks (martinp23) wrote :

gnome-session 2.19.3 has the changelog entry:

  * Session Manager
     - Don't do logout fade if there's a compositing manager running (Ray Strode, Bastien Nocera)

I don't know if this will solve this bug - hopefully it will :). If anyone can test it, it's packaged and waiting to be uploaded when the freeze ends. Otherwise, you can download it using:

dget http://www.sbka.org.uk/MOTU/gnome-session_2.19.3-0ubuntu1/gnome-session_2.19.3-0ubuntu1.dsc

@Martin: link looks broken

Martin Peeks (martinp23) wrote :

Ahh yes - the package in the gutsy archive is now 2.19.4-0ubuntu3, which is an updated version of the one I packaged and linked above - it would be best to try to test with that.

Thanks.

Nick B. (futurepilot) wrote :

Confirmed. On Dapper too.

Changed in gnome-session:
status: Confirmed → Triaged
El_Webmaster (elwebmaster) wrote :

Confirmed on Ubuntu Gutsy with Gnome 2.19.6
Only workaround I've found is to set export LTSP_CLIENT=1 in .gnomerc but this IS NOT a solution because it leads to many other inconveniences, such as no "eject" or "unmount" options on the removable media's icons...

I'm still looking for a solution. I would patch the logout manager myself but unfortunately I'm not that familiar with C/C++ yet.

Nick B. (futurepilot) wrote :

Yes, this still happens on Gutsy. Up-to-date Tribe 5.

I think the problem is Gnome can be notified (I don't know how this actually happens, but that's not the point) or can "understand" a compositor is enabled only if it is included in the windows manager. xcompmgr does all of its work indirectly, so when windows have already been created; that's probably why you don't get real transparency with gnome-terminal, and that's probably why the logout dialog still fades, locking the screen: in fact with a compositor-enabled wm the logout dialog does not have any background shade (I don't understand why gksudo worls, though).

solution? Dunno. This should be forwarded upstream. In the meantime I found using xfwm4 is fair enough

Sebastien Bacher (seb128) wrote :

not milestoned the bug, compiz is used as composite manager, there is probably not many users running xcompmgr

I use xcompmgr in my Gutsy pc with a s3 savage graphic card ... and I can't use compiz ...

bug was fixed in latest git!!

apt-get build-dep xcompmgr
git clone git://anongit.freedesktop.org/git/xorg/app/xcompmgr
cd xcompmgr
./autogen.sh
make
sudo fakeroot checkinstall # to have debian package installed

for people interested I've attached a checkinstall package here http://ubuntuforums.org/showpost.php?p=3612499&postcount=4

Sebastien Bacher (seb128) wrote :

do you know what change fixes the issue? Using such hacked packages is not recommended

Martin Peeks (martinp23) wrote :

"Bug #9762: Fix opacity changes on unmapped windows." is the upload log entry for that one - didn't realise it wasn't included on [1] above.

@sebastien, sure that's just a quick and dirty package I've did for myself, not meant for release; I didn't want to figure out how to apply the correct license, I'm not good with dh_make and stuff.

By the way you should be able to figure out the changes by doing an apt-get source xcompmgr, clone from git and then diff

ps: Maybe you could forward the update to debian, too, they still have a very old release http://packages.debian.org/experimental/xcompmgr

Martin Peeks (martinp23) wrote :

NoWhereMan: Does the attached work for you as desired?

this page lists the whole changelog summary

http://gitweb.freedesktop.org/?p=xorg/app/xcompmgr.git;a=summary

our package name says "20060831", so the changes start from

http://gitweb.freedesktop.org/?p=xorg/app/xcompmgr.git;a=commit;h=d75fd64f7aefd818dcac7ab2ebdf57e69bf12ea5
"Set the _NET_WM_CM_S* atom on the screen we're running on."

I think *that* might be the key-change for our bug http://standards.freedesktop.org/wm-spec/1.4/ar01s08.html

the other commit addresses a different bug http://bugs.freedesktop.org/show_bug.cgi?id=9762

HTH

Martin Peeks (martinp23) wrote :

hmm - I've just finished testing the package I uploaded here just then, and it does ideed seem to show the logout dialog now (in gutsy), whereas I was getting nothing at all before the upgrade. Debdiff attached.

hmm, I'm not sure of what happened here but the package you uploaded doesn't work for me, I mean, I don't see the logout while it works with mine o.O

Martin Peeks (martinp23) on 2007-10-23
Changed in gnome-session:
status: Triaged → Fix Committed
Martin Peeks (martinp23) wrote :

Strange. I'll set this back to in progress until we know what's happening ;).

Here's what I did:
1)sudo apt-get install xcompmgr
2)Put "xcompmgr -c -r 10 -o .50 -l -15 -t -15" into startup programs
3)Ctrl-Alt-Backspace
4)Test - doesn't work
5)Install new package, Ctrl-Alt-Backspace
6)Test - works - I see the logout dialog (no fade though, maybe because I'm using compiz usually?).

Changed in gnome-session:
status: Fix Committed → In Progress

here's what i did

(old package installed)

$ xcompmgr #whatever you want to add here

no need for parameters really

try to logout -> it doesn't work

move to the package dir ->

$ ./xcompmgr # -> logout -> it works

$ dpkg -i name-of-your-package

$ xcompmgr # logout: it doesn't work anymore :/

$ dpkg -i name-of-MY-package

$ xcompmgr # it works

well maybe I did something wrong, I was a bit tired yesterday, I'll try to have a look later today

is your package made from git as mine? or did you patch the old one in some way?

no, unfortunately the package you attached does not work for me :/

Rysiek (rickardhultgren) wrote :

I'm not an experienced linux user, but perhaps my ideas can be useful. I wondered if an addition in the file /etc/X11/xinit/xinitrc or /home/~/.xsession can solve the problem. I've already tried adding the code xcompmgr with parameters in these files, but that didn't gave any result. Perhaps anyone else knows a suitable code. Another solving of the problem could be to use a program like gnome-settings-visualeffects ( http://www.gnomefiles.org/app.php/gnome-settings-visualeffects ). Just this program is unfortunately discontinued.

Kido (greasedbolt) wrote :

i tried both pacages too. the one on the forums works, but the one here doesn't. :/

traaf (traaf) wrote :

bug is still present with an up-to-date gutsy install running xcompmgr

Gianluca Borello (g.borello) wrote :

Bug is still present in gutsy (ati+xcompmgr+metacity)

it is; if you need it to work you can try the suggested procedure above, or use the checkinstall package attached on the forums

Gianluca Borello (g.borello) wrote :

I even tried compiling xcompmgr fetching sources from git://anongit.freedesktop.org/git/xorg/app/xcompmgr, but it continues to feeeze the logout screen..

Gianluca Borello (g.borello) wrote :

Ok, I need to correct myself: if I launch the new xcompmgr without parameters, it works, but if I launch xcompmgr -c, it freezes!
What can I do to avoid that?
However, this is not a big problem, because I use xcompmgr for running screenlets, even if some shadows would be cool ;)

Sebastien Bacher (seb128) wrote :

the bug is deprecated in the new intrepid dialog

Changed in gnome-session:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.