fallback message contains poor grammar

Bug #712091 reported by Brian Murray on 2011-02-02
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
High
Didier Roche
Natty
High
Didier Roche

Bug Description

Binary package hint: gnome-session

From debian/patches/02_add_ubuntu_session.patch:
+_FallbackMessages=;It seems you do not have the hardware requirement to run unity. Installing new driver can maybe be a help.\nYou should try the Ubuntu classic session to directly get the traditional interface.

This is one of the first messages people may receive when running Natty and the grammar doesn't really make a good impression.

Brian Murray (brian-murray) wrote :

It'd be worth looking at bug 704409 when working on this.

Changed in gnome-session (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
Bryce Harrington (bryce) wrote :

Agreed, this is probably a bad experience to give users. It can pop up in cases where there is nothing wrong with the hardware, just that the software isn't up to snuff.

The dialog is ok for alpha releases but should be revisited by beta.

I don't think the dialog should start recommending installing different drivers, that just seems like fail. If we know newer drivers solve the issues then they should be packaged and installed.

Honestly I think this is a case where no warning message would be better. If they know the difference between classic and unity, it'll be obvious that they're not running unity; this dialog doesn't add to their knowledge in that situation. If they don't know the difference, then this dialog will just confuse them and make them worry that Ubuntu is broken.

On Wed, Feb 02, 2011 at 08:19:07PM -0000, Bryce Harrington wrote:
> Agreed, this is probably a bad experience to give users. It can pop up
> in cases where there is nothing wrong with the hardware, just that the
> software isn't up to snuff.
>
> The dialog is ok for alpha releases but should be revisited by beta.
>
> I don't think the dialog should start recommending installing different
> drivers, that just seems like fail. If we know newer drivers solve the
> issues then they should be packaged and installed.

Right, I'd think that jockey would just recommend installing the
proprietary driver if it is appropriate for the hardware.

Sebastien Bacher (seb128) wrote :

Could a native speaker suggest a better string? Subscribing Didier as well since displaying a dialog and asking to logout rather than doing that for the user was discussed earlier in the cycle and a design choice

Brian Murray (brian-murray) wrote :

"It seems that you do not have the hardware required to run Unity. Please choose the Ubuntu Classic Desktop at the login screen and you will be using the traditional environment."

That works for me.

Changed in gnome-session (Ubuntu Natty):
status: New → Confirmed
Didier Roche (didrocks) wrote :

Thanks for the suggestion, it's better to suggest something that telling just "poor grammar" which doesn't help non native speaker…

So, we need to hilight more in ubiquity that they can install proprietary driver to have the full ubuntu experience.

Changed in gnome-session (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Didier Roche (didrocks)
Didier Roche (didrocks) on 2011-02-03
Changed in gnome-session (Ubuntu Natty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.32.1-0ubuntu14

---------------
gnome-session (2.32.1-0ubuntu14) natty; urgency=low

  * debian/patches/02_add_ubuntu_session.patch:
    - add a better wording (LP: #712091)
  * debian/control.in:
    - recommends unity-2d as a gnome-panel | unity alternative (LP: #708928)
  * debian/patches/05_enhance_fallback_mode.patch:
    - change the multi-fallback handling, now a list of key in the keyfile is
      provided to FallbackSessionsID. If the fallback is found, the matching
      <keyname>_Message will be displayed if exists. (LP: #704409)
    - don't show "change user session" for now has gnome-control-center with
      that option won't be ready for natty (LP: #711920)
    - adapt the gnome session to the new format (LP: #707232)
  * debian/patches/02_add_ubuntu_session.patch:
    - adapt to new format
    - set ubuntu as the default session if no argument is given
 -- Didier Roche <email address hidden> Thu, 03 Feb 2011 16:17:57 +0100

Changed in gnome-session (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers