Fallback from Unity-GL should use unity-2d if installed

Bug #703653 reported by Mark Shuttleworth on 2011-01-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-session
Expired
Medium
gnome-session (Ubuntu)
Wishlist
Didier Roche

Bug Description

Binary package hint: gnome-session

When logging into a Unity-GL session, we detect whether the hardware is capable of supporting that shell, and if it is not, we fall back to a 2D experience. In Natty, that 2D experience is the Classic Gnome shell. However, if the Unity-2D shell is installed, then we should fall back to that instead.

How to reproduce:

 - install Natty on a machine that is not capable of running Unity-GL
 - install Unity-2D
 - log into the desktop choosing the standard "Ubuntu Desktop" session

What happens:

 - you get a warning, and the Classic Gnome session

What should happen:

 - you should not get a warning, and the Unity-2D session should be loaded

Sebastien Bacher (seb128) wrote :

Right, we dsicussed that with Didier last week as well

Changed in gnome-session (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

Yeah, nice that we are on the same page as I proposed that last week :)

So, the fallback session should have a preference order rather than using alternatives in that case and an option extra key to tell "don't show the fallback message if fallbacking to…".
Working on it this week.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.32.1-0ubuntu12

---------------
gnome-session (2.32.1-0ubuntu12) natty; urgency=low

  * debian/patches/05_show_message_if_fallback.patch =>
    debian/patches/05_enhance_fallback_mode.patch:
    - now support multiple fallbacks. It will pick the first valid one.
      show the corresponding fallback message if needed.
  * debian/patches/02_add_ubuntu_session.patch: (LP: #703653)
    - the ubuntu session has now two fallbacks:
      + unity-2d (2d-ubuntu) for launching the 2d version of unity without any
        warning message if present.
      + gnome-classic (classic-gnome), launching the classic gnome shell
        (panels) with a warning message about the different user experience.
 -- Didier Roche <email address hidden> Tue, 18 Jan 2011 12:58:24 +0100

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
PEIGNOT Kévin (kpeignot) wrote :

I think it should show a message, even if fallbacking to Unity-QT, and in the two cases ( fallback to Gnome-panel or Unity-QT, ask the suer if he wants to show this message next time.)

Changed in gnome-session:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-session:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.