maximus should only run in netbook-session and not start in gnome-session

Bug #631696 reported by Nicolas Dechesne on 2010-09-06
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Oliver Grawert
gnome-session (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
ubuntu-netbook-efl-default-settings (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: gnome-session

I am using the 10.10 beta image for armel (OMAP) with ubuntu-netbook. By default it uses the une-efl session, where apps are maximized by default.

after logging out and logging into with the standard desktop session, apps are still maximized, and I think they should not.

Related branches

Oliver Grawert (ogra) on 2010-09-20
summary: - When using ubuntu-netbook beta image on OMAP, after switching to
- standard desktop, apps show up maximized
+ maximus should only run in netbook-session and not start in gnome-
+ session
Changed in gnome-session (Ubuntu):
status: New → Invalid
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → ubuntu-10.10
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Changed in ubuntu-release-notes:
assignee: nobody → Oliver Grawert (ogra)
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
milestone: ubuntu-10.10 → maverick-updates
Oliver Grawert (ogra) wrote :

Release Note:

"On the ARM preinstalled images there is a minimal desktop session you can select from GDM.
Due to a bug in the tool maximus (bug 631696) windows in this session have no frames and are
always started in full screen mode."

Changed in ubuntu-release-notes:
status: New → Fix Committed
Gary M (garym) wrote :

The latest maximus update (0.4.14-1ubuntu3 x86) has caused windows to no longer be "full-screened" in a gnome desktop session with une not installed. Is that related to a fix for this, or is it a new bug?

Martin-Éric Racine (q-funk) wrote :

This is a regression. We want Maximus to maximize windows in all session types, not just in UNE.

Oliver Grawert (ogra) wrote :

@garym: yes, please file a new bug for this, it will actually need code changes in maximus to make it detect if the session it is run in contains window picker, currently it is not that clever and will only start in the session the /etc/xdg mechanism fires it up in

@martin: no this is not a regression, in lucid maximus did not start in the normal desktop session at all.

Gary M (garym) wrote :

@Oliver, I agree with Martin-Éric that I want Maximus to auto-start in a normal desktop session if installed. I currently use it on a small screen in a gnome desktop session without UNE or Window Picker.

If maximus appeared in the gnome-session-properties list ("Startup Applications"), it could easily be disabled if not wanted.

Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
Oliver Grawert (ogra) wrote :

@garym, how wuld a user close their windows without window picker installed ? we cant enable it by default in a gnome-session since it removes all opportunities to close the window if window picker is not there.

Gary M (garym) wrote :

@Oliver, only the visual cues are lost. The window menu is directly accessible via Alt-space, window control functions are also accessible via their shortcut keys (e.g. Alt-F4 to close), and I can also use the mouse/touchpad with Window List in the bottom panel to view full window titles with hover and access the window menus with a right-click. Window switching can be done with the keyboard (e.g. Alt-tab) or with the mouse/touchpad (Window List). I set both top and bottom panels to auto-hide, and with netbook screen resolutions it's only a moderate mouse/touchpad movement to show them.

Oliver Grawert (ogra) wrote :

and you think that would be a good default for all gnome sessions the users select on the netbook image ? could your mother handle that intuitively ?

sorry, but i really think thats a corner case for advanced hackers, by default maximus requires window picker to be installed, else usability breaks for everyone else. it is not to hard to manually add it to the "started applications" of your session for someone who is experienced enough to handle it without window borders i would think.

Gary M (garym) wrote :

@Oliver, we may be at cross-purposes. Maximus seems like a good "pixel-conserving" solution for users who have small screens even when they can't/won't use Unity. I installed Maximus without UNE, and I had a reasonable expectation that it would start automatically. I'm just an old IT-vet who sometimes installs packages, not a Gnome hacker. I'm not trying to recommend how others should use Ubuntu, just trying to point out that the last config change had a surprising result for me, and I hadn't realised that my use case was seen as anomalous.

I've followed your advice and manually added it to Startup Applications in an enabled state without problem. Perhaps a note regarding this could be added to the package description and/or man page.

Tobin Davis (gruemaster) wrote :

Is this bug still valid?

Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
assignee: Canonical ARM Developers (canonical-arm-dev) → Oliver Grawert (ogra)
Changed in ubuntu-netbook-efl-default-settings (Ubuntu):
assignee: Canonical ARM Developers (canonical-arm-dev) → nobody
Rolf Leggewie (r0lf) on 2011-09-18
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: Confirmed → Incomplete
Changed in ubuntu-netbook-efl-default-settings (Ubuntu):
status: Confirmed → Incomplete
Tobin Davis (gruemaster) on 2012-02-24
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: Incomplete → Won't Fix
assignee: Oliver Grawert (ogra) → nobody
milestone: maverick-updates → none
Changed in ubuntu-netbook-efl-default-settings (Ubuntu):
milestone: maverick-updates → none
Adolfo Jayme (fitojb) on 2015-10-02
Changed in ubuntu-netbook-efl-default-settings (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers