tomboy applet prevents the indicator to be shown

Bug #620427 reported by Pete Goodall on 2010-08-19
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
gnome-session (Ubuntu)
Medium
Canonical Desktop Experience Team
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Quicklists no longer work on any of my launcher icons in Unity. This means I cannot pin an icon to the launcher or benefit from the quicklist of (for instance) Tomboy. When I right click on a launcher I either get nothing or I gues the app name and Quit as my only options.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.26-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic i686
Architecture: i386
Date: Thu Aug 19 12:34:34 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Pete Goodall (pgoodall) wrote :
Michael Terry (mterry) wrote :

This appears to be related specifically to Tomboy. I got this behavior (when I right-clicked on icons like Terminal, the label would expand to the right (as if expanding to the length needed to show "Keep in launcher" or whatever) but would not show a menu, just the app title).

But when I closed Tomboy, everything worked again.

I opened Tomboy again, and things sometimes worked. I sometimes got the Quicklist and sometimes just the longer label.

I never got the Tomboy icon to respond to right or left clicks at all. Seems Tomboy really does a number on unity. Do you see the same thing, Pete, or is mine a subtly different bug?

Ken VanDine (ken-vandine) wrote :

This appears to be related to window matching, the icon we see for tomboy in the launcher is actually for the "Search" dialog, not tomboy. If you close that window, the launcher goes away and doesn't show the arrow saying it is running even though it still appears in the indicator with the menu.

Somehow we need to special case this so the icon can match tomboy not the search dialog, I assume.

Didier Roche (didrocks) on 2010-09-08
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
milestone: none → 2010-09-09
Changed in unity (Ubuntu):
milestone: none → ubuntu-10.10
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
assignee: Didier Roche (didrocks) → Gord Allott (gordallott)
David Barth (dbarth) wrote :

I can still see the issue in 0.2.36. It seems to happen when the application is active. Ie, an inactive application can display a quicklist (to pin a launcher for launcher), but once the application is active, the QL doesn't display. Still I can see the shape of the tooltip adjusting to widen in preparation for the QL to display.

Changed in unity:
importance: Medium → High
David Barth (dbarth) on 2010-09-10
Changed in unity:
milestone: 2010-09-09 → 2010-09-16
Didier Roche (didrocks) on 2010-09-14
Changed in unity:
status: Triaged → Fix Released
status: Fix Released → Triaged
David Barth (dbarth) wrote :

Rendering issues with the menu items, observed in particular with Intel 945/950 chipsets.

Changed in unity:
assignee: Gord Allott (gordallott) → Mirco Müller (macslow)
Mirco Müller (macslow) wrote :

From the initial report summary this looks to be an integration issue with bamf. I can confirm that on my systems here. This is not intel GMA 950 related.

What rendering issues do you get on your netbook, David? Maybe we can open a dedicated bug for those. If received the new newbook now and can execute unity on intel GMA950 hardware now.

Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) wrote :

Rhythmbox no longer working with the dynamic quicklist-entries is expected, due to the new sound-menu. Tomboy, though, should still work, and I've yet to find the spot where the exported entries get lost on their way to unity.

Neil J. Patel (njpatel) on 2010-09-16
Changed in unity:
milestone: 2010-09-16 → 2010-09-22
David Barth (dbarth) wrote :

On GMA950 the issue is pretty clear: only the tooltip window appaears. For most of the QL i've tested, the QL window refuses to expand from the initial tooltip. I can see the tooltip window expand horizontally in certain cases, but it stays at the same size vertically. That's for normal application QLs.

The QL for the files & folders icon "breaks its frame", ie the frame stays at the same size, but the content expands vertically outside of it. Same for the applications icon.

David Barth (dbarth) wrote :

And after trying that for a while. The QL content of even the files & folders or applications icon refuse to show up anymore.

Didier Roche (didrocks) wrote :

This can also happen anytime on the UNE session (under mutter). After a while, I can't open any quicklist

Didier Roche (didrocks) wrote :

(this is with unity 0.2.40)

Mirco Müller (macslow) wrote :

The problem seems to be not on the unity-side. The running bamfdaemon is not recent enough for this to work correctly. In unity's quicklist_controller.vala menu_items = top_menu.get_children() is null, thus no items to add to the quicklist. I'm currently grabbing/compiling bamf trunk to verify this.

Mirco Müller (macslow) wrote :

I'm using bamf trunk (marked as 0.2.53) now. With this I get tomboy's quicklist-entries correctly displayed again.

Changed in unity:
status: In Progress → Invalid
Mirco Müller (macslow) wrote :

I'm marking this as invalid. It's a package-dependency issue rather.

The rendering issues stated in the comments, should be filed as separate bugs.

Mirco Müller (macslow) on 2010-09-20
summary: - No quicklists in Unity
+ tomboy applet prevents the indicator to be shown
Changed in unity:
status: Invalid → Confirmed
assignee: Mirco Müller (macslow) → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

will be fixed by gnome-session not loading the panel

affects: unity (Ubuntu) → gnome-session (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.31.6-0ubuntu2

---------------
gnome-session (2.31.6-0ubuntu2) maverick; urgency=low

  * debian/patches/24_filter_autosaved_application_for_une.patch:
    don't start gnome-panel, metacity/compiz from saved session in UNE.
    This is a current workaround to LP: #578585. A correct fix
    will be to integrate a migration path, excluding all
    required_components from the saved list before starting them.
    It fixes (LP: #620427, #641256) as the applets aren't loaded.
 -- Didier Roche <email address hidden> Tue, 21 Sep 2010 15:38:47 +0200

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-09-22
Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers