Gnome splash screen quits way too early

Bug #59479 reported by Trouilliez vincent on 2006-09-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-session
Expired
Medium
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-session

I am on Edgy at the moment, but I think the problem was already there in Dapper:

When I log into Gnome, I get the splash screen, but, it quits after only 2 seconds, loooong before the desktop is actually loaded, so you can't actually trust the splash to know when you can start using the desktop, but must rather ignore the splash and wait until you "think" it's loaded.
So would be nice if the splash actually worked, and disappeared only when the Desktop is 100.00% loaded and ready to be used.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. On my edgy desktop the splash go away when the panels are drawing and like 1 second before having nautilus drawing the desktop. The conditions probably depends of the program started, the box speed, the user profile, etc. Setting as a low priority issue since that's a detail and we have lot of other things to work on too

Changed in gnome-session:
assignee: nobody → desktop-bugs
importance: Untriaged → Low
status: Unconfirmed → Confirmed
RoDoLFo TX (rodolfo-inec) wrote :

May 28th, 2008
and this bug still exists.
Exactly as it is detailed before, gnomesplash goes away when Nautilus starts being loaded so you have to guess when the system is ready. I just commented this here because Ubuntu hardy comes with GNOME 2.22 but it seems that this detail doesn't mean that everything on GNOME will be working just fine and bug-free.

Could someone please just take a look?
Also could you guys add this BR to the wishlist?

thank you.

Sebastien Bacher (seb128) wrote :

do you still get the issue in intrepid?

Changed in gnome-session:
status: Confirmed → Incomplete

I am having this problem in both 32-bit hardy and 64-bit Intrepid. In hardy I am getting 3 icons appearing..the last being the file browser and them no more icons.... It just hangs till everything is loaded. In Intrepid I am only getting one icon. That one icon again being the file browser. There is no more icons appearing. It doesnt make the splash go away though until everything is loaded.

I tried changing my default file browser too to thunar to see if it was just nautilus but this doesnt seem to be the case. I am just wondering if the spalsh utility knows of these icons. I think it may just be loading blank icons or something. Is there somewhere i can check what icons the gnome splash loads? or what applications it loads?

RoDoLFo TX (rodolfo-inec) wrote :

Humm actually I didn't think about this possibility...GSS may just be loading blank icons...anyway, if this is what's happening, then I think those 'blank icons' should come with gnome splash screen...

By the way, what happens if starting up the system with GSS in 8.10?
Has anyone tried it already?

yes i am having this problem in 64-bit intrepid too. It is only loading one of the icons...that being the nautilus one. it comes first and then there is no more

Linking to upstream bug.

Changed in gnome-session:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-session:
status: Incomplete → Confirmed
Changed in gnome-session:
status: Unknown → Confirmed
Changed in gnome-session:
status: Confirmed → Triaged
doc_471 (the-analist-3d) wrote :

I confirm this issue. The splash screen in my case doesn't appear even with the Splashscreen manager and all stuff.
Currently using Lucid 64-bit, with the updates and everything.
Maybe the Splash screen its not appearing because Compiz start first and doesn't allow gnome-session to show it? I think the solution lies in the priority of processes/daemons/stuff when loading the desktop

Chris Coulson (chrisccoulson) wrote :

We don't even install the splash screen in Ubuntu any more

Changed in gnome-session (Ubuntu):
status: Triaged → Invalid
Changed in gnome-session:
importance: Unknown → Medium
Changed in gnome-session:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.