[regression-release] Neither compiz nor metacity nor nautilus are run at start

Bug #467668 reported by Michał Gołębiowski-Owczarek on 2009-10-31
126
This bug affects 52 people
Affects Status Importance Assigned to Milestone
gnome-session
Invalid
Undecided
Unassigned
gnome-session (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

After yesterday updates I've lost my window manager - it doesn't start when I log in. I have to trigger 'compiz --replace' manually - all I get before that are windows without borders, close buttons etc.

Another issue is that nautilus doesn't start - I don't see icons on the desktop and so on.

ProblemType: Bug
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: mgol 2453 F...m pulseaudio
 /dev/snd/controlC0: mgol 2453 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,1028024f,00100302 HDA:80862802,80860101,00100000'
   Controls : 32
   Simple ctrls : 19
CheckboxSubmission: 38a02a3e64856f28c4282db7a77b74c3
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Sun Nov 1 00:37:01 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091008)
MachineType: Dell Inc. Latitude E6500
NonfreeKernelModules: wl
Package: linux-image-2.6.31-14-generic 2.6.31-14.48
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-14-generic root=UUID=e53695eb-254d-4e3f-a123-fbad8c303dd9 ro
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:2470): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2470): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2519): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2744): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
dmi.bios.date: 05/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A13
dmi.board.name: 0NY667
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA13:bd05/08/2009:svnDellInc.:pnLatitudeE6500:pvr:rvnDellInc.:rn0NY667:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6500
dmi.sys.vendor: Dell Inc.

Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mgol 2453 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,1028024f,00100302 HDA:80862802,80860101,00100000'
   Controls : 32
   Simple ctrls : 19
CheckboxSubmission: 38a02a3e64856f28c4282db7a77b74c3
CheckboxSystem: d00f84de8a555815fa1c4660280da308
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091008)
MachineType: Dell Inc. Latitude E6500
NonfreeKernelModules: wl
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-14-generic root=UUID=e53695eb-254d-4e3f-a123-fbad8c303dd9 ro
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:
 2: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A13
dmi.board.name: 0NY667
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA13:bd05/08/2009:svnDellInc.:pnLatitudeE6500:pvr:rvnDellInc.:rn0NY667:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6500
dmi.sys.vendor: Dell Inc.

tags: added: apport-collected
description: updated
Changed in compiz:
status: New → Invalid
affects: linux (Ubuntu) → compiz (Ubuntu)

Architecture: amd64
CheckboxSubmission: 38a02a3e64856f28c4282db7a77b74c3
CheckboxSystem: d00f84de8a555815fa1c4660280da308
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,video,svg,screenshot,regex,commands,text,gnomecompat,imgjpeg,mousepoll,png,workarounds,session,extrawm,dbus,thumbnail,shift,snap,resizeinfo,wall,expo,fade,ezoom,shelf,scale,staticswitcher,scaleaddon]
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091008)
MachineType: Dell Inc. Latitude E6500
NonfreeKernelModules: wl
Package: compiz 1:0.8.4-0ubuntu2
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-14-generic root=UUID=e53695eb-254d-4e3f-a123-fbad8c303dd9 ro
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 05/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A13
dmi.board.name: 0NY667
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA13:bd05/08/2009:svnDellInc.:pnLatitudeE6500:pvr:rvnDellInc.:rn0NY667:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6500
dmi.sys.vendor: Dell Inc.
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.31-14-generic

Changed in compiz (Ubuntu):
status: New → Incomplete
affects: compiz (Ubuntu) → gnome-session (Ubuntu)
Changed in gnome-session (Ubuntu):
status: Incomplete → New
Changed in gnome-session (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Changed in gnome-session (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-session (Ubuntu):
status: Invalid → New
Changed in gnome-session (Ubuntu):
status: New → Incomplete
Leo (leorolla) on 2010-06-02
affects: compiz → gnome-session
summary: - Neither compiz nor metacity nor nautilus are run at start
+ [regression-release] Neither compiz nor metacity nor nautilus are run at
+ start
tags: added: regression-release
removed: amd64
Leo (leorolla) on 2010-06-02
Changed in gnome-session (Ubuntu):
status: Incomplete → Confirmed
23 comments hidden view all 103 comments

My ~/.config/gnome-session/saved-session directory was empty. And still, neither nautilus nor compiz run by itself.

Leo (leorolla) wrote :

@Tony
Good. I think it's exactly what Travis is asking for. Can you zip and attach it?

@Michał
Sorry, I pointed all the other bugs to duplicate this one and now it seems that maybe the problem you observed with Karmic and the problem we observe with Lucid have different roots.
Could you try "mv ~/.config ~/.config-old" and reboot to see what happens?
You said it doesn't happen for a fresh user account, so it must be somewhere in ~/.whatever
Please rename instead of deleting so we can have the folders for autopsy

Augustin (g-u-s-g-u-s) wrote :

I have renamed the following folders:
- ~/.compiz
- ~/.config/compiz
- ~/.config/gnome-session

A reboot later, nothing's fixed.

I may try to rename even more folders, or do the opposite, i.e. rename every folder but a few that I'm 100% sure have nothing to do with graphical stuff (thunderbird, chromium, etc.).

It's so frustrating not to be able to launch some kind of program to return to a default config and work up from there.

Tony Pursell (ajpursell) wrote :

Here is my gnome-session-old folder.

Tony Pursell (ajpursell) wrote :

FWIW my ~/.config/gnome-session/saved-session folder is now completely empty.

@Leo
Removing ~/.config doesn't help. I restored the previous contents.

A fresh user account works fine. What other folders I could possibly check?...

Leo (leorolla) wrote :

Reboot, log in with xterm session instead of gnome.
cd ~
mkdir backup
mv .gconf* backup
mv .gnome* backup
mv .config backup
mv .compiz backup
Log out, log in with gnoe session.

Augustin (g-u-s-g-u-s) wrote :

Leo, thank you... in a way =)

This indeed fixed the problem, so thank you for that.

However, the commands you gave do not move the directories to a backup... They RENAME each directory to the same name, which means it gets erased. Which means, for instance, I've lost all my Chromium extensions (fortunately I had enabled the Synch option, so my bookmarks are safe) and saved passwords. Of course, I've also lost all my configuration files for Compiz, for instance, but that might have been necessary anyway.

So, please, could you fix your suggestion before other people lose their data?

Thank you for your help anyway, apart from this quirk, I can now boot without having to hack my way through to a normal desktop.

Leo (leorolla) wrote :

Hi Augustin, I don't how it could make you loose the folders. Did you copy-paste the above six lines to the terminal? Could you run "ls -la ~/backup" ?

Augustin (g-u-s-g-u-s) wrote :

I'm very confused... After doing all this, I did "cd backup" then "ls -al" and it returned nothing. I did that three times to be sure. Now, I've just done it again because you asked, and it's all there.

So, obviously, I've messed up the command or had a very, very bad brain lapse. In any case, I'm very sorry to have written false information about your message, and as soon as I find a way to edit my comment, I will do so.

Again, all my apologies, and let me reiterate the "thank you" for making my Ubuntu more usable =)

Leo (leorolla) wrote :

Don't worry :-)
Let's refine the search?
You can set back some of the folders to see which ones are causing the problem.
(For example, ***I am assuming you didn't do anything with the backup folder*** to be sure that the problem is in { .config , .compiz }
rsync -a ~/backup/ ~/double-backup-to-keep-chromium-links-even-safer/
rm -rf ~/{.gnome*,.gconf*} ; rsync -a ~/backup/{.gnome*,.gconf*} ~/
Reboot. Should be working well.
rm -rf ~/{.config,.compiz} ; rsync -a ~/backup/{.config,.compiz} ~/
Reboot. Should be as bad as before. )

Augustin (g-u-s-g-u-s) wrote :

Thank you Leo.

I cannot try this right now, this being my office computer. I will try it later today, or tomorrow, or this week-end, and let you know here.

Thanks again.

@Augustin
Those instructions are OK, You must have screwed sth up.

@Leo
I'll check it later.

@Augustin
I'm sorry, I missed Your later comments. Must have been blind for a while.

Rob S (rsiferd2) wrote :

@Leo
The fix you posted on the other page (Bug #572617) seemed to fix it for me. Thanks a bunch!
The only issue to those using it: you will loose a lot of settings and you will have to manually restore them. In this case it wasn't too confusing or tedious.

Cheers,
Rob

Hi Rob. This means the problem is inside .config
Thanks for testing.
You can restore the previous settings:
cd $HOME ; mkdir backup2 ; mv .config backup2 ; mv backup/.config . ;
mv .config/gnome-session backup
Reboot and tell us please?

Doug Morse (dm-dougmorse) wrote :

Hi Rob,

Per your request in bug #572617 -- my apologies for mis-posting there -- I removed my workarounds, moved my ~/.config directory to a backup location, reboot the system, and then logged back on.

This most decidedly did NOT fix the problem. Indeed, it create quite a mess, wherein, depending on what I tried to fix the mess, I'd get either (a) just a blank desktop with only my desktop background image, that is, no awn, no panels, not right-clicking on the desktop for a menu, simply nothing (in these cases, switching to tty1, I saw that compiz.decorator was running, but not compiz), or (b) a semi-normal desktop but desktop appearances set to "none" and no awn.

Regarding (b), if I selected "extra" in System > Preferences > Appearance, well, many things would happen, all of them "bad". Sometimes gnome-appeance-properties would then say "Searching for drivers" and then sometimes it would return to the Appearances dialog and other times it would say "Could not set desktop effects". At other times, gnome-appeance-properties would seem to then do something that started a run-away loop; it's hard to explain, but it *seemed* like compiz was continually restarting and/or perhaps "fighting" with metacity?

Nothing did would then restore my desktop to a functional state. Restoring my original .config directory and, either re-enabling my workarounds or not, nothing did the trick. I had to restore my home directory from the previous day and that did, finally, get me back to a working desktop.

Thus, I strongly suspect that the problem is NOT just in a user's .config directory. What all happened after I let gnome recreate a .config dir, and the fact that restoring my original .config directory did not fix the problem, are the primary reasons I think this. have other reasons to believe the problem lies not just in the .config directory, due to previous experiences that I've had, but I won't elaborate on them here.

I'm probably stating the obvious, but it seems pretty clear that it's some sort of timing / sequencing or coordination issue between multiple components, perhaps compiz and gnome/gconf, maybe even the display drivers and/or metacity?

From one of the times that I logged in and my desktop hung at displaying my background image, I've attached: (a) the last 23 lines of my dmesg file -- you can see the nvidia driver cycling, (b) my .xession-errors file from the same point in time. I observed nearly identical behavior on my < 1yr old laptop with ATI radeon 3200 HD before implementing my workaround, so I don't think this is just a driver issue, either (although perhaps an interaction).

Lastly, I did create a new users and logging in / out as that user, with desktop effects set to "extra" worked just find, and gnome did not "forget" that extra had been set for this user. I believe this tells us that the problem is limited to a users home directory, but not limited to just the .config directory.

If I have some time soon (I doubt it, but who knows), I may try tackling this in reverse: create a new user *without* the problem and see what I can do to recreate the problem.

Hope this helps, and thanks for your efforts on this.

Doug

Doug Morse (dm-dougmorse) wrote :

Hi,

Correction: My previous post was intended for Leo, not Rob. My apologies.

Doug

Leo (leorolla) wrote :

Hi Doug, Thanks for helping with the tests.
It is hard to get ultimate conclusions as you have a more complex setting with awn as well. It may be related to deeper bugs in the same direction, namely lack of backward compatibility in reading user's home.
Yet for most users who had enabled desktop effects, upgraded and now don't have windows borders, it may be inside .config or at most {.config,.compiz} as Rob's post suggests.

Doug Morse (dm-dougmorse) wrote :

@Leo

Yes, correct. My apologies, I misspoke. What I should have wrote is: What we can be relatively certain of now is that, at a minimum, something within the $HOME/.config folder is implicated as the source of the problem, and at a maximum the source does not extend beyond $HOME.

I can say that I don't think that, at least in my case, it's limited to just .config and .compiz -- not long ago (albeit Karmic, not yet Lucid), I move .config, .compiz elsewhere, and also remove .cached, .gconfd, and a few other reasonable candidate cache / session type files/folders from console session (tty1) and then logged in again via gdm (tty7). No joy, still the same problems. Again, just FYI, in case it helps.

I expect that, in my and more complicated cases, the solution may simply be to create a new, empty homedir, reconfigure all GUI components again manually, and then repopulate homedir with data and carefully repopulate other dotfiles and dotdirs (i.e., one at a time or in small groups) so as not to re-introduce the "entanglement". Just not something that I have time to do right now and I am holding out hope that, once it's determined what the problem is within .config and/or .compiz, the information from that discovery might help me hunt down what's going on in my homedir. Right now, for me, the problem seems to be too much of a complex and complicated interaction.

Doug

Rob S (rsiferd2) wrote :

@Leo

I did as you said and everything seems to be working like normal.

Cheers,
Rob

Rob S (rsiferd2) wrote :

**Edit**

Like normal meaning there aren't any problems...

Leo (leorolla) wrote :

Thanks Rob.
To make sure what happened: you ran the commands from Post 34 in Bug #572617 and the problem was solved but you lost a lot of settings. Then you ran the command from Post 80 here and the problem is solved without loosing all your settings (maybe just a few about your desktop session). Is it right?
Could you then attach here the problematic folder?
cd ~ ; cd backup ; tar -czvf gnome-session.zip gnome-session
The archive will be created inside ~/backup

Leo (leorolla) wrote :

Oops...
cd ~ ; cd backup ; tar -czvf gnome-session.tar.gz gnome-session

Rob S (rsiferd2) wrote :

@Leo

Update

It has returned. I have no idea why. After last time I rebooted a couple of times and it did seem to be fixed. Today I get home and turn on my computer and it's back. Now for an even larger mystery, I logged off and on, and it went away. I checked to make sure I didn't have the workaround still in and I had it completely removed. I will attach two copies, one of it now and the previous one.

Cheers,
Rob

Rob S (rsiferd2) wrote :
Rob S (rsiferd2) wrote :

Sorry, me again.

Here it was play by play...

1) I did post #34 from Bug #572617

Result: Everything seemed fixed, but I lost a lot of settings for other programs.

2) I restored the old config folder and removed the gnome-session folder. I disabled to the workaround.

Result: It seemed fixed. I rebooted several times over the time doing various things. It seemed to work fine.

3) I turned on the computer an hour ago. I haven't installed anything new that would affect it in any way. The problem seemed to be back. I logged off and on, and it seemed fine. I checked to make sure the workaround was still disabled and it was.

Leo (leorolla) wrote :

Did you install Ubuntu updates? Has it been fixed for good after log out/in ?

Rob S (rsiferd2) wrote :

@Leo
I did update some. But I am pretty sure the only thing that was updated since was Handbrake. I'll wait on it for a few days and record when it happens. When I booted up this morning it seemed fine so maybe it was just a one time thing.

Rob S (rsiferd2) wrote :

@Leo
It has happened a second time, where logging off and on seem to fix it again.

If you log off and on, would it then be in the .xsession-errors.old?

If so, then there are a number of things going on and I'm not sure how to really debug things. I'm getting this message:

Starting gtk-window-decorator
Unable to find a synaptics device.
Initializing nautilus-gdu extension
I/O warning : failed to load external entity "/home/rob/.compiz/session/10ffdfc3255105ca9112760258277476100000011170029"

However, when I logout then on I get this message:

Starting gtk-window-decorator
I/O warning : failed to load external entity "/home/rob/.compiz/session/10431175d07a8ea0c6127602587538288900000017080029"

So I'm not exactly sure if it's related. :s

Leo (leorolla) wrote :

@Rob
Maybe it is in gnome-session+.compiz?
So you can try
mv .compiz backup ; rm -rf .config/gnome-session
from a terminal session, whithout any desktop session open.

Andras Muranyi (muranyia) wrote :

I have the same problem on Lucid amd64, and old account.

Interestingly, when i shut down the manually started compiz session, a compiz session starts like if it was there also before - but no functional compiz at startup.

Andras Muranyi (muranyia) wrote :

Well, the above only happens when i close a terminal window from where 'compiz &' was issued.
Maybe the OS is just trying to preserve my running apps? not that i have ever seen this, or closing the terminal would not kill a 'gedit &' for example.

I've tried so many things and just this seems to work well (beside to create another account login):

Invoke compiz AND metacity as a startup application.

See attachment image to view what it looks like.

d0ti5 (d0ti5) wrote :

For me, this just started up in the last couple of weeks, and I can not for the life of me see what I might have done.

I think that editing the gnome menu can cause this bug. I can break an account putting a broken file called gnome-wm.desktop in ~/.local/share/applications

Maybe this is a better way to start compiz (I can't test it right now because I'm on my mobile).
http://www.jejik.com/articles/2008/10/how_to_properly_start_compiz_in_gnome/

@André
Doesn't help.

Paul van Genderen (paulvg) wrote :

Under Ubuntu 9.10, compiz was enabled each time I ran startx. Even though I disabled it through gnome-appearance-properties. Then I upgraded to 10.04, and now I have to manually run gnome-appearance-properties and enable it each time to get a working window manager and decorations. I'd prefer the old 9.10 behaviour of enabling compiz by default but ideally the preference would be remembered between sessions.

Displaying first 40 and last 40 comments. View all 103 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments