Please sponsor gnome-session 2.26.0-0ubuntu1 in to Jaunty

Bug #344460 reported by Chris Coulson on 2009-03-17
2
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-session

gnome-session (2.26.0-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #xxxxxx):
  * debian/patches/90_no_debug_flood_by_default.patch:
    - Dropped, as debug messages are disabled by default
      upstream now.
  * debian/patches/91_upstream_change_fix_session_saving.patch:
    - Updated with latest patch from Gnome bug #552387.
    - Re-enable session saving support (disabled upstream).
  * debian/patches/98_autotools.patch:
    - New version update.

 -- Chris Coulson <email address hidden> Tue, 17 Mar 2009 18:25:40 +0000

Chris Coulson (chrisccoulson) wrote :
Changed in gnome-session (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Michael Vogt (mvo) wrote :

I just had a look over the debdiff and noticed that upstream does:

--- gnome-session-2.25.92/data/session-properties.glade 2009-03-03 17:58:01.000000000 +0100
+++ gnome-session-2.26.0/data/session-properties.glade 2009-03-16 23:26:58.000000000 +0100
@@ -306,7 +306,7 @@
                     <property name="visible">True</property>
                     <child>
                       <widget class="GtkButton" id="session_properties_save_button">
- <property name="visible">True</property>
+ <property name="visible">False</property>
                         <property name="can_focus">True</property>
                         <property name="receives_default">True</property>
                         <child>

This looks like we want to revert this change in "debian/patches/91_upstream_change_fix_session_saving.patch" ? It seems like we do not do that currently in the patch.

Chris Coulson (chrisccoulson) wrote :

Hi Michael,

I think the button was disabled because it currently doesn't do anything. From having a quick look, it seems that this button triggers the following callback in capplet/gsm-properties-dialog.c:

static void
on_save_session_clicked (GtkWidget *widget,
                         GsmPropertiesDialog *dialog)
{
        g_debug ("Session saving is not implemented yet!");
}

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.26.0-0ubuntu1

---------------
gnome-session (2.26.0-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #344460):
  * debian/patches/90_no_debug_flood_by_default.patch:
    - Dropped, as debug messages are disabled by default
      upstream now.
  * debian/patches/91_upstream_change_fix_session_saving.patch:
    - Updated with latest patch from Gnome bug #552387.
    - Re-enable session saving support (disabled upstream).
  * debian/patches/98_autotools.patch:
    - New version update.

 -- Chris Coulson <email address hidden> Tue, 17 Mar 2009 18:25:40 +0000

Changed in gnome-session:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers