Gedit blocks logout even if document is saved

Bug #272854 reported by Ernst Sjöstrand on 2008-09-21
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-session
Fix Released
Medium
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

Steps to reproduce:
Start gedit
Open a document, don't change anything
Try to log out

Result:
Gedit is blocking logout

Expected:
Gedit should not block logout

fab-furnari (fab-furnari) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I've tried to reproduce your bug but I can log out without any problem, with gedit open and a document not modified or saved.
Can you report your distribution or other useful informatons please?

Changed in gedit:
status: New → Incomplete
Ernst Sjöstrand (ernstp) wrote :

This is on intrepid, sorry! Could be reproduced by others on #ubuntu+1

Changed in gedit:
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's gnome-session and known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=553168

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in gnome-session:
status: Unknown → New
jan (jan-ubuntu-h-i-s) wrote :

Worked fine in Hardy. Please explain why the incompatible combination EggSMClient with gnome-session 2.24 was included in Intrepid in the first place, and how regression / beta tests did not catch this.
Who can move the status of http://bugzilla.gnome.org/show_bug.cgi?id=553168 beyond unconfirmed ?

Sebastien Bacher (seb128) wrote :

the issue was known but the new gnome-session is part of GNOME and upstream said they would fix issues before the stable version which they didn't

Changed in gnome-session:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is fixed to svn now

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.26.0svn20090408-0ubuntu1

---------------
gnome-session (2.26.0svn20090408-0ubuntu1) jaunty; urgency=low

  * Updated to the current svn version (lp: #257067, #272854)
  * debian/patches/91_upstream_change_fix_session_saving.patch:
    - update by Vincent Untz which should make session storing work
      on all the actions now (lp: #552387)
  * debian/patches/98_autotools.patch:
    - new version update
  * debian/rules:
    - update for manpage changes in the new version

 -- Sebastien Bacher <email address hidden> Wed, 08 Apr 2009 09:47:57 +0200

Changed in gnome-session (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-session:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.