Gnome won't Shutdown

Bug #24307 reported by ChrisDesjardins on 2005-10-20
20
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Medium
Sebastien Bacher

Bug Description

When I click log out under the Systems pull down menu and then click the
shutdown button, my computer freezes and fails to shutdown. Then I press alt +
ctl + backspace it proceeds to shutdown, sometimes or it will restart X.

Daniel Holbach (dholbach) wrote :

Thanks for your bug report. If it doesn't proceed in shutting down, could you
please try to hit Ctrl-Alt-F1, login in the console and see (with ps afxvx and
 top ) if there are any processes that are "hanging"? We had problems with
broken flash plugins and the like, so that info would help a lot.

Sebastien Bacher (seb128) wrote :

Does a standard logout or reboot work, or it hangs on the GNOME desktop and wait
for a timeout before doing the action?

ChrisDesjardins (cddesjardins) wrote :

(In reply to comment #2)
> Does a standard logout or reboot work, or it hangs on the GNOME desktop and wait
> for a timeout before doing the action?

Sometimes a standard logout, reboot, or shutdown does works. Other times it
just hangs in GNOME and never performs the requested commanded. It hangs about
half the time when I try to "logout". After I have asked it to logout it will
just hang in the GNOME window manager and not allow me to do anything. It never
exits the GUI. When this happens I usually wait several minutes then I exit X
using alt + ctrl + backspace. When I do this command it does one of two things.
 It either goes to perform the requested command or it brings me to a terminal
prompt. Of particular note regarding this bug is that it seems to happen when
my computer has been on all day. At the request of Daniel Holbach I restarted
my computer this morning and sure enough it didn't hang. But I will run Mr.
Holbach's commands next time it hangs and report back.

ChrisDesjardins (cddesjardins) wrote :

chris@ubuntu:~$ ping localhost
PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.053
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.046
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=3 ttl=64 time=0.046
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=4 ttl=64 time=0.046
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=5 ttl=64 time=0.045
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=6 ttl=64 time=0.048
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=7 ttl=64 time=0.051
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=8 ttl=64 time=0.050
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=9 ttl=64 time=0.050
ms64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=10 ttl=64 time=0.049 ms

--- localhost.localdomain ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 8998ms
rtt min/avg/max/mdev = 0.045/0.048/0.053/0.006 ms

Pinging killed by ctrl + C after 10 pings

Sebastien Bacher (seb128) wrote :

that's on a boggus logout or on a working session?

ChrisDesjardins (cddesjardins) wrote :

(In reply to comment #5)
> that's on a boggus logout or on a working session?

That's on a working session. I'll try that on a bogus logout next time it happens.

Daniel Holbach (dholbach) wrote :

*** Bug 25729 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

do you still have this issue?

Nutcracker (nutcracker) wrote :

If you're speaking to me (ex 19615) I can say "yes, I'm still having throubles".
I tried, immediately after pushing the exit button, from single user the
commands ps afxvx and top but no hanged process seems to be present.
However I'm not updating/upgrading the packages from 2 weeks because I'm without
ADLS connection and the dial-up connection is too slow.

Reinhard Tartler (siretart) wrote :

I connected via network to see the processes left running after I pressed shutdown in the gnome-panel and gnome-session is hung. I started to kill several processes and found one which immediatly makes the computer proceed to shutdown:

 5797 ? S 0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/gnome-session

After a 'kill 5797' the computer continued with shutdown as expected.

Not sure if this is related, will investigate this further.

Reinhard Tartler (siretart) wrote :

I noticed that I have a process 'x-session-manager' rather than
'gnome-session' running in my process list:
>> ps x | grep session
16346 ? Ss 0:00 x-session-manager

when gdm hangs, sending this process a SIGHUP makes my gnome session
end. Is this perhaps related?

Sebastien Bacher (seb128) wrote :

x-session-manager is an alternative and probably pointing to gnome-session

Reinhard Tartler (siretart) wrote :

I don't see this bug currently. Perhaps it was fixed in some past uploads?

I no longer have this problem, though I've upgraded to Dapper.

On Thu, 2006-02-23 at 12:58 +0000, Reinhard Tartler wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/24307
>
> Comment:
> I don't see this bug currently. Perhaps it was fixed in some past
> uploads?

Sebastien Bacher (seb128) wrote :

Closing as fixed since it works fine for everybody now. Feel free to reopen if you get the issue again

Changed in gnome-session:
status: Needs Info → Fix Released
Eetu Huisman (eh) wrote :

I have a strong feeling that I'm suffering of the same thing. At least the symptoms match. I'll try to debug it when I have the time.

Eetu Huisman (eh) wrote :

Hmm, now that I did, the problem didn't occur at all. Might be a case of some broken process hanging the whole logout...

Eetu Huisman (eh) wrote :

The "problems with broken flash plugins" part of the first message seems to apply to me as well. I'm running 32-bit flash on a 64-bit system with nspluginwrapper and it frequently crashes. When there's a zombie nsplugin.bin process, the exit dialog takes ages to show up. I'm not sure it's a gnome-session issue at all, but it is really annoying nonetheless.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.