package gnome-session-bin 3.27.91-0ubuntu1 failed to install/upgrade: installed gnome-session-bin package post-installation script subprocess returned error exit status 2

Bug #1753403 reported by dino99 on 2018-03-05
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Critical
Unassigned

Bug Description

Crash after upgrade

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: gnome-session-bin 3.27.91-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-11.12-generic 4.15.5
Uname: Linux 4.15.0-11-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
AptOrdering:
 gnome-session-common:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
Date: Mon Mar 5 09:38:29 2018
DuplicateSignature:
 package:gnome-session-bin:3.27.91-0ubuntu1
 Setting up gnome-session-bin (3.27.91-0ubuntu1) ...
 update-alternatives: error: alternative path /usr/bin/gnome-session doesn't exist
 dpkg: error processing package gnome-session-bin (--configure):
  installed gnome-session-bin package post-installation script subprocess returned error exit status 2
EcryptfsInUse: Yes
ErrorMessage: installed gnome-session-bin package post-installation script subprocess returned error exit status 2
Python3Details: /usr/bin/python3.6, Python 3.6.4+, python3-minimal, 3.6.4-1
PythonDetails: /usr/bin/python2.7, Python 2.7.14+, python-minimal, 2.7.14-4
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu1
 apt 1.6~beta1
SourcePackage: gnome-session
Title: package gnome-session-bin 3.27.91-0ubuntu1 failed to install/upgrade: installed gnome-session-bin package post-installation script subprocess returned error exit status 2
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
tags: added: block-proposed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2018-03-05
Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
importance: High → Critical
ouzo (saulius-m) wrote :

+1

dino99 (9d9) wrote :

Upgrade is fine now; thanks Jeremy

gnome-session (3.27.91-0ubuntu2) bionic; urgency=medium

  * Fix dh_install rule after switching to dh_missing (LP: #1753403)
  * Fix accidental +x permission for debian/gnome-session-bin.install

 -- Jeremy Bicha <email address hidden> Mon, 05 Mar 2018 08:06:39 -0500

tags: removed: block-proposed need-duplicate-check
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.27.91-0ubuntu2

---------------
gnome-session (3.27.91-0ubuntu2) bionic; urgency=medium

  * Fix dh_install rule after switching to dh_missing (LP: #1753403)
  * Fix accidental +x permission for debian/gnome-session-bin.install

 -- Jeremy Bicha <email address hidden> Mon, 05 Mar 2018 08:06:39 -0500

Changed in gnome-session (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers