unity-gnome-shell-migration.18.08.py crashed with signal 5 in g_object_new_valist() due to gnome-shell-extension-ubuntu-dock not installed

Bug #1720310 reported by helboof on 2017-09-29
138
This bug affects 22 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Medium
Didier Roche
Bionic
Undecided
Didier Roche

Bug Description

[Impact]

 * People having this particular setup:
   - removed ubuntu-desktop metapackage from their system
   - upgrading from 16.04 to 18.04 (or previously to 17.10) by manually editing /etc/apt/sources.lists without using do-release-upgrade (which reinstalls ubuntu-desktop).
They end up with:
- no ubuntu-dock installed
- and consequentely, the settings migration script would trigger an apport dialog (crashing) due to lack of gsettings schema.
 * Even if this is an unsupported case (people shouldn't cowboy sources.list and use our upgrader tools), we can easily prevent this crash, ignoring settings migration in such a case.

[Test Case]

 1. Install 16.04
 2. Remove ubuntu-desktop metapackage
 3. Change your sources.list from "xenial" to "bionic"
 4. apt update && apt full-upgrade
 5. Reboot and log into a new session once upgrade is done.
-> you won't get the ubuntu-dock, but the session migration script shouldn't crash.

[Regression Potential]

 * The script was crashing (even if there is no settings to migrate, so it was a no-op). We prevents gsettings to segfault by guarding for schema existence in the standard way.

------

Upgrade...

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: ubuntu-session 3.26.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.10.0-35-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 29 08:15:13 2017
ExecutablePath: /usr/share/session-migration/scripts/unity-gnome-shell-migration.18.08.py
InstallationDate: Installed on 2017-09-25 (3 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
InterpreterPath: /usr/bin/python3.6
ProcCmdline: /usr/bin/python3 /usr/share/session-migration/scripts/unity-gnome-shell-migration.18.08.py
ProcEnviron:
 LANGUAGE=ru
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
Python3Details: /usr/bin/python3.6, Python 3.6.3rc1, python3-minimal, 3.6.2-1ubuntu4
PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
Signal: 5
SourcePackage: gnome-session
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
Title: unity-gnome-shell-migration.18.08.py crashed with signal 5 in g_object_new_valist()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

helboof (helboof) wrote :

StacktraceTop:
 g_settings_set_property (object=0x20260d0, prop_id=<optimized out>, value=<optimized out>, pspec=<optimized out>) at ../../../../gio/gsettings.c:590
 object_set_property (nqueue=0x1f63420, value=<optimized out>, pspec=0x2019920, object=0x20260d0) at ../../../../gobject/gobject.c:1423
 g_object_new_internal (class=class@entry=0x20189e0, params=params@entry=0x7fffc8d5c370, n_params=n_params@entry=1) at ../../../../gobject/gobject.c:1815
 g_object_new_valist (object_type=33593824, first_property_name=<optimized out>, var_args=var_args@entry=0x7fffc8d5c4c0) at ../../../../gobject/gobject.c:2104
 g_object_new (object_type=<optimized out>, first_property_name=<optimized out>) at ../../../../gobject/gobject.c:1624

Changed in gnome-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the error is
"Settings schema 'org.gnome.shell.extensions.dash-to-dock' is not installed"

how did you upgrade? gnome-shell-extension-ubuntu-dock which includes that schemas should be installed on upgrades

summary: unity-gnome-shell-migration.18.08.py crashed with signal 5 in
- g_object_new_valist()
+ g_object_new_valist() due to gnome-shell-extension-ubuntu-dock not
+ installed
Paul (sabret00the) wrote :

In response to #7: I responded to a call to help test the transition to Gnome early in the development cycle. It was before Ubuntu Dock was even a thing.

Didier Roche (didrocks) on 2018-04-30
Changed in gnome-session (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2018-05-02
description: updated
Changed in gnome-session (Ubuntu Bionic):
status: New → Triaged
Changed in gnome-session (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-session (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)

Hello helboof, or anyone else affected,

Accepted gnome-session into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-session/3.28.1-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-session (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Dan Christensen (jdc) wrote :

I installed version 3.28.1-0ubuntu3 of gnome-session-bin gnome-session-common
and ubuntu-session from bionic-proposed, and the problem went away.

(When I upgraded from 16.04 to 18.04, do-release-upgrade stopped with an error,
so I did the rest of the upgrade manually.)

Didier Roche (didrocks) on 2018-05-07
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.28.1-0ubuntu3

---------------
gnome-session (3.28.1-0ubuntu3) bionic; urgency=medium

  * Prevent debian/unity-gnome-shell-migration.17.10.py script migration
    crash when no Ubuntu Dock or Dash to Dock installed after upgrade
    (LP: #1720310)

 -- Didier Roche <email address hidden> Wed, 02 May 2018 09:40:42 +0200

Changed in gnome-session (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-session has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.28.1-0ubuntu3

---------------
gnome-session (3.28.1-0ubuntu3) bionic; urgency=medium

  * Prevent debian/unity-gnome-shell-migration.17.10.py script migration
    crash when no Ubuntu Dock or Dash to Dock installed after upgrade
    (LP: #1720310)

 -- Didier Roche <email address hidden> Wed, 02 May 2018 09:40:42 +0200

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers