Gnome wayland session doesn't source ~/.profile

Bug #1631713 reported by Thomas Christensen on 2016-10-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Low
Unassigned
gnome-session
Fix Released
Medium
gnome-session (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
Yakkety
Low
Unassigned

Bug Description

Impact
======
Logging in with GDM3 and choosing GNOME on Wayland gives me a session where `$HOME/.profile` **hasn't** been sourced.

Where as logging on with standard GNOME gives me a session where `$HOME/.profile` **has** been sourced.

Test Case
=========
This test case assumes you haven't removed any lines from the default ~/.profile that is created for you.
mkdir ~/bin
Log out. Click your user name and choose GNOME on Wayland from the gear button and then Log in.
Open a terminal. Run
env | grep PATH

PATH will not contain /home/username/bin as the first entry

From Ubuntu GNOME, install the updated gnome-session packages
Log out. Log in to GNOME on Wayland
Open a terminal. Run
env | grep PATH

PATH will contain /home/username/bin as the first entry

When you're done testing, feel free to remove ~/bin if you haven't put any other files in that directory.

Regression Potential
====================
This update was pushed to Fedora 25, which uses Wayland by default although X is still available there.

Ubuntu GNOME still uses X by default although "GNOME on Wayland" is available as an included option in Ubuntu 16.04 and newer.

Other Info
==========
The reason this bug existed for so long was that GNOME developers would like to use a different way to let users set environment variables or whatever other common tasks used to be done by running profile scripts. However, that new way hasn't been implemented yet. Now that GNOME 3.22 uses Wayland by default (overridden currently in Ubuntu and Debian stretch), this bug has become more of a problem so developers backed down and provided this solution until the alternative is ready.

https://lwn.net/Articles/709769/

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: gnome-session-wayland 3.20.2-1ubuntu7
ProcVersionSignature: Ubuntu 4.8.0-21.23-generic 4.8.0
Uname: Linux 4.8.0-21-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Oct 9 14:52:08 2016
InstallationDate: Installed on 2013-04-11 (1277 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Alpha amd64 (20130410)
SourcePackage: gnome-session
UpgradeStatus: Upgraded to yakkety on 2016-10-02 (6 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Changed in gnome-session:
importance: Unknown → Medium
status: Unknown → In Progress
Jeremy Bicha (jbicha) on 2017-01-16
Changed in gnome-session (Ubuntu):
importance: Undecided → Low
Changed in gnome-session (Ubuntu Xenial):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-session (Ubuntu Yakkety):
importance: Undecided → Low
status: New → Triaged
Jeremy Bicha (jbicha) on 2017-01-17
description: updated
Changed in ubuntu-gnome:
status: New → In Progress
importance: Undecided → Low
Changed in gnome-session (Ubuntu):
status: Confirmed → In Progress
Changed in gnome-session:
status: In Progress → Fix Released
Jeremy Bicha (jbicha) on 2017-02-01
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package gnome-session - 3.22.2-2ubuntu1

---------------
gnome-session (3.22.2-2ubuntu1) zesty; urgency=medium

  * Merge with Debian unstable. Remaining changes:
    - debian/control.in:
      + Recommend session-migration
      + Remove gnome-shell circular dependency to ease upgrades
      + Don't suggest desktop-base
      + Move xwayland dependency to gnome-session and
        make gnome-session Arch: any
    - Split ubuntu-session out of gnome-session.
    - Add upstart user session and systemd user session:
      debian/data, debian/gnome-session-bin.user-session.upstart
    - debian/gnome-session-bin.postinst, debian/gnome-session-bin.prerm:
       Moved registering gnome-session binary as a session manager to
       gnome-session-bin package
    - Add gnome-session-wayland transitional package
    - don't install gnome-mimeapps.list (installed by desktop-file-utils in
      Ubuntu):
      debian/gnome-session-common.dirs, gnome-session-common.install,
      gnome-session-common.maintscript, gnome-session-common.postinst
    - debian/patches/revert_remove_gnome_session_properties.patch,
      debian/patches/revert_remove_gnome_session_properties2.patch:
      + Keep the session-properties applet for ubuntu sessions
    - debian/patches/13_display_session_properties.patch: Display
      session-properties as the Startup Applications capplet was removed from
      gnome-control-center, which makes it hard to discover the
      gnome-session-properties tool. (Closes: #683814)
    - debian/patches/22_support_autostart_delay.patch:
      Bugzilla patch to support adding a delay to autostart apps, using
      a "X-GNOME-Autostart-Delay" key in the desktop file
    - debian/patches/50_ubuntu_sessions.patch, debian/gnome-wayland.desktop:
      + Add Ubuntu session
      + Add --session=gnome to GNOME sessions now that the "ubuntu" session
        is the default. Use TryExec to test if gnome-shell is installed.
    - debian/patches/51_remove_session_saving_from_gui.patch:
      add GNOME_SESSION_SAVE environment variable for people wanting to
      use the save session still, knowing that it can break your system
      if used unwisely
    - debian/patches/53_add_sessionmigration.patch:
      launch session-migration if present at the start of the session. This
      sync tool runns different session migration scripts that can be
      provided in various desktop packages.
    - debian/patches/95_dbus_request_shutdown.patch: Add "RequestShutdown" and
      "RequestReboot" DBus methods to allow other applications to shutdown or
      reboot the machine via the session manager.
    - debian/patches/103_kill_the_fail_whale.patch: Kill the Fail Whale as it
      tends to be more annoying than helpful
    - debian/patches/export_env_to_upstart.patch: Update the Upstart environment
      before the plain D-Bus one. This is to work around a bug where Upstart
      brokenly forwards variables which contain an "=" to the D-Bus environment,
      resulting in invalid environment variables in the session (see bug
      #1630090).
  * Dropped patch applied in new version:
    - git_fix_gpu_cache_info.patch

gnome-session (3.22.2-...

Read more...

Changed in gnome-session (Ubuntu):
status: In Progress → Fix Released
Greg Williams (greg2lapa) wrote :

In 17.04, the Xsession doesn't source ~/.profile. It's not limited to wayland. Does anybody know a way to change the default umask in 17.04? Setting umask at ~/.profile has no effect.

Is this bug in any way related to https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/1685754

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.