Running ./unity --replace ... terminates the session and starts a new one on vivid

Bug #1449959 reported by Eleni Maria Stea on 2015-04-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
High
Iain Lane
Vivid
High
Iain Lane

Bug Description

[ Description ]

Due to an error when merging with Debian, ubuntu's gnome-session file is
inadvertantly starting compiz when it should instead be managed by
upstart. This means that we don't, for example, have unity restarted by
upstart if it crashes and (as the reporter of this bug notes) unity
--replace breaks due to gnome-session tearing the session down if one of
its required components goes away and comes back.

[ Fix ]

Remove "compiz;" from ubuntu.session so that the unity7.conf shipped by
unity is used.

[ QA ]

Verify that you see the following before upgrading

laney@raleigh> status unity7
unity7 stop/waiting
laney@raleigh> pstree -s -p $(pidof compiz)
systemd(1)───lightdm(1625)───lightdm(10651)───upstart(10864)───gnome-session(11094)───compiz(11374)─┬─{dconf worker}(11382)
                                                                                                    ├─{gdbus}(11383)
                                                                                                    └─{gmain}(11376)

i.e. compiz is a child of gnome-session, and the unity7 job isn't
running.

and this after

laney@raleigh> status unity7
unity7 start/running, process 8945
laney@raleigh> pstree -s -p $(pidof compiz)
systemd(1)───lightdm(1625)───lightdm(8487)───upstart(8715)───compiz(8945)─┬─{dconf worker}(8972)
                                                                          ├─{gdbus}(8976)
                                                                          └─{gmain}(8950)

compiz is a direct child of upstart and the unity7 job is running.

Additionally, verify that unity --replace kicks you back to the display
manager before and unity is replaced in-session after.

[ Regression potential ]

unity's job is now used instead of upstart being started by
gnome-session. This was the case since we started having upstart in the
session, but make sure that login and logout still work properly.

[ Original description ]

Running ./unity --replace <params> on vivid (systemd) exits the session
and the login screen of lightdm appears. After log in, a new session
starts.

Steps:
1- build unity
2- run ./unity --replace with the env. variables and parameters you used
   on utopic
3- see the lightdm login screen and login

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubuntu-session 3.14.0-2ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Apr 29 13:15:16 2015
InstallationDate: Installed on 2014-07-04 (299 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Eleni Maria Stea (hikiko) wrote :
Iain Lane (laney) on 2015-04-29
Changed in gnome-session (Ubuntu Vivid):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) on 2015-04-29
description: updated
description: updated
Iain Lane (laney) wrote :

Thanks. I've uploaded a fix which works for me to vivid's SRU queue. It should be accepted into vivid-proposed soon.

Changed in gnome-session (Ubuntu Vivid):
importance: Undecided → High

Hello Eleni, or anyone else affected,

Accepted gnome-session into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-session/3.14.0-2ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-session (Ubuntu Vivid):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.14.0-2ubuntu5

---------------
gnome-session (3.14.0-2ubuntu5) vivid; urgency=medium

  * In 3.14.0-2ubuntu1, RequiredComponents of ubuntu (unity)'s session file
    incorrectly gained compiz. This caused compiz to be started by
    gnome-session and not to be managed by upstart in user sessions meaning,
    for example, that it won't be restarted correctly in the event of a crash.
    (LP: #1449959)

 -- Iain Lane <email address hidden> Wed, 29 Apr 2015 12:01:55 +0100

Changed in gnome-session (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-session (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-session has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers