Ubuntu GNOME Vivid - password won't unlock screen

Bug #1425350 reported by Erick Brunzell on 2015-02-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-session (Ubuntu)
Critical
Unassigned

Bug Description

I'm testing Ubuntu GNOME Vivid 20150224 i386 and performed an encrypted LVM install which appeared to complete successfully but when I let the screen lock my password is not accepted. I repeated the test to be sure it wasn't an error on my part. To reproduce follow these steps:

(1) Install Ubuntu GNOME Vivid using any method. Be sure to choose auto-login = yes (I'm not sure that matters but at this point).

(2) Once the installation is complete boot the new system and wait +5 minutes for the screen to lock.

(3) Attempt to unlock the screen and you'll find your password is not accepted.

(4) Press Ctrl + Alt + F1 to open a TTY, enter your user name, and then your password which you'll find is accepted.

(5) Type sudo-reboot and the system reboots as expected.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: gnome-session 3.14.0-2ubuntu3
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic i686
ApportVersion: 2.16.1-0ubuntu2
Architecture: i386
CurrentDesktop: GNOME
Date: Tue Feb 24 19:46:42 2015
InstallationDate: Installed on 2015-02-25 (0 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Alpha i386 (20150224)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1425350

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

This is not limited to encrypted installs. I just did a plain manual install and got the same thing.

summary: - Ubuntu GNOME encrypted install - password won't unlock screen
+ Ubuntu GNOME Vivid - password won't unlock screen
description: updated
Erick Brunzell (lbsolost) wrote :

BTW it's not hardware related as I've done two bare metal installs on totally different hardware - one being an encrypted/LVM install and the other using manual partitioning.

Erick Brunzell (lbsolost) wrote :

Additionally if I select logout I just go to a nearly blank screen and can't even call a TTY, and if auto-login is turned off after entering the password aport tries to report a bug but it's un-reportable:

lance@lance-AMD-desktop:~$ ls /var/crash
_usr_sbin_gdm.0.crash

Erick Brunzell (lbsolost) wrote :

Additionally if I select logout I just go to a nearly blank screen and can't even call a TTY, and if auto-login is turned off after entering the password apport tries to report a bug but it's un-reportable:

lance@lance-AMD-desktop:~$ ls /var/crash
_usr_sbin_gdm.0.crash

Could bug #1421991 be related?

Erick Brunzell (lbsolost) wrote :

Oops, didn't know some content had been auto-saved.

Erick Brunzell (lbsolost) wrote :

I filed bug #1425779 as a follow up to the blank screen on logout issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Changed in gnome-session (Ubuntu):
importance: Undecided → Critical
Erick Brunzell (lbsolost) wrote :

Unlocking screen works fine if I boot using the systemd boot option from the advanced grub menu.

Tim Lunn (darkxst) on 2015-02-28
Changed in ubuntu-gnome:
milestone: none → vivid
Tim Lunn (darkxst) wrote :

Does this still happen with gdm 3.14.1-0ubuntu2?

Erick Brunzell (lbsolost) wrote :

It looks good now. I even started with a fresh install of the 20150302 amd64 image and tried every display manager test I could imagine. This also fixes bug #1425779.

If you are still experiencing this bug, please set status back to "confirmed".

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-gnome:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers