gnome-session not shutting down cleanly

Bug #1385572 reported by Tim Lunn
252
This bug affects 194 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
gnome-session (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
High
Unassigned

Bug Description

[Impact]
We have had reports going back to 13.10 that gnome-shell extensions are disabled after restart (LP: #1236749), this has probably been our #1 unresolved bug for the last few cycles. While this is the main user visible bug probably other bugs caused by this for example (BGO: #745707)

The cause was tracked down to gnome-session not shutting down cleanly under upstart. Although the underlying issue seems to be the order in which upstart takes down the various components in a user session, the side-effects themselves appear to be caused by gnome-session continuing to run when it should in fact be shutdown

The fix updates the 103_kill_the_fail_whale.patch to force shutdown of gnome-session. This is inline with the fix upstream for (BGO: #745707) also.

[ Test Case ]
Note: This is only reproducible under upstart init.
1. Load gdm
2. Login to gnome-shell using GNOME from the session list
3. enable some extensions
4. reboot system from user menu.
5. login again to find extensions disabled.

[ Regression Potential ]
Very low, the fail whale is meant to be fatal. The upstream dialog that is disabled in ubuntu does in fact cause gnome-session to get shutdown.

Revision history for this message
Tim Lunn (darkxst) wrote :
Tim Lunn (darkxst)
Changed in ubuntu-gnome:
milestone: none → utopic
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
Changed in upstart (Ubuntu):
importance: Undecided → Low
Revision history for this message
Pietro Gagliardi (andlabs/pietro10) (andlabs) wrote :

I don't know how much this comment would contribute to this bug but I can at least confirm that the behavior described here is a possible reason why this is going on, as judged by my comment to bug 1236749 here: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1236749/comments/77 Specifically, for me the bug only occurred if I rebooted cleanly, but not if I forced the machine off.

Tim Lunn (darkxst)
Changed in ubuntu-gnome:
milestone: utopic → vivid
Revision history for this message
Tim Lunn (darkxst) wrote :

we disable the fail whale dialog on ubuntu, but then just return back into the code, without telling gnome-session to die which is causing some problems. the fail whale should be fatal and the disabled dialog, would normally tell gnome-session to quit.

Revision history for this message
Tim Lunn (darkxst) wrote :

reassigning to gnome-session, although the issue seems to be triggered by upstart pulling down things in the wrong order, most of the damage seems to come from a buggy ubuntu patch in gnome-session.

affects: upstart (Ubuntu) → gnome-session (Ubuntu)
Revision history for this message
Tim Lunn (darkxst) wrote :
Revision history for this message
Tim Lunn (darkxst) wrote :
Tim Lunn (darkxst)
description: updated
description: updated
Revision history for this message
Tim Lunn (darkxst) wrote :

marking importance as High, since I have a strong suspicion this is also causing many reported black screen deadlocks, and quite possibly failed software rendering fallback under gdm.

Changed in gnome-session (Ubuntu):
importance: Low → High
Changed in ubuntu-gnome:
importance: Undecided → High
Changed in gnome-session (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-gnome:
status: New → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.14.0-2ubuntu4

---------------
gnome-session (3.14.0-2ubuntu4) vivid; urgency=medium

  [ Tim Lunn ]
  * debian/patches/103_kill_the_fail_whale.patch: fix logic gnome-session
    should die at this point. This will fix LP: #1236749,
    LP: #1385572 and possibly various other strange bugs

  [ Ryan Tandy ]
  * debian/patches/git_add_disable_acceleration_option.patch: Import upstream
    patch to add a --disable_acceleration_check command-line option.
    (LP: #1251281)
  * debian/gnome-session-bin.user-session.upstart: Disable acceleration check
    when launching a GNOME Flashback (Metacity) session.
 -- Dmitry Shachnev <email address hidden> Fri, 20 Mar 2015 09:35:59 +0300

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-session (Ubuntu Trusty):
status: New → In Progress
Changed in gnome-session (Ubuntu Utopic):
status: New → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Tim, or anyone else affected,

Accepted gnome-session into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-session/3.9.90-0ubuntu16.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-session (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-session (Ubuntu Trusty):
status: In Progress → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Tim, or anyone else affected,

Accepted gnome-session into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-session/3.9.90-0ubuntu12.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Tim Lunn (darkxst) wrote :

tested on trusty and utopic, both are working as expected and enabled extensions, stay enabled after restart.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu12.1

---------------
gnome-session (3.9.90-0ubuntu12.1) trusty; urgency=medium

  [ Tim Lunn ]
  * debian/patches/103_kill_the_fail_whale.patch: fix logic gnome-session
    should die at this point. This will fix LP: #1236749,
    LP: #1385572 and possibly various other strange bugs

  [ Ryan Tandy ]
  * debian/patches/git_add_disable_acceleration_option.patch: Backport
    upstream patch to add a --disable-acceleration-check command-line option.
    (LP: #1251281)
  * debian/gnome-session-bin.user-session.upstart: Disable acceleration check
    when launching a GNOME Flashback (Metacity) session.
 -- Dmitry Shachnev <email address hidden> Sat, 21 Mar 2015 15:49:36 +0300

Changed in gnome-session (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Update Released

The verification of the Stable Release Update for gnome-session has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu16.1

---------------
gnome-session (3.9.90-0ubuntu16.1) utopic; urgency=medium

  [ Tim Lunn ]
  * debian/patches/103_kill_the_fail_whale.patch: fix logic gnome-session
    should die at this point. This will fix LP: #1236749,
    LP: #1385572 and possibly various other strange bugs

  [ Ryan Tandy ]
  * debian/patches/git_add_disable_acceleration_option.patch: Backport
    upstream patch to add a --disable-acceleration-check command-line option.
    (LP: #1251281)
  * debian/gnome-session-bin.user-session.upstart: Disable acceleration check
    when launching a GNOME Flashback (Metacity) session.
 -- Dmitry Shachnev <email address hidden> Sat, 21 Mar 2015 15:49:36 +0300

Changed in gnome-session (Ubuntu Utopic):
status: Fix Committed → Fix Released
Tim Lunn (darkxst)
Changed in ubuntu-gnome:
status: Triaged → Fix Released
Revision history for this message
Andreas Ritter (eddie8) wrote :

Dear all, are you sure the bug is fixed? Or are there any other bugs wich lead to this behavior (extensions disabled after login)? I switched back to KDE because of this bug, but with ubuntu 15.10 I began using gnome, again. The last month, the extensions were only about once a week disabled, for now since a few days on every startup.

Ubuntu 15.10, default gnome.

Revision history for this message
kylea (kylea) wrote :

Still present in 15.10. This is definitely not fixed

Revision history for this message
Miner (assassinking) wrote :

Affects Ubuntu 16.04 setup with Dell Inspiron 3537 laptop and external HDMI monitor. Tends to happen when closing a lid and then unplugging HDMI cord.

THIS IS NOT FIXED AND IT MAKES ME PULL OUT MY HAIRS.

Revision history for this message
Miner (assassinking) wrote :

Also happens when resetting the session with "pkill -u <username>", for example when system froze, and you need to Ctrl+Alt+FX to unfreeze it.

Revision history for this message
Jerther (jerther) wrote :

Kind of late, and lost some hair too, but I found that if the extentions are enabled via "Gnome Tweak Tool", they stay on.

Revision history for this message
Justo (jtorres1825) wrote :

Hi, I run gnome 16.04 on a lenovo yoga 910 and I still get the disabled extensions after reboot and after wake from suspend. I employed this workaround "https://scognito.wordpress.com/2014/11/30/fix-gnome-shell-3-12-extensions-being-disabled-at-every-startup/", but the bug is not fixed. So far, the workaround works. Will try to disable and re-enable via gnome-tweak-tool in comment #20 and see if it solves it (without the workaround).

Thanks!

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Justo, this bug is closed. You'll need to open a new bug for whatever issue you are experiencing.

Revision history for this message
Francewhoa (francewhoa) wrote :

Done. I opened a new bug. Find new ticket at https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1697229

As you know this bug #1385572 was fixed in the package gnome-session - 3.9.90-0ubuntu16.1 per comment #15 above at https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1385572/comments/15

So this ticket #1385572 is closed. But somehow this bug is back. Maybe a regression? Maybe a zombie-bug, LOL ;)

Steps to reproduce in that new ticket at https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1697229

Revision history for this message
Steve Silvi (delta1071) wrote :

I can confirm that this bug still exists in Ubuntu 19.10 with Gnome 3.34.1. Last night, after restarting the PC to change from my Windows 10 OS to Ubuntu, all previously enabled extensions were disabled. After visiting the Gnome Extensions website and re-enabling them and then re-enabling them again in Tweaks, they are working again.

Revision history for this message
Nash (thenash) wrote :

In 10 days this bug will be 5 years old. Steve did you try the above fix by Brian, it didn't work for me a few years ago, but not so sure now as I no longer use Ubuntu, might work for you.

Revision history for this message
tellapu (tellapu) wrote :

In Ubuntu 19.10 (Gnome 3.34.1) it still happens to me, too, after I logout and login again (I use Ubuntu Desktop not the Gnome desktop). Thanks for working on this.

Revision history for this message
Tiago (tscolari) wrote :

I saw this was marked as fixed but it's still happening on Ubuntu 18.04 and GNOME 3.28.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers