gnome-classic sessions broken with upstart user sessions

Bug #1381297 reported by Tim Lunn on 2014-10-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Undecided
Unassigned

Bug Description

As of GNOME 3.12 gnome-classic session is selected by setting a GNOME_SHELL_SESSION_MODE environment variable. upstream this is set in the gnome-session desktop file, however when using upstart user sessions this file gets bypassed and hence the gnome-classic session just loads a standard gnome-shell session.

We need to make sure this variable is set in the upstart user session as well

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: gnome-session 3.9.90-0ubuntu15
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Uname: Linux 3.16.0-22-generic x86_64
ApportVersion: 2.14.7-0ubuntu6
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Oct 15 13:16:56 2014
InstallationDate: Installed on 2014-06-27 (110 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tim Lunn (darkxst) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu16

---------------
gnome-session (3.9.90-0ubuntu16) utopic; urgency=medium

  * set GNOME_SHELL_SESSION_MODE for gnome-classic sessions (LP: #1381297)
 -- Tim Lunn <email address hidden> Wed, 15 Oct 2014 11:18:08 +0100

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers