gnome-session crashed with SIGSEGV in g_object_unref()

Bug #1196163 reported by Mar-castelluccio on 2013-06-30
278
This bug affects 45 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Medium
Unassigned

Bug Description

Right after startup. Also the date applet crashed.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-session-bin 3.8.2.1-1ubuntu4
ProcVersionSignature: Ubuntu 3.10.0-0.7-generic 3.10.0-rc7
Uname: Linux 3.10.0-0-generic x86_64
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
Date: Sat Jun 29 20:56:52 2013
ExecutablePath: /usr/bin/gnome-session
InstallationDate: Installed on 2012-03-30 (456 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
MarkForUpload: True
ProcCmdline: gnome-session --session=ubuntu
SegvAnalysis:
 Segfault happened at: 0x7f438c697b04 <g_object_unref+20>: cmpq $0x50,(%rax)
 PC (0x7f438c697b04) ok
 source "$0x50" ok
 destination "(%rax)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: gnome-session
StacktraceTop:
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? ()
 ?? ()
 dbus_connection_dispatch () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /usr/lib/x86_64-linux-gnu/libdbus-glib-1.so.2
Title: gnome-session crashed with SIGSEGV in g_object_unref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

StacktraceTop:
 g_object_unref (_object=0x12cae20) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:3086
 gsm_shell_disconnect_from_bus (shell=shell@entry=0x7f4378004740) at gsm-shell.c:346
 gsm_shell_bus_filter (connection=<optimized out>, message=0x1231360, user_data=<optimized out>) at gsm-shell.c:216
 dbus_connection_dispatch () from /tmp/apport_sandbox_F8KnIp/lib/x86_64-linux-gnu/libdbus-1.so.3
 message_queue_dispatch (source=source@entry=0x12659f0, callback=<optimized out>, user_data=<optimized out>) at dbus-gmain.c:90

Changed in gnome-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
information type: Private → Public
jimjutte (jimjutte) wrote :

This error occurred after what appeared to be skype hanging. It became unresponsive. I closed everything else down, still unresponsive, rebooted the machine and this error showed up.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu3

---------------
gnome-session (3.9.90-0ubuntu3) saucy; urgency=low

  * debian/patches/git_fix_wrong_unref_call.patch:
    - backport fix from git, don't unref the wrong object (lp: #1196163)
 -- Sebastien Bacher <email address hidden> Fri, 11 Oct 2013 15:45:25 +0200

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers