gnome-session crashed with SIGSEGV in gsm_autostart_app_restart()

Bug #1193730 reported by Cristian Aravena Romero on 2013-06-23
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
High
Unassigned

Bug Description

I'm working and crash.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-session-bin 3.8.2.1-1ubuntu2
ProcVersionSignature: Ubuntu 3.9.0-7.15-generic 3.9.7
Uname: Linux 3.9.0-7-generic x86_64
ApportVersion: 2.10.2-0ubuntu2
Architecture: amd64
Date: Sat Jun 22 21:34:02 2013
ExecutablePath: /usr/bin/gnome-session
InstallationDate: Installed on 2013-06-21 (1 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130621)
MarkForUpload: True
ProcCmdline: gnome-session --session=gnome
SegvAnalysis:
 Segfault happened at: 0x40c5e9: mov 0x8(%rax),%rcx
 PC (0x0040c5e9) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-session
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 g_cclosure_marshal_VOID(int0_t, void) () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-session crashed with SIGSEGV in g_cclosure_marshal_VOID()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 gsm_autostart_app_restart (app=0x1bff8d0, error=0x7fff44727108) at gsm-autostart-app.c:1199
 gsm_app_restart (app=app@entry=0x1bff8d0, error=error@entry=0x7fff44727108) at gsm-app.c:453
 _restart_app (manager=0x1bec100, app=0x1bff8d0) at gsm-manager.c:609
 ?? ()
 ?? ()

Changed in gnome-session (Ubuntu):
importance: Undecided → Medium
summary: - gnome-session crashed with SIGSEGV in g_cclosure_marshal_VOID()
+ gnome-session crashed with SIGSEGV in gsm_autostart_app_restart()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
information type: Private → Public
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I just uploaded an update fixing that issue

Changed in gnome-session (Ubuntu):
importance: Medium → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.8.2.1-1ubuntu4

---------------
gnome-session (3.8.2.1-1ubuntu4) saucy; urgency=low

  * debian/patches/22_support_autostart_delay.patch:
    - don't segfault when an autostarted desktop hits an error (lp: #1193730)
 -- Sebastien Bacher <email address hidden> Tue, 25 Jun 2013 17:07:05 +0200

Changed in gnome-session (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers