Update gnome-session to 3.8

Bug #1185873 reported by Jeremy Bicha on 2013-05-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Wishlist
Unassigned

Bug Description

gnome-session should be updated to 3.8 in Saucy so that the new GNOME Classic mode (provided by gnome-shell and gnome-shell-extensions) will work.

- RequiredProvider and DefaultProvider sections have been dropped, now only RequiredComponents is used
- The fallback session has been dropped with the .session files being picked up by gnome-panel (we just need to backport the commit from master).
- For other changes see https://git.gnome.org/browse/gnome-session/tree/NEWS?h=gnome-3-8

This will therefore require a small transition involving gnome-session and gnome-panel.

I think we'll be moving the gnome-session-fallback binary to the gnome-panel source package. On the other hand, we could just have gnome-panel Provide gnome-session-fallback and drop the separate binary.

Sebastien Bacher (seb128) wrote :

Thanks, I looked a bit at this one yesterday and I've some comments:

- the package in the ppa has the support for autostart delay disabled, that needs to be restore

- somebody should check that the suspend and lock screen inhibitor still work, under GNOME and unity

- the support of login to journald seems to be included in the systemd build option, we want to use logind but not journald, that might need patching

please get that update in the desktop team ppa for testing before uploading to the archive

Changed in gnome-session (Ubuntu):
importance: Undecided → Wishlist
tags: added: upgrade-software-version
Changed in gnome-session (Ubuntu):
status: New → Confirmed
Tim Lunn (darkxst) wrote :

1. re-enabled autostart patch in package on gnome3-staging

2. I suspect this won't be an issue until/if we land g-s-d 3.8 (still should be tested though.

3. I think the journald stuff is harmless and can stay as is, for now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.8.2.1-1ubuntu2

---------------
gnome-session (3.8.2.1-1ubuntu2) saucy; urgency=low

  [ Tim Lunn ]
  * 22_support_autostart_delay.patch:
    - Refreshed and re-enabled

  [ Jeremy Bicha ]
  * Restore gnome-session.postinst, accidentally left out of previous
    upload
 -- Tim Lunn <email address hidden> Thu, 20 Jun 2013 11:31:00 +1000

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers