enable gnome-shell to run with software rendering (llvmpipe)

Bug #1047828 reported by Tim Lunn on 2012-09-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Undecided
Unassigned

Bug Description

fedora 17/18 have gnome-shell running with software rendering (llvmpipe). On Ubuntu gnome-shell will only run when hardware 3D is available.

This would be particularly useful for the ubuntu gnome live CD's

llvmpipe is currently blacklisted in gnome-session hardware-compatibility.
/usr/share/gnome-session/hardware-compatibility

Removing the blacklisting, is enough to get both gdm and gnome-shell running with llvmpipe (no fallback mode!). I have tested this in a VM and performance seems ok, definitely useable. It is atleast as fast as the equivalent Unity session, if not a little faster.

Tim Lunn (darkxst) wrote :

This is about all I could find on the fedora implementation. At the very least need to remove llvmpipe from blacklist in gnome-session.

https://fedoraproject.org/wiki/Features/Gnome_shell_software_rendering

There is talk on that page of virtual GEM kernel drivers and modifications to Mesa/X, however its not really clear if any of that has been done.

Tim Lunn (darkxst) wrote :

I have tested gnome-shell running with llvmpipe (in a vmware VM) and it seems to work quite well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed

The attachment "remove llvmipe blacklisting from gnome-session" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tim Lunn (darkxst) on 2012-09-08
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.5.91-0ubuntu1

---------------
gnome-session (3.5.91-0ubuntu1) quantal; urgency=low

  * New upstream translation update release.
  * 97_dont_blacklist_llvmpipe.patch:
    Patch from Fedora to not blacklist llvmpipe from GNOME sessions
    (LP: #1047828) Thanks Tim!
 -- Jeremy Bicha <email address hidden> Sun, 09 Sep 2012 14:20:35 -0400

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2012-09-09
no longer affects: gnome-shell (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers