First screenshot saved sticks for duration of session

Bug #1393188 reported by Rowan Berkeley on 2014-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-screenshot (Ubuntu)
Undecided
Unassigned

Bug Description

This is new since I upgraded to 14.10, about 60 hours ago. Tested through four sessions. Not affected by any action in destination folder (eg, deleting any existing screenshot files there). Not affected by whether screenshot application or print screen button is used; not affected by whether screenshot is whole screen, desktop or selected area. The whole screen of the first attempt of the session is saved somewhere (I don't know where), and cannot be overwritten for the rest of the session, so new screenshots cannot be made without restarting. If I attempt a selected area of a new screen, I get the corresponding selected area of the first screen of the session, the one which cannot be overwritten. So - the screenshot application is working correctly, except that the first screen saved is being retained throughout the session and cannot be overwritten. And this is completely new since my upgrade to 14.10.

PS: I have tried the application "Shutter", which performs all screenshot functions in a more elaborate way, and I get the same result, therefore both the basic "gnome-screenshot" and "Shutter" use the same, so to say, image scratchpad to store their screenshots, and for both of them, once written to, this image scratchpad cannot be cleared for new images for the duration of the session thereafter.

PPS: I see this is comparable to bug #1103847. I do have fglrx, just as in that bug situation. But I am not getting an error report in the terminal, as is reported there.

PPPS: Using Synaptic, I completely removed fglrx (this means in fact fglrx-core 2:14.201-0ububtu2, because this is what was installed by default; the full version of fglrx is not installed by default, and was not present). But problem is persisting. Terminal still does not report any error, so symptomatology is still different to that reported in bug #1103847.

description: updated
description: updated
description: updated
Rowan Berkeley (rowan-berkeley) wrote :

I've received no response to this since I filed it three weeks ago. The fault remains, as I specified it, but I have noticed one curious detail: wherever the image scratchpad for screenshots may be, it is in fact large enough to hold not just one but two distinct screenshots before it is full. So in fact there are two images saved. Once these two images have been collected, the scratchpad is full and cannot altered for the remainder of the session. The two saved screenshots alternate apparently randomly no matter how many attempts are made to capture new screenshots. There is no way known to me that they can be erased so that new screenshots may be made and saved, until the entire system is restarted.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers