gnome-screensaver 3.2.0-0ubuntu1 failed to exit

Bug #882893 reported by david6 on 2011-10-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Undecided
Unassigned

Bug Description

On older PC (Intel P4 2.8GHz, 1GB RAM), I am seeing this lockup with default settings.

Ubuntu 11.10, Unity-2D, latest patch/updates loaded.

Occurs when I wait for timeout, and screen blanks. Does NOT occur when select screen-lock (from GUI, or keyboard)

I have now two separate PCs, with identical results.

Note: login screen (lightdm) is not susceptible to this issue.

david6 (andrew-dowden) wrote :

This may be similar to, or a recurrence of, Bug #778953 .

david6 (andrew-dowden) wrote :

This can be defeated once, by pressing 'shift' key to wakeup.

This works once (after boot time), and does NOT work a second time (after subsequent timeout).

When PC is in lockout state, only power-off is possible. I have loaded SSH server, and machine is also non-responsive to connect attempt (over SSH).

tags: added: 11.10 screensaver ui unity-2d
david6 (andrew-dowden) wrote :

This could be an issue with the Intel 82865G integrated graphics driver.

I have tried the older Intel 2.4 Driver.

RevertingIntelDriverTo2.4
https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4

( Does NOT work, missing details and valid PPA sources .. )

Instead I used:

Downgraded versions of X.org drivers, libraries, etc. for Ubuntu.
https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-retro

Click on: 'View package details'

Click on: 'xserver-xorg-video-intel-2.4 - 2:2.4.1-1ubuntu11~ppa1' (near bottom)

Download:
https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-retro/+files/xserver-xorg-video-intel-2.4_2.4.1-1ubuntu11%7Eppa1_i386.deb

Then installed using:

   Ctrl-Alt-F1, for text login

  cd Downloads/ (location of .deb file)

  sudo dpkg -i xserver-xorg-video-intel-2.4_2.4.1-1ubuntu11~ppa1_i386.deb
  (enter password)

  sudo apt-get -f install

(re-start PC)

THIS DID NOT APPEAR TO FIX PROBLEM.

david6 (andrew-dowden) wrote :

This may or may not be related to: Bug #727594

david6 (andrew-dowden) wrote :

Previously noted, for Ubuntu 9.10 (Karmic)

http://ubuntuforums.org/showpost.php?p=10279527

david6 (andrew-dowden) wrote :

WORK AROUND (remove the package)

~: [b] sudo apt-get remove gnome-screensaver[/]

~: [b]sudo apt-get install xscreensaver xscreensaver-gl-extra xscreensaver-data-extra[/b]

After installing, go to ‘Control –> Startup Applications’

Then click ‘Add’ and type the entry below:

Name: Xscreensaver
Command: xscreensaver –nosplash

Finally click ‘Add’

When finish, open ‘Dash’ and search for xscreensaver. Open it and customize it.

Anders Hall (kallebolle) wrote :

Can confirm this exact behavior on lenovo x201

david6 (andrew-dowden) wrote :

Andres, please update 'bug affects you'. Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
Anders Hall (kallebolle) wrote :

Another "workaround" for this issue is to be "very patient and hit enter a few times while the screen is frozen". After a while (minutes) the password screen appears.

I've seen this happen to another guy in the office and he makes a hard reboot every time (figures it is a complete freeze)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers