Who cares about num lock?

Bug #877456 reported by Aren Cambre on 2011-10-18
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Wishlist
Unassigned

Bug Description

The gnome screensaver is the only application I have ever used, ever, that thinks that num lock being on is something I should be warned about when entering a password.

This seems pointless as people generally do not change num lock during computer use, or if they do, it's not to the frequency of using caps lock.

Further, numlock being off, which appears to be the preferred state because that removes the warning, is an old-school habit, increasingly unusual.

Please remove this warning. It is warning against the normative state, and it doesn't provide useful information. It's just screen clutter.

Robert Roth (evfool) on 2011-10-18
Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
Julian Taylor (jtaylor) wrote :

I agree, I think I never used a computer where numlock was off by default.

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Wishlist
Aren Cambre (aren-arencambre) wrote :

Junking the numlock warning would solve #835649 and #841541, too.

Michael Wild (themiwi) wrote :

I agree, I *never* use the numpad for its cursor keys. It's a numpad after all. And seeing that warning I always first think capslock is on.

BTW: Now it seems that also lightDM, ssh-add and gpg-agent seem to be affected by this, which becomes really annoying (but also possibly simpler to fix, since it appears that this is a GTK+ issue rather than an issue of the individual applications).

Lachezar Dobrev (lachezar) wrote :

WRONG!
On Laptop computers NumLock changes letters into digits!
It is just as bad, as having CapsLock turned on.

Aren Cambre (aren-arencambre) wrote :

How many laptops really have that? My ancient Lenovo X60 tablet has that feature, but my much newer HP Envy 14 doesn't.

Even then, how often do people really turn on num lock?

I'm concerned this warning is only for a tiny fraction of users--laptop users whose laptops still have that feature _and_ who actually use num lock.

Lachezar Dobrev (lachezar) wrote :

All the IBM, Lenovo and Toshiba laptops I've seen.
I am curious... This HP laptop seems to have no numeric keypad. What DOES the NumLock do?

The problem is not whether I USE num-lock, but if I accidentally turn it on, I'm in trouble.

mycae (mycae) wrote :

This affects my system - and I have numkeys on the letters.

This needs to not be a warning, but a much less obtrusive notice -- its confusing to be warned about something that is normal, and often innocuous.

Aren Cambre (aren-arencambre) wrote :

Has anyone ever opened a bug report on any app, ever, and it ended up that they couldn't log in because their num lock key was on?

I'll bet the answer is either 0 or close to 0.

I feel we're stuck on a hypothetical that virtually never happens.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 3.2.0-1ubuntu8

---------------
gnome-screensaver (3.2.0-1ubuntu8) precise; urgency=low

  * debian/patches/22_dont_show_numlock_warning.patch: Don't show a warning
    for the numlock key, as some hardware tracks numlock status
    differently. (LP: #841541, LP: #877456, LP: #835649)
  * debian/patches/21_properly_lock_when_activated.patch: Updated with
    final upstream commit.
 -- Marc Deslauriers <email address hidden> Sun, 05 Feb 2012 17:15:02 -0500

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers