unlocking dialog doesn't show

Bug #712103 reported by Ralf Hildebrandt
58
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: gnome-screensaver

In natty, the screensaver unlock dialog doesn't come up. Yet it DOES work (it does unlock the screen) but only if you type in the password blind, press enter and switch to the console and back to X11. If you don't switch back and forth between X and the console, the screensaver output stays on screen.

In some cases, the screen will re-lock itself after the switch.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-screensaver 2.30.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Wed Feb 2 21:20:30 2011
GconfGnomeSession:
 idle_delay = 3
  /desktop/gnome/session/required_components:
   windowmanager = metacity
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=de_DE.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-screensaver
WindowManager: metacity

Revision history for this message
Ralf Hildebrandt (ralf-hildebrandt) wrote :
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

I think this was a compiz layering bug that got fixed. Are you still able to reproduce this on an up-to-date natty?

Changed in gnome-screensaver (Ubuntu):
status: New → Incomplete
Revision history for this message
Espen Arnesen (espen77) wrote :

I have almost the same problem, but for me it don't help to switch to console and back to x.
After i have written the password i can see the mousepointer changing when i move it across the screen, depending on what is suppose to be showing (link in firefox, text input, etc), but the screen stays all black except the mouse pointer. This started a couple of days ago, and happens about half the times the screensaver comes on. I have to reboot when this happens.
My system is natty a2 i386 thinkpad x200t, last updated 20.02.2011.

Revision history for this message
Ralf Hildebrandt (ralf-hildebrandt) wrote :

Right now I have the same problem as Espen. It doen't help to switch to console and back to x.
I have to go to the console and kill the screensaver-gnome process.

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → New
Revision history for this message
Victor Jimenez (betabandido) wrote :

I also have the same problem as Espen. If the monitor goes to standby mode, when I want to use again the computer the password dialog does not appear. However, it is there since I can enter the password and after doing that, I have access to the computer (the screen is completely black, but I can close music program by pressing alt+F4, for instance). I also notice how the mouse icon changes depending on whether I am on a browser link, etc.

Killing gnome-screensaver from the console does not help for me. I need to restart gdm, so it is quite annoying.

I am using Ubuntu 11.04 with the latest upgrades applied (I am using only official repositories from Ubuntu).

Revision history for this message
Josh Nurczyk (methuseus) wrote :

I have almost the exact same issue as Victor Jimenez. Killing screensaver-gnome does not help, but the cursor does not change depending on where it is on the screen. I don't know if entering the password works or not. to be honest.

Revision history for this message
Boris Baelen (sjimmie) wrote :

I have EXACTLY the same problem as Espen.

Started after I upgraded to Natty.

BTW I'm _not_ using Unity but the Classic Ubuntu.

IS this the first bug logged for this or might there be a duplicate?

Revision history for this message
Alejandro R. Mosteo (mosteo) wrote :

Same as #5, but haven't yet tried to kill processes, I had always used the sudo service gdm restart route.

Also 11.04 up to date with classic desktop, random screensaver and monitor suspend.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

I experience this in precise, but only when running a unity session, and also not really reliably on two (sandy-bridge) systems.

One system is a desktop PC running a radeon 6670 graphics card. There, I experienced this each time when resuming after suspending the machine reliably. Switching from unity to gnome3 seems to help.

The other system is a laptop that was recently upgraded to precise. I have added a session item that locks the screen when logging in (because the system is configured to auto-login). Here, the described symptom happens already at login time.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers