gnome-screensaver crashed with SIGSEGV in gs_manager_set_active()

Bug #558721 reported by Kayvan Sylvan on 2010-04-08
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Expired
Medium
gnome-screensaver (Ubuntu)
Medium
Chris Coulson
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: gnome-screensaver

I clicked on the Power-button->"Lock screen" choice and was able to reproduce the crash each time.

This host is a KVM guest.

kayvan@ksub10beta:~$ uname -a
Linux ksub10beta 2.6.32-19-generic #28-Ubuntu SMP Thu Apr 1 10:39:41 UTC 2010 x86_64 GNU/Linux

kayvan@ksub10beta:~$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
kayvan@ksub10beta:~$

kayvan@ksub10beta:~$ apt-cache policy gnome-screensaver
gnome-screensaver:
  Installed: 2.30.0-0ubuntu1
  Candidate: 2.30.0-0ubuntu1
  Version table:
 *** 2.30.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: gnome-screensaver 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
Date: Thu Apr 8 13:49:16 2010
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/gnome-screensaver
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcCmdline: gnome-screensaver
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: gnome-screensaver
StacktraceTop:
 ?? ()
 ?? ()
 gs_manager_set_active ()
 ?? ()
 gs_marshal_BOOLEAN__BOOLEAN ()
Title: gnome-screensaver crashed with SIGSEGV in gs_manager_set_active()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WindowManager: gnome-wm

Kayvan Sylvan (kayvan) wrote :

StacktraceTop:
 ?? ()
 gs_fade_start (fade=0x224f400, timeout=1000)
 gs_manager_set_active (manager=0x220ba80,
 listener_active_changed_cb (
 gs_marshal_BOOLEAN__BOOLEAN (closure=0x2260bc0,

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Jens Maus (jens.maus) wrote :

I also get the same kind of crashes of gnome-screenaver daemon as soon as "gnome-screensaver-command -a" is used. Please note, however, that this happens with a remote X connection to a Sunray. But the stacktrace looks quite similar. I Have started "/usr/bin/gnome-screenaver" with the option "--no-daemon" and then when issuing the "/usr/bin/gnome-screensaver-command -a" command to activate the screensaver the daemon immediately exists with a Segfault. Here is the stacktrace:

-- cut here --
Starting program: /usr/bin/gnome-screensaver --no-daemon
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
(gdb) bt
#0 0x0000000000000000 in ?? ()
#1 0x000000000041c6e9 in ?? ()
#2 0x0000000000411ed9 in gs_manager_set_active ()
#3 0x000000000040c028 in ?? ()
#4 0x000000000041d712 in gs_marshal_BOOLEAN__BOOLEAN ()
#5 0x00007ffff4c9b5de in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#6 0x00007ffff4caf598 in ?? () from /usr/lib/libgobject-2.0.so.0
#7 0x00007ffff4cb08b9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#8 0x00007ffff4cb1033 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#9 0x000000000040e702 in gs_listener_set_active ()
#10 0x000000000040f9ea in ?? ()
#11 0x000000000040ff3c in ?? ()
#12 0x0000000000410482 in ?? ()
#13 0x00007ffff798c3a6 in dbus_connection_dispatch () from /lib/libdbus-1.so.3
#14 0x00007ffff7bc4e45 in ?? () from /usr/lib/libdbus-glib-1.so.2
#15 0x00007ffff41c88c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#16 0x00007ffff41cc748 in ?? () from /lib/libglib-2.0.so.0
#17 0x00007ffff41ccc55 in g_main_loop_run () from /lib/libglib-2.0.so.0
#18 0x00007ffff6e11af7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x000000000040b893 in main ()
-- cut here --

dmesg also outputs the following segfault information:

-- cut here --
gnome-screensav[13614]: segfault at 0 ip (null) sp 00007fffb654b4c8 error 14 in gnome-screensaver[400000+27000]
-- cut here --

Here some information on the system:

Description: Ubuntu 10.04 LTS
Release: 10.04

gnome-screensaver:
  Installed: 2.30.0-0ubuntu1
  Candidate: 2.30.0-0ubuntu1
  Version table:
 *** 2.30.0-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Linux titan 2.6.32-21-server #32-Ubuntu SMP Fri Apr 16 09:17:34 UTC 2010 x86_64 GNU/Linux

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Could you please run "killall gnome-screensaver && gnome-screensaver --no-daemon --debug 2>&1 | tee ~/gnome-screensaver.log", recreate the crash and then attach the log file here. I have a suspicion about what is happening here, but the log file will confirm it for me.

Thanks

Changed in gnome-screensaver (Ubuntu):
status: New → Incomplete
Jens Maus (jens.maus) wrote :

Thanks for you fast reply. Please find attached the cathed debug log when gnome-screensaver crashes when issuing a "gnome-screensaver-command -a". Would be great to get that fixed ASAP as this seems to be the only issue that is currently holding back us from deploying ubuntu 10.04 to our main servers. ;)

Chris Coulson (chrisccoulson) wrote :

[gs_fade_init] gs-fade.c:906 (13:32:47): Fade type: 0

Ok, I think I see what happens here then

Thanks

Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Incomplete → Triaged
Jens Maus (jens.maus) wrote :

Ok. let me know if you have some intermediate debug version I could test and see if the issue is fixed. Would love to test that here.
Thanks

Changed in gnome-screensaver (Ubuntu):
status: Triaged → In Progress
tags: added: regression-release
Changed in gnome-screensaver:
status: Unknown → New

Accepted gnome-screensaver into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-screensaver (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Filip Palm (filip) wrote :

Colin,
This fix works like a charm.

Thanks.

Jens Maus (jens.maus) wrote :

Here the same. The fix works as expected.
regards

tags: added: verification-done
removed: verification-needed
crash (crash369) on 2010-05-25
Changed in gnome-screensaver (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 2.30.0-0ubuntu2

---------------
gnome-screensaver (2.30.0-0ubuntu2) lucid-proposed; urgency=low

  * debian/patches/15_dont_crash_on_no_fade.patch:
    - Don't crash on systems that don't support XF86VM or XRANDR gamma fade,
      by testing if fade is supported on a particular screen before
      calling the fade_setup and fade_finish virtual functions (LP: #558721)
  * debian/patches/16_dont_crash_in_kvm.patch:
    - Don't crash when the XF86VM extension doesn't allow the gamma
      to be set (LP: #581864)
  * debian/patches/14_no_fade_on_user_switch.patch:
    - Disable fade on locking to work around LP: #546578 and prevent
      the screen remaining blank after user switching. The screensaver
      will still fade-in on idle though
 -- Chris Coulson <email address hidden> Wed, 19 May 2010 11:51:40 +0100

Changed in gnome-screensaver (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick, too.

Changed in gnome-screensaver (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-screensaver:
status: New → Fix Released
Changed in gnome-screensaver:
importance: Unknown → Medium
Changed in gnome-screensaver:
status: Fix Released → New
Changed in gnome-screensaver:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.