Random screensaver is always the same one

Bug #53575 reported by shanen (Shannon Jacobs) on 2006-07-21
8
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Fix Released
Low
Nominated for Trunk by Jessie Lawrence
gnome-screensaver (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Since upgrading to the Dapper Drake, the random screen saver feature has always been locked on one specific screensaver, the one called Xylap.

(Actually, I'd rather remove all of the screen savers and just use a power saver, but I haven't gotten to that level yet... It seems that the screen savers are bundled with the desktop, and I've already destroyed one machine by tampering with that. (I managed to mostly fix it, but that was quite a learning experience and a half.))

Matt Thompson (mattthompson) wrote :

I'll confirm this, but it is only in the gnome-screensaver-preferences for me.

Changed in gnome-screensaver:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Do you still get the bug?

Changed in gnome-screensaver:
importance: Undecided → Low

I don't think so, but it's so old I can't really recall. I'm running
Ubuntu on a number of machines.

--- Sebastien Bacher <email address hidden> wrote:

> Do you still get the bug?
>
> ** Changed in: gnome-screensaver (Ubuntu)
> Importance: Undecided => Low
>
> --
> Random screensaver is always the same one
> https://bugs.launchpad.net/bugs/53575
> You received this bug notification because you are a direct
> subscriber
> of the bug.
>

--------------------------------------
Big Chance to Win 50,000 Yahoo! Points!
http://pr.mail.yahoo.co.jp/nlcp/

This is still a problem in Gutsy for me.

Ricardo (ricardobdasilva) wrote :

It is there in hardy for me too. Is there a way to include the other screensavers in the Random pick list?

I've been meaning to look into it for ages, but I've never got round to it.

look, this is a really ugly bug, and its been around for years, why the heck wasnt it fixed by now if people knew about it since 2 years ago, possibly longer?!!

look, with obvious bugs like this, it discourages people from using ubuntu, cause they think its flaud when they boot it up and they can immediately see these.

someone PLEASE FINALLY PUT AN END TO THIS BUG!!! it seems like it could be so easy to fix, to! this is ridiculous!

Developers only fix bugs they think are important. This one is pretty pathetic really. I'm sure otther OSes have unfixed flaws much worse than this.

If it's easy to fix, do it yourself. That's the beauty of having the source.

Strangely, no-one ever thought that reporting this upstream would be a good idea.

Changed in gnome-screensaver:
status: Unknown → New

well, i would, but i havent programmed in a while, and although i do plan to get back into it for the porpose of helping with ubuntu, im not a programmer as of now, so, in the meantime, ill just report bugs. hopefully, i will be programming soon.

btw, bruce, r u a programmer? i would much appreciate it if u fixed it.

Yes, but I can't make head nor tail of gnome-screensaver. I'll try at some point in the future though.

Changed in gnome-screensaver:
assignee: nobody → desktop-bugs
status: Confirmed → Triaged

why wasnt this fixed yet in gnome 2.24?????

this is a gnome bug, not specific to ubuntu. also, its not specific to xylap either. when selecting random screensaver, it always selects the very last one, whichever it may be. it just so happens to be xylap as the last one, and so it picks xylap every time. so, it's an extremely simple problem, it might have even been caused by a typo when writing the code

Changed in gnome-screensaver:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in gnome-screensaver:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 2.27.0-0ubuntu1

---------------
gnome-screensaver (2.27.0-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #345107)
    - Add an autostart file for gnome-screensaver (#585485)
    - Updated Translations
    - Fixed audit GError usage (William Jon McCann)
    - Fixed use g_strerror (William Jon McCann)
    - Fixed logout_command setting may be overwritten with
      keyboard_command value (William Jon McCann)
    - Fixed gnome-screensaver-gl-helper calls gdk_x11_visual_get_xvisual
      with NULL visual (William Jon McCann)
    - Fixed Screenserver (William Jon McCann)
    - Remove power notice signal
    - Rely on GNOME session idle detection
    - Proxy g-s inhibitors over to the session
    - Read status message from session
    - Accept a full path for theme (Matthias Clasen)
    - Fix pixmap leak (Matthias Clasen)
    - Fix dialog border width
    - Add bevel around dialog
    - get idle time from xorg (LP: #230749)
    - screensavers-personal-slideshow should not show hidden directories (Jörg)
    - "Random" preview is always the last saver (Maxim Ermilov) (LP: #53575)
    - Calls wrong slideshow binary if there is one installed in
      $PATH (Frederic Crozat)
    - libgnome-desktop:gnome_bg_create_pixmap() leaks pixmaps and X
      clients (Scott Remnant)
    - Preview of "Blank screen" is not consistent (Neil Patel) (LP: #105836)
    - Add GTK and GNOME to screensaver desktop (William Jon McCann)
    - Screensaver suddenly stopped working (William Jon McCann)
    - gnome-screensaver-dialog NULL pointer crash (William Jon McCann)
    - gnome-screensaver should release mouse/keyboard when failed to grab both of
      them (Joey Yu Zheng)
    - Cleaning up GTK Includes in gnome-screensaver (Maxim Ermilov)
  * debian/control.in:
    - add Vcs-Bzr tag
    - re-generate debian/control
  * Adapt debian/watch to get unstable version
  * debian/patches:
    - remove 06_dont-leak-root-windows.patch and
      07_fix_blank_screen_preview.patch as applied upstream
    - removed 08_watch-all-X-screens-when-detecting-idle.patch as upstream
      handled the issue in rewriting src/gs-watcher-x11.c (multiple X handling)

 -- Didier Roche <email address hidden> Tue, 16 Jun 2009 10:59:32 +0200

Changed in gnome-screensaver (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-screensaver:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.