Screensaver blocks Fn+F4 to suspend

Bug #535491 reported by Max Bowsher on 2010-03-10
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Debian)
New
Undecided
Unassigned
gnome-screensaver (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-screensaver

In karmic and early lucid, pressing Fn+F4 "suspend" whilst the screen was locked worked to suspend the computer.

It has stopped working in current lucid, and it is now necessary to unlock the screen in order to suspend the computer.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 10 03:23:44 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
Package: gnome-screensaver 2.29.91-0ubuntu3
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: gnome-screensaver
Uname: Linux 2.6.32-16-generic i686
WindowManager: compiz
XorgConf:
 Section "ServerFlags"
  Option "DontZap" "false"
 EndSection

Max Bowsher (maxb) wrote :
Albertas Agejevas (alga) wrote :

Also, gnome-screensaver should pass through the volume up, down, mute keypresses.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Albertas Agejevas (alga) wrote :

Yes, neither power management nor volume control buttons work when the screensaver is active in Ubuntu Natty.

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → New
Marius B. Kotsbak (mariusko) wrote :

I would expect the observed behavior. A random user with physical access to a PC but without user account should not be able to suspend the PC, possibly stopping background jobs etc (and loosing files if the suspend fails).

Same with volume control, the user might have muted it on purpose.

Changed in gnome-screensaver (Ubuntu):
status: New → Invalid
Albertas Agejevas (alga) wrote :

I would argue that the sound and power management buttons are to do with the physical access to the device, and are more akin to physical actions like switching power on/off or pulling the sound cable, rather than accessing the session of a logged in user.

I accept your point that it is possible that that the user would want to block PM/sound controls when locking the screen, however I maintain that most often this is not the case.

Changed in gnome-screensaver (Ubuntu):
status: Invalid → New
Marius B. Kotsbak (mariusko) wrote :

Okay, it should probably be discussed as a wishlist item instead. Ideally it should be configurable by the user and the discussion be what should be the default.

I always expected sleep button not to work when it is locked, but could benefit from it being possible.

I have the same issue in Debian 6.03. I use the system as a home server with an auto-logged-in user. At night I would like to be able to suspend the machine by simply pressing the power switch, but right now I always have to disable the screensaver first.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers