Screensaver doesn't unlock

Bug #530044 reported by aspa on 2010-03-01
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-screensaver

It's sometimes impossible to log back into the system after the screen has been locked.
When this problem occurs a blank screen appears when I enter the correct password.
If I move the mouse or press a key, I get a new password prompt but it just keeps prompting the password even if I enter it correctly.
I'm able to log in with the same user account from a virtual terminal.
I'm also able to log in using another account through X (switch user).

ProblemType: Bug
Architecture: i386
Date: Mon Mar 1 15:32:42 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gnome-screensaver/gnome-screensaver-dialog
NonfreeKernelModules: nvidia
Package: gnome-screensaver 2.28.0-0ubuntu3.4
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic-pae
SourcePackage: gnome-screensaver
Uname: Linux 2.6.31-19-generic-pae i686
XsessionErrors:
 (gnome-settings-daemon:5154): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:5154): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:5227): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:5197): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

aspa (marko-asplund) wrote :
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Please run "killall gnome-screensaver && gnome-screensaver --no-daemon --debug 2>&1 | tee ~/gnome-screensaver.log", lock the screen, attempt to unlock it and then attach the log file here only if you see the problem

Thanks

Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
aspa (marko-asplund) wrote :

The same issue also appeared on a colleague's Ubuntu 9.10 installation.
He noticed some errors in /var/log/messages that may be related to this and I also found the following messages in my machine's log file:

Mar 1 15:31:34 l3bz510 kernel: [ 8311.291902] gnome-screensav[8315]: segfault at 0 ip b6587185 sp b64a2de0 error 6 in pam_lsass.so[b6584000+8000]
Mar 1 15:31:46 l3bz510 kernel: [ 8323.840147] gnome-screensav[8378]: segfault at 0 ip b649e185 sp b63b9de0 error 6 in pam_lsass.so[b649b000+8000]
Mar 1 15:35:25 l3bz510 kernel: [ 8542.274933] gnome-screensav[8965]: segfault at 0 ip b65b5185 sp b64d0de0 error 6 in pam_lsass.so[b65b2000+8000]

Could the problem be related to MS ActiveDirectory authentication and Likewise?

The issue appeared all of a sudden on my computer and persisted for more than two weeks until it disappeared about two days ago. I did boot the system several times during that period.

I don't know if this is related but our MS Exchange email server started to issue password expiration reminder notices to me a few weeks ago. I changed my the password earlier this week and it was after that at some point that the problem disappeared.

My colleague also mentioned getting password expiration notices.

aspa (marko-asplund) wrote :

Unfortunately, I don't have the 9.10 installation anymore so I won't be able to provide the requested information. Hope comment #3 helps in resolving this issue.

Pyppe (pyppe) wrote :

I had the same problem with Ubuntu 9.10. It started when my user account started to get notices about expiring password (MS ActiveDirectory & Likewise).

After I changed my password, and my user account stopped bugging me about password expiring soon, the gnome-screensaver problem was fixed as well.

MMeija (mmeija) wrote :

here's the output requested by Chris Coulson

same issue it seems, ubuntu 9.10 with likewise for AD auth

frown! last time i ran into this i switched to xscreensaver but i'd rather not

at some point in the coming weeks I shouldbe able to test against lucid

Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this. Can you still reproduce this with Ubuntu 10.10 (Maverick)?

MMeija (mmeija) wrote :

I'll try 10.10 as you requested; I've still not even tested lucid. I'm not entirely sure how to artificially adjust the password expiration in my windows domain if anyone has ideas on how to do that it would be helpful. Otherwise could be a couplefew weeks.

MMeija (mmeija) wrote :

I just came across the opportunity to test 10.04 .2 and it appears to be resolved now, log attached from comparison to 9.04 where the problem existed at time of report

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers