"Timeout has expired" error on resume from hibernate

Bug #50198 reported by edal
158
This bug affects 32 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
New
Undecided
Unassigned
One Hundred Papercuts
Undecided
Unassigned
gnome-screensaver (Ubuntu)
Low
Unassigned

Bug Description

This bug occurs at random but it happens at least five times a week so I have plenty of opportunity to test 8-(

On resuming from hibernate I get a small window asking for my user ID and password. One of three things then happens:

a) I enter my password and start using my laptop.

b) During password entry I get an error message "Timeout has expired". The screen then goes black and then resumes at the ID and password window with the password field blank. Sometimes I do not notice this which means that I only enter the second portion of my password.

c) As soon as I resume from hibernate I see the "Timeout has expired" error message. By moving the mouse pointer around the screen goes black then resumes at the user ID / password window.

This bug is of course none-critical, just annoying.

Ed Almos
Budapest, Hungary

Revision history for this message
Ante Karamatić (ivoks) wrote :

I can confirm this.

Revision history for this message
Juan Pablo Salazar Bertín (snifer) wrote :

I can confirm this too. It also occurs after resuming from suspend.

Revision history for this message
Philip Paquette (pcpaquette) wrote :

Setting package temporarily from (undefined) to gnome-screensaver.
Can you confirm this bug still happens in edgy/feisty?

Thank you.

Revision history for this message
Philip Paquette (pcpaquette) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further and it has been outstanding for a very long period of time. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-screensaver:
assignee: shooters → nobody
status: Needs Info → Rejected
Revision history for this message
Martin Pool (mbp) wrote :

This is happening for me as a new regression after upgrading to Karmic. It happens 100% of the time coming back from suspend, and I think also from hibernate.

What seems to be happening is this: the unlock dialog appears on the screen just before the machine suspends, so that dialog thinks too much wall time has expired when the machine wakes up.

A few seconds after the "timeout has expired" message comes up the unlock dialog disappears, leaving the screen blonk, so people may think the machine has failed to resume.

Changed in gnome-screensaver (Ubuntu):
status: Invalid → Confirmed
Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Low
Revision history for this message
Gordon Hopper (gohopper) wrote :

Confirmed to be still present in package version gnome-screensaver 2.28.0-0ubuntu3 (Karmic).

Revision history for this message
glass.dimly (jmjohn) wrote :

My error is similar to this behavior, only not precisely this. My screen says "Time has expired" above the password prompt, and then goes blank. Karmic, current.

Revision history for this message
Andrew Fluth (afluth) wrote :

This bug appears to be present in Lucid Lynx alpha 2. (gnome-screensaver 2.28.0-1ubuntu5)

Revision history for this message
steubens (steubens) wrote :

happens 100% of the time for me, i concur with #5; this makes the process feel very flaky; and the mouse cursor does disappear when the screen is blanked again after the dialogue "times out" the first time, further, it makes resuming from hibernation all the more chunky. it would be preferable if there were some resume feedback until it tries to show the cursor or the dialogue, because both are very very chunky until the machine stops swapping in pages some seconds later

if i were taking a stab at fixing this i would make sure i'd be sure the screen was blanked before resume before starting feedback throbbers or whatever, then do the dialogue completely after resume (and in the case of hibernate, until paging io has calmed down a bit so the mouse cursor doesn't jump around and the machine interactivity is actually tenable for entering your credentials)

Revision history for this message
steubens (steubens) wrote :

if still present, I haven't seen it in ages. (lucid lynx beta 2)

Revision history for this message
lilphil (lilphil) wrote :

If it helps, I'm still reliably seeing it in Lucid, on every resume from suspend.

Revision history for this message
Marc (hunter-ubuntu) wrote :

Running 10.04 and it happens to me almost every time

Revision history for this message
Martin Schayna (mschayna) wrote :

10.04 and also happens to me on 50% resumes from suspend (I don't use hibernate).

Vish (vish)
affects: hundredpapercuts → gnome-screensaver
Revision history for this message
Neil H (neilhillen) wrote :

If you use a laptop, and close the screen, and require a password to be entered to return to the desktop, the text box sometimes shows with this message. it then closes and a fresh dialog shows.

Presumably the dialog was triggered before sleep and it has a lifespan set which will be expired when when you return to the laptop later.

It wastes about 5 seconds every time you open your laptop - so whilst the bug might be minor in that it doesn't affect functionality, I am tired of seeing it, and I suspect I am a fairly forgiving user.

Revision history for this message
Mike Coleman (tutufan) wrote :

This is currently occurring on about 40% of resumes for me (ubuntu 10.04), on a Dell Inspiron 1420N (sold with ubuntu). Just to clarify, for me, I always see either behavior (a), or I see (b) followed by (c).

Over several ubuntu releases, it seems like this problem has disappeared and reappeared, perhaps multiple times. Although it's fairly easy to work around once you realize what's happening, for me it's probably ubuntu's most obvious flaky behavior. Perhaps the importance of this bug should be increased.

Revision history for this message
Robert Entner (robertentner) wrote :

Does this bug really deserve Importance=low? At least my wife complains about this every time, also I see this as really annoying making Ubuntu look "unready".

Revision history for this message
erikj (erik-jogi) wrote :

Hello,

I ran gnome-screensaver in foreground with --debug flag to see what is different when the timeout message occurs. Attached to this comment is the log from the case where I got the timeout message. As there is only one attachment per comment then I with the next comment I will include the log from a case where everything was fine - i.e. the password dialog didn't disappear immediately.

I will try to dig in the code to understand from the log why this happens but any help from someone who is more familiar with the source would be most welcome. Right now it looks like the message "Request unlock but dialog is already up" might point to the right direction - maybe the dialog is sometimes kept open from before the suspend and therefore receives the timeout...

Revision history for this message
erikj (erik-jogi) wrote :

Log from correct behaviour

Revision history for this message
Phil Thompson (phil-thompson-289) wrote :

Some of you may want to check this out.
http://ubuntuforums.org/showthread.php?t=263356

Revision history for this message
Peter Levi (peterlevi) wrote :

Just mentioning that this bug still happens in Maverick

Revision history for this message
Raphael Weingartner (raphaelwolfgang) wrote :

I also think this bug should receive a higher priority. After suspend I usually have the "Time has expired" message. Normally this isn't a problem but recently I had a complete freeze of the system and I couldn't enter my password at all. I couldn't reproduce this on a subsequent test though. Even if this bug is unrelated to my freeze up, I think the "Time has expired" message is something that many Ubuntu users have encountered and gives a bad impression....

Revision history for this message
CTenorman (ctenorman) wrote :

This bug should definitely receive a higher priority. Faster resume times are one of the big focuses of the latest computers and OSs like the Air and Google's Chrome OS netbook. Not being able to type in your information for 4 or 5 seconds and having to hit several keys to get the prompt to come up is a big pain by comparison.

Revision history for this message
CTenorman (ctenorman) wrote :

I should also probably mention that of the four laptops I work with, this error only occurs on the one which doesn't automatically resume upon the lid being opened. On the machine with the error, my Asus 1015PEM netbook, it won't resume unless I press a button after opening the lid. My other three machines resume simply by the lid being opened.

Could the error be related to resetting a timer based on a lid-open event that doesn't occur when a key-press is used like with my 1015PEM netbook?

Revision history for this message
Forest Bond (forest-bond) wrote : Re: [Bug 50198] Re: "Timeout has expired" error on resume from hibernate

Hi,

On Sun, Dec 12, 2010 at 05:46:38AM -0000, CTenorman wrote:
> I should also probably mention that of the four laptops I work with,
> this error only occurs on the one which doesn't automatically resume
> upon the lid being opened. On the machine with the error, my Asus
> 1015PEM netbook, it won't resume unless I press a button after opening
> the lid. My other three machines resume simply by the lid being opened.
>
> Could the error be related to resetting a timer based on a lid-open
> event that doesn't occur when a key-press is used like with my 1015PEM
> netbook?

No, I see this problem on my HP Mini 110, which properly resumes on lid open.

-Forest

Revision history for this message
Chris Wilson (notgary-deactivatedaccount) wrote :

Could the people affected by this bug please state what make and model of laptop it appears on? Since it doesn't seem to be appearing on every laptop, I'm lead to believe it may be a hardware issue. I've noticed two netbooks in the comments above. What everyone else got?

Revision history for this message
lilphil (lilphil) wrote :

Hp Compaq nx7300
Hp Compaq nx7400 x3
Asus Eee PC 901 x2
Acer mumblemumble (3 different models that I havn't got in front of me)

I've also seen it on various desktop's that I have suspended, but I rarely suspend them it's just for testing.

I don't think I've personally seen a computer where it doesn't happen, although it does not seem to occur if you resume immediately, it needs a few minutes.

HTH

lilphil

Revision history for this message
Peter Levi (peterlevi) wrote :

Mine is a FSC Amilo Pi 1536 (not a netbook). I need to press the power button in order to resume (does not resume on lid-open or on ordinary key press). I think I haven't seen the problem on this laptop in the releases before Maverick.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Apple MacBook4,1. Happens intermittently (about once every 30~40 wakeups) after opening the lid.

Revision history for this message
Raphael Weingartner (raphaelwolfgang) wrote :

Sony Z21 MN, running lucid lynx.
Last time this happened I could not even do the "alt + SysRq + REISUB" trick to gently reboot the system, it was a complete freeze!

Revision history for this message
Chris Wilson (notgary-deactivatedaccount) wrote :

I'm going to invalidate this as a paper cut since the problem isn't apparent on every computer, which leads me to the conclusion that this is a hardware issue. A paper cut should be a small usability flaw that is present in all default installations of Ubuntu.

Changed in hundredpapercuts:
status: New → Invalid
Revision history for this message
James Legg (lankyleggy) wrote :

Happens most of the time when resuming from standby on my Asus X58L laptop running Ubuntu 10.04 (Lucid Lynx) x86_64.

Revision history for this message
Umang Varma (umang) wrote :

I can see it on a Dell Inspiron N5010 using Lucid (10.04).

The laptop resumes on opening the lid and then the dialog momentarily appears, the "Time has expired" message shows for a few seconds and then the dialog disappears. I can start entering characters once the unlock dialog reappears.

Revision history for this message
Knef (knef) wrote :

This bug happens everytime I open my netbook from suspend. Even though suspend works everytime, the brief flashing of the "Time has expired" message makes it look glitchy.

I have an Asus 1015PEM.

Revision history for this message
Owais Lone (loneowais) wrote :

this happens to me all the time in oneiric. even when simply locking with cntrl+alt+L

Revision history for this message
VladNistor (vladnistor) wrote :

I get this in oneric with after I haven't used the computer in a few hours (like overnight). It happens every time. I have gnome3 installed.

Revision history for this message
appi2012 (appi2012) wrote :

I'm getting this in onieric as well. For me at least, I can't do anything other than force a reboot. This should have a higher priority, IMO.

Revision history for this message
Peter Gaultney (petergaultney) wrote :

I have had this same problem since at least Maverick Meerkat. It always happens, and my wakeup is always slower than it ought to be. Once the screen has gone black, it will 'come back' normally and everything works, but it's a ridiculous situation.

Revision history for this message
Umang Varma (umang) wrote :

I'm no longer affected in Ubuntu 11.10 regular Unity (not Unity 2D).

Revision history for this message
David Barnett (mu-mind) wrote :

And I see the problem on a Lenovo 3000 n500 with integrated video using i915 driver.

Is there anywhere we can compile this whole list of hardware and work out the commonalities with the hardware? We've listed quite a few systems here, but I fear everyone's waiting for someone else to look into it.

Revision history for this message
Umang Varma (umang) wrote :

I'm running a Dell Inspiron N5010. I encountered this problem consistently with Ubuntu 10.04 (a few times a day) and have not encountered it in Ubuntu 11.10 yet. I have been running 11.10 for more than a week without problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers