gnome screensaver only shows blank screen on karmic 9.10

Bug #496716 reported by v1nsai
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-screensaver

On Ubuntu 9.10 Karmic with gnome-screensaver 2.28

No matter what screensaver is chosen, blank screen is displayed when screensaver turns on.

Have tried selecting and de-selecting activate screensaver and lock screen options, have changed screensavers (i normally use random) and still only a blank screen is displayed.

I've seen this reported before but they're pretty old, none have been reported past Hardy. Please let me know of any other information I can provide.

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 14 15:26:33 2009
DistroRelease: Ubuntu 9.10
Package: gnome-screensaver 2.28.0-0ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: gnome-screensaver
Uname: Linux 2.6.31-16-generic x86_64

Revision history for this message
v1nsai (v1nsai) wrote :
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thanks. Please post the output of "apt-cache policy libgnome-menu2". It's likely the bug you're experiencing is one that was already known and fixed recently, but you are running the out-of-date version still.

Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
v1nsai (v1nsai) wrote :

I fixed the problem by rolling back some mesa related drivers from the x-updates PPA. Once I did that everything worked fine again.

I knew it was weird that I couldn't find any information on this, close this bug sorry I should have tried rolling back these updates first.

Revision history for this message
v1nsai (v1nsai) wrote :

Screw it, it stopped working again >.<

apt-cache policy reports that I'm using of libgnome-menu2. It came from the ubuntu main repo, how do I get a newer version?

Revision history for this message
Kip Warner (kip) wrote :

I'm having the same problem for god knows how many distro upgrades by now. I'm currently running Maverick with the same problem. If I preview the screensaver through screensaver preferences, it works fine. If I wait until the screensaver actually starts, or run gnome-screensaver-command --active, all I see is a blank black screen in place of my selected screensaver.

Revision history for this message
Mikster (maltarriba) wrote :

I'm now seeing this problem after having upgraded from 10.04 to 10.10. Previously, gnome-screensaver worked normally. After the upgrade, the screensaver will work correctly the first time or two after a reboot, but, afterwards, instead of the chosen screensaver only a black screen is shown. This is also true when the screensaver is activated via gnome-screensaver-command --activate. The screensaver preferences screen displays everything normally.

Revision history for this message
Kip Warner (kip) wrote :

I am still having this problem, even through explicit activation via gnome-screensaver-command --activate.

Revision history for this message
Chris (ckav8r) wrote :

I also have this bug in 10.04.. Screensaver worked great in 9.10. Any fixes?

Revision history for this message
Bobby (bmagnusen) wrote :

I'm having the same issue on a Dell Latitude E6410 running 10.10 x64.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers