Unlock screen is invisible with Nvidia twinview

Bug #45018 reported by John Beisley on 2006-05-16
110
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Fix Released
Medium
gnome-screensaver (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-screensaver

This bug may equally be an issue with the Nvidia GLX drivers or Xorg.

When my laptop is configured with the following excerpt from xorg.conf, the gnome-screensaver unlock dialog does not appear. I haven't tested if the dialog box appears if a second monitor/projector is connected.

Further symptoms include two screensavers seeming to run at the same time, sometimes one screensaver briefly appears over the top of the other.

# Begin xorg.conf

Section "Device"
 Identifier "NVIDIA Corporation NVIDIA Default Card"
 Driver "nvidia"
 BusID "PCI:1:0:0"
 Option "RenderAccel" "true"
 Option "Coolbits" "1"
 Option "ConnectedMonitor" "DFP,CRT"
 Option "TwinView" "1"
 Option "Metamodes" "1280x800,1280x800; 800x600,800x600; 1280x800,NULL"
 Option "UseEdidFreqs" "true"
 Option "SecondMonitorHorizSync" "30-96"
 Option "SecondMonitorVertRefresh" "50-160"
 Option "TwinViewOrientation" "Clone"
EndSection

# End xorg.conf

I have disabled the ConnectedMonitor Option and all below it as a workaround while I do not have a second monitor connected.

Marius Gedminas (mgedmin) wrote :

I too suffer from invisible unlock screen, but I have a Radeon card, not Nvidia. I do use dual-head layouts (MergedFB) also, but the unlock screen appears invisible even in single-head mode. I can type in my password blindly and unlock the session.

This seems to only happen when I use the 'blank screen' screensaver.

Amos Brocco (mriya3) wrote :

I also have the same bug, with an nvidia geforce4 go 420 and nvidia proprietary drivers.

The password box does not appear and I have to blindly type the password to unlock the screen.

Disabling twinview is not an option because it's a notebook I use frequently for presentations.

Changed in gnome-screensaver:
status: Unknown → Confirmed
Timo Aaltonen (tjaalton) wrote :

confirmed upstream, so confirming here as well.

Changed in gnome-screensaver:
status: Unconfirmed → Confirmed
Sam Williams (sam-williams) wrote :

I reported an earlier version of this bug and it looked initially like it might have been corrected with a slight modification of the xorg.conf file. Instead tonight the problem came back, so my early report was premature.

Changed in gnome-screensaver:
status: Confirmed → Fix Released

This was fixed in 2.18 according to the upstream bug report.

Changed in gnome-screensaver:
status: Confirmed → Fix Released
Sean Sosik-Hamor (sciri) wrote :

I have similar problems when using the Blank Screen screensaver. Moving the mouse or tapping a key reveals a blank white or blank gray dialog box. Hitting Esc to cancel the dialog then moving the mouse again shows the dialog properly.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

Package: gnome-screensaver
Architecture: i386
Version: 2.22.2-0ubuntu1

 * 256MB NVIDIA GeForce 8400M GS (nvidia-glx-new)

Keith Hughitt (keith-hughitt) wrote :

Same problem here. The screensaver works fine, but freezes up when I move the mouse. Even though no unlock dialog box is displayed, I can still type
in my password and the screen will unlock. I'm running Ubuntu 8.04 with the proprietary NVIDIA drivers (169.12), X 11.0 (1.4.0.90 (10400090) and Compiz:

$ compiz --version
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:01d1 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (3520x1200) to maximum 3D texture size (4096): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
compiz 0.7.4

I'm on a Radeon, configured my xorg with "aticonfig --initial=dual-head". The first screen goes blank (as I'm using the Blank Screen screensaver) but my second stays unchanged. I get no password prompt on either screen, and though my mouse changes to an I bar when I mouse over text widgets in either the black left window or the unchanged right window, I can't interact with anything and have to kill X.

Charles Galpin (cgalpin) wrote :

I have the same problem as Candle Jack describes, also with an ATI Radeon (X300SE) on Ubuntu 8.04.1

Chuck McKenzie (redchuck) wrote :

I'm having an identical problem to Candle Jack on 8.04.1 with a Radeon X600, also configured via "aticonfig --initial=dual-head"

I'm also unable to disable the screensaver via System -> Preferences -> Screensaver because only a hanging grey box opens when I run it.

Mansoor (mansoor2483) on 2009-11-15
Changed in gnome-screensaver (Ubuntu):
status: Fix Released → New
MrSkrimps (sesimpson78) wrote :

I'm having the same problem reported upstream. Ubuntu 9.10+compiz and ATI radeon using proprietary drivers. the weird thing in my situation is, nothing was wrong up until i installed KDE...conflict perhaps?

I also have the same problem with ubuntu 9.10 i386 and ATI RADEON HD!!

DaveM (davidmartin-ntlworld) wrote :

I'm having the same problem, with Ubuntu 9.10 i386 and a single monitor...

$ uname -a
Linux thebox 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux

$ aticonfig --list-adapters
* 0. 01:05.0 ATI Radeon HD 3200 Graphics

* - Default adapter

I have to type the password in blindly to unlock the screen. I'm not experiencing any other problems with this graphics card.

This only started happening after I upgraded from 9.04. All other post-upgrade niggles have all been solved..

Thank you for posting this bug.

Is this an issue in Lucid?

Changed in gnome-screensaver (Ubuntu):
status: New → Incomplete

Nope, in Lucid this works ok.

On Wed, Sep 15, 2010 at 3:26 AM, rusivi1 <email address hidden> wrote:
> Thank you for posting this bug.
>
> Is this an issue in Lucid?
>
> ** Changed in: gnome-screensaver (Ubuntu)
>       Status: New => Incomplete
>
> --
> Unlock screen is invisible with Nvidia twinview
> https://bugs.launchpad.net/bugs/45018
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (55277).
>

Charles Galpin (cgalpin) wrote :

Likewise, working now in Lucid, thanks!

Changed in gnome-screensaver:
importance: Unknown → Medium
megabyte (maartenberg1) wrote :

this does appear for me in lucid, but I am going to upgrade to Maverick vary soon...

I have this issue from time to time on both laptop and desktop (both having single-head configuration).

laptop:
ATI Radeon x1250
Ubuntu 11.04 x86, kernel: 2.6.38-8-generic

desktop:
ATI Radeon HD 2600XT
Ubuntu 11.04 x86, kernel: 2.6.38-8-generic-pae

Both machines have Unity running. I can't tell if running classic gnome or classic gnome without compiz can fix the issue.

Luis Mondesi (lemsx1) wrote :

I started having this issue after upgrading to Oneiric (11.10). Previous versions of Ubuntu worked fine. I'm using nvidia card with dual-head (twinview). also, I'm using gnome3 from universe.

locking screen works. no screensaver. moving the mouse shows the mouse pointer changing when it goes over the dialog where you would be typing your password. typing my password logs me in.

on 11.04 I was using gnome3 from the gnome3 ppa team and everything worked fine. then i did a do-release-upgrade -d a few days after beta1 was announced.

peddy (peddy22) wrote :

Confirmed with Luis. Is it normal protocol to open a new bug report or to re-open this one?

Matthew Gregg (mcg) wrote :

Same issue as Luis on 11.10. Please re-open.

peddy (peddy22) on 2011-09-23
Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Confirmed
peddy (peddy22) wrote :

Fixed for me in the latest set of updates, can somebody else confirm this?

Matthew Gregg (mcg) wrote :

Looks to be fixed for me as well. I am consistently getting an unlock dialog and I am not seeing the content behind the lock in the second display.

Similar issue on my desktop (dual DVI on nVidia GeForce GTX 560). I often have to kill gnome-screensaver from a virtual console since the password box does not appear.

msdin (msdin) wrote :

I also have this problem (Ubuntu 11.10). It occurs on both of my systems. Both are dual-monitor. One system has nvidia with twinview and the other is Intel graphics.

Cinquero (cinquero) wrote :

Just updated oneiric, but this bug is still there:

[ 621.985891] gnome-screensav[2699]: segfault at 5 ip 00007f5d6a044859 sp 00007fff423153f0 error 4 in libcairo.so.2.11000.2[7f5d6a00b000+b9000]

Happens to me to on 11.10, i'm experiencing this with an Intel board, it happens intermittently, sometimes i can see the log-in dialog box, other times i can't, one would think that this bug would have a higher importance, or at least a workaround... I've personally found that if i switch between the ttys enough the box will eventually re-appear, defiantly a nasty bug for any new user to experience

Dave Brady (matter-grey) wrote :

I'm experiencing what I think is the same problem. I'm on Ubuntu 12.04, with two monitors with twinview. One monitor is 1920x1080, and the other is 1280x1024. The symptoms are exactly as described here by another user:

http://askubuntu.com/questions/151337/screen-saver-issue

Interestingly, the problem doesn't occur if you merely lock the screen. The problem only manifests if you also blank the screen. I can still move the mouse around the first screen, but it stops when I hit the border to the second screen. After I blindly enter my password, things go back to normal.

+1 I am hitting the exact same issue as in the question and mentioned by dave brandy

+1 on 12.04 / nvidia

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.