Screensaver should display time when screen is locked

Bug #409432 reported by randomas on 2009-08-05
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Fix Released
Wishlist
gnome-screensaver (Ubuntu)
Wishlist
Unassigned

Bug Description

When you have the option to lock screen in the screen-saver is activated, it would be useful to have the time and date display on the password widget (the one where you can leave notes).

Rich Jones (richwjones) wrote :

This would be awesome.

Sense Egbert Hofstede (sense) wrote :

Actually it would be bad if you could still hear sound when the screen is locked. I'd consider that a bug.

Changed in hundredpapercuts:
status: New → Confirmed
randomas (randomas) wrote :

I'd agree with you if the user were to actually click on the lock screen option, but if it were just enabled in the screen saver, you wouldn't want the pc to stop playing music just because you're away from the keyboard. On the other hand if you needed to mute the volume quickly for some reason, you couldn't because first you'd have to log back in. Which is why I'd like to have the media hotkeys on the keyboard still responsive, or media player controls on the screen lock widget.

Chris Halse Rogers (raof) wrote :

I've split this into two bugs - one to have the time displayed on the lock screen (this bug), and the other about volume up/down is basically bug #18415.

summary: - Screensaver should display time and allow volume control when screen is
- locked
+ Screensaver should display time when screen is locked
description: updated
Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME .
Once submitted upstream , do report back here with the upstream bug number.Thanks in advance!

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Wishlist

Thanks a lot for reporting this, however since this constitutes a feature request, rather than a small design flaw, I am closing the paper cut portion of this report. For reference, this could be considered a paper cut if there was a clock displayed on the screen saver that had a problem.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in gnome-screensaver:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-screensaver:
importance: Unknown → Wishlist
status: Unknown → New
Changed in gnome-screensaver:
status: New → Fix Released
no longer affects: hundredpapercuts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.