Complete System Lockup following Screensaver then Monitor Power Down

Bug #366737 reported by david.h on 2009-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-screensaver

This is my first time reporting a bug on Ubuntu so apologies if I miss anything.

Today my machine locked up while I was away from desk. When I returned the machine was unresponsive to keyboard (internal and external), mouse and or trackpad. The network also appeared to be offline as I couldn't ping it from another machine on my network. The machine didn't appear to be busy - no rapidly flashing lights! It was also unresponsive to a the power button (not in suspend or hibernate). I had to hold the power button down for 3-5 seconds to shut the machine down.

The machine had idled to screensaver (Skyrocket) before I left my desk.

I do not know if power management had put the display to sleep as I was not at the desk, but I was away long enough for this to have occurred (~1 hour).

Yesterday, following it's release, I did a fresh install of Jaunty Jackalope 64bit on my machine. (I had previously been running Intrepid Ibex.)

I also installed the latest driver from Nvidia (x86_64 v180.53) released on the 22 Apr 09. (I had previously been using a beta Nvidia Driverx86_64 v185.13 released on the 13 Mar 09.)

At the time, the following applications were running;
1. QuickSynergy (minimized but connected as a server to one other pc)
2. Firefox (1 instance)
3. Gedit (2 files open)
4. Terminal (idle)

Apart from VMware Server2, the machine runs very little on the host. I had installed a couple of new applications on trial as this was my first build of Jaunty.

My machine specs are as follows;

Dell Precision M6400 (Laptop)
  Intel Core 2 Extreme QX9300
  16Gb RAM / 2 * 500Gb Sata 7200 (no RAID)
  17" RGB LED 1920x1200 driven by Nvidia FX3700M 1Gb
Ubuntu Jaunty Jackalope 64Bit (9.04) 2.6.28-11
  Nvidia Driver x86_64 v180.53

I had not had this issue previously under Intrepid.

Thank you, I hope this information may be useful somehow.

Regards

David

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: gnome-screensaver 2.24.0-0ubuntu6
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-screensaver
Uname: Linux 2.6.28-11-generic x86_64

david.h (a1863-ubuntulaunchpad) wrote :
david.h (a1863-ubuntulaunchpad) wrote :

Forget to mention, when I got back to my desk the monitor was sleeping, there was no active screen saver.

The following thread seemed very close to the issue I experienced.
  http://ubuntuforums.org/showthread.php?t=1129414&page=3

Regards

David

david.h (a1863-ubuntulaunchpad) wrote :

Just tried to repeat the problem but was unsuccessful.

I set the screensaver timeout to 1 min and the display power down to 2 minutes.

With nothing open the issue did not repeat after 5 minutes.
With QuickSynergy open, the issue did npt repeat after 5 minutes.
With gedit open, the issue did npt repeat after 5 minutes.

Possibly I need to let the screen saver run for longer. I will try that later.

Regards

David

Pedro Villavicencio (pedro) wrote :

Thanks for the report, May you please get us a screensaver debug log? please do the following:

killall -9 gnome-screensaver
gnome-screensaver --no-daemon --debug > /tmp/gs.log 2>&1

Reproduce the issue and attach that resulting file to the report. Could you also attach your ~/.xsession-errors file and your Xorg.0.log file after reproduced the issue? Thanks.

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Roy (rdstrac) wrote :

I am having the same problem with the i386 release and a Matrox G550 video card. I do not experience lock up unless the computer is idle for a long period of time - >5 hours. The problem will always re-occur overnight, during which time only BOINC is running. After lock up, the keyboard and mouse have no effect (though it is a wireless mouse and the connection indicater flashes) and only a power reset will restart the computer. I will try to get the files you requested in the morning after the next lockup.
Changing settings in Screensaver Preferences and Power Management doesn't seem to have a noticeable effect on the time required before lock-up.

Roy

Roy (rdstrac) wrote :

I changed Screen Saver Prefs to -
 - Regard as idle after 2 hours
 - Activate Screen Saver : unchecked
 - Lock Screen : unchecked

Power Management -
 - Put computer to sleep : never
 - Put display to sleep : never

After 5.5 - 6 hours (according to BOINC which only records it's active time) the computer locked up. No screen saver activated but I could not ping the box and the keyboard/mouse had no effect.
I tried to restart with a power reset. The first try failed at the point the busy (circular) mouse pointer appeared. On the second try there was a routine check of the drive, then the computer came up normally.

I did the killall -9 gnome-screensaver, then created /tmp/gs.log as per your instructions to David.
I am attaching it and Xorg.0.log however the ~/.xsession-errors file does not exist.

I hope this is of some help
  Roy

Roy (rdstrac) wrote :

I tried adding the 2 files as a folder but it looks like only gs.log made it so here is Xorg.0.log.

  Roy

Roy (rdstrac) wrote :

Next try - Enabled ACPID & APMD which were both disabled - Enabled the Proposed Repository and did the updates.
After about 2 hours the screen came alive with mouse movement. After about 8 hours the computer was locked up requiring a power off/on reset. The computer booted without any error or problem. Do you have any suggestion as to what to try next?

Thanks
  Roy

Pedro Villavicencio (pedro) wrote :

thanks for the logs.

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Confirmed
Roy (rdstrac) wrote :

I'm still not 100% sure if the screen saver is the problem. I think heat *may* be a contributing factor. I cleaned the fins of the CPU cooler (small amount of dust) and applied a new coating of heat paste. I also cut back on the BOINC CPU usage. This seems to have helped, but not completely eliminated the problem. I installed Jaunty on another computer (Dell GX270 2.8 Ghz P-4, Intel on-board video) and have had no problems with it.

  Roy

Pedro Villavicencio (pedro) wrote :

Thanks for the report david.h , It has been a long time without any comment or a duplicate in this bug report and It is possible that the bug has been fixed. May you please try to reproduce it with the latest Stable Release of Ubuntu the Natty Narwhal and add the respective comments to the report? You can learn how to get that release at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers