Screensaver not disabled when running XBMC

Bug #355580 reported by Turniphead on 2009-04-05
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-screensaver

I'm running a fresh install of Jaunty with all updates as of 20090404 and running XBMC from SVN repository

When watching a video using xbmc the screensaver kicks in at the time set in the screensaver preferences. This was not the case with intrepid. I would have expected the screensaver to remain off while running this app as it contains its own screensaver.

I reported it to the XBMC dev team but they are of the opinion that it is out of their reach. It may not be the most important bug, but it's one of the very few I have come across so far.

My quick fix was to make a custom app launcher, which runs a script disabling the screensaver, starting xbmc then re-enabling it on exit. Seems to work.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xbmc 8.10final1svn19085-intrepid1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: xbmc
Uname: Linux 2.6.28-11-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Turniphead (turniphe4d) wrote :
Turniphead (turniphe4d) wrote :

Same thing happens when using my unmentionable virtual machine in VirtualBox. Just for the record. I haven't got round to trying other SDL based software.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, May you please get us a screensaver debug log? please do the following:

killall -9 gnome-screensaver
gnome-screensaver --no-daemon --debug > /tmp/gs.log 2>&1

Reproduce the issue and attach that resulting file to the report, thanks in advance.

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Invalid

I can reproduce on 9.04 with all updates installed.

I'm attaching the requested debug logfile. The lines with timestamps around 02:46:18 is when the screensaver kicks in during video playback in XBMC.

Changed in gnome-screensaver (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers