don't use OpenGL savers if no hardware support

Bug #33753 reported by Matthias Klose on 2006-03-05
76
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Expired
Medium
gnome-screensaver (Ubuntu)
Medium
Unassigned

Bug Description

gnome-screensaver may randomly select an OpenGL screensaver, even if hardware acceleration for OpenGL is unavailable. When that is the case, it results in extremely poor performance and high CPU utilization inappropriate for a screensaver.

Matthias Klose (doko) wrote :

marking as major (regression compared to breezy)

Oliver Grawert (ogra) wrote :

all 2d screensavers are in the xscreensaver-data and xscreensaver-data-extra (universe) packages, the 3d screensavers are in xscreensaver-gl and xscreensaver-gl-extra (universe)
as an easy workaround you can uninstall the *-gl-* packages

Oliver Grawert schrieb:
> Public bug report changed:
> https://launchpad.net/malone/bugs/33753
>
> Comment:
> all 2d screensavers are in the xscreensaver-data and xscreensaver-data-extra (universe) packages, the 3d screensavers are in xscreensaver-gl and xscreensaver-gl-extra (universe)
> as an easy workaround you can uninstall the *-gl-* packages

right, but uninstalling the gl packages removes ubuntu-desktop. we don't
support accelerated 3d drivers in main, so why have the 3d screensavers
there (and enabled by default)?

Hello,

I think we should configure gnome-screensaver to use a default 2D that won't eat CPU whatever the hardware support is. Especially on nVidia with nv driver, which is the default config (and that's good).

Étienne.

Alexandre Otto Strube (surak) wrote :

Ogra, do you confirm this? Can we change this bug's status?

Oliver Grawert (ogra) wrote :

i'm not sure i like to confirm that. we shipped GL screensavers by default since warty and had them always selected as well in the default selection.
in any case i cant confirm the current bug summary, there is a bunch on 2D screensavers installed by default

Alexandre Otto Strube (surak) wrote :

Thanks Ogra. Than can this receive a "wontfix"? It would not be done anyway...

Oliver Grawert (ogra) on 2006-04-05
Changed in gnome-screensaver:
status: Unconfirmed → Rejected
Matthias Klose (doko) wrote :

delayed for dapper+1

Changed in gnome-screensaver:
status: Rejected → Confirmed
Matt Zimmerman (mdz) wrote :

Yes, this has always been the case, since the first Ubuntu release, and I'd consider it an upstream issue. gnome-screensaver really shouldn't allow OpenGL screensavers to run by default when no acceleration is available. Please forward upstream.

Timo Aaltonen (tjaalton) wrote :

I've forwarded this upstream, and changed the title accordingly (since 2D savers have been in for quite some time):

http://bugzilla.gnome.org/show_bug.cgi?id=359592

Changed in gnome-screensaver:
status: Unknown → Unconfirmed
Jeff Fortin Tam (kiddo) wrote :

Okay, meanwhile, why does ubuntu ship a screensaver by default? Why not just blank the screen?! And this applies ESPECIALLY to the liveCD. The screensaver does not start during the install (as I previously suggested in some other bug) but it still starts in normal operation in the liveCD. It uses power, it eats ram and takes a long time to load. Urgh.

I have had several matrox, intel and ati based graphics cards that with the default install would CRASH upon about half of the opengl-screensavers.

If the screensavers that require 3D are in seperate packages, why are they even installed by default and/or available on a live-desktop. This is a packaging issue, not an upstream issue.

Please get those 3d screensavers out of the default install and live-cd and add their package to g-a-i for Edgy. Put the package in universe instead of official repo's while you're at it. (where they belong).

Also I vote for priority 'critical'. Since on about half of the 3d cards out there, using the default open source drivers, they make the system crash.

I will try to post some specific bug reports about all the hardware although I suspect they are already well known upstream. I have experienced this at least on two different Acer Systems as well as some Dell systems. They were all company related systems (yes: i have switched a number of small companies I work for from windows to ubuntu). It was shamefull to talk about stability for 10 minutes and then turn around to point to a crashed system (because some opengl screensaver started).

Hi,

On Wed, Oct 11, 2006 at 08:33:05PM -0000, Ralf Nieuwenhuijsen wrote:
> I have had several matrox, intel and ati based graphics cards that with
> the default install would CRASH upon about half of the opengl-
> screensavers.

So, this is your hardware or upstream xorg drivers bug.

> If the screensavers that require 3D are in seperate packages, why are
> they even installed by default and/or available on a live-desktop. This
> is a packaging issue, not an upstream issue.

No, this is a buggy hardware or buggy upstream drivers issue, because
system should never crash - stability should never depend on some
software, which user can start, like 3D game or screensaver.

> Also I vote for priority 'critical'. Since on about half of the 3d cards
> out there, using the default open source drivers, they make the system
> crash.

If you got system crash you should report a critical bug against xorg
drivers, not agains 3D game or other software, which uses xorg.

> I will try to post some specific bug reports about all the hardware
> although I suspect they are already well known upstream.

Yes, you should report bugs agains xorg-driver-xxx packages or kernel
DRI drivers. Btw, I suggest you to try to test with older Ubuntu
versions, for example I noticed lots of crashes on several system with
ATI Radeon 9xxx driver with Ubuntu 6.06, but with Ubuntu 5.10 they works
fine and stable.

> No, this is a buggy hardware or buggy upstream drivers issue, because
> system should never crash - stability should never depend on some
> software, which user can start, like 3D game or screensaver.

It's both an packaging issue of opengl as well as driver issue with
xorg. Its that the screensavers are the only element of the _official
supported_ desktop that require opengl, yet there are no free drivers
that even enable us to use opengl at a usable state. It's too slow for
screensavers or games.

OpenGL itself is not an officially supported part of Ubuntu. So why
would some screensaver package that nobody cares about, but is enabled
by default, depend upon stable high quality opengl support, when the
rest of the official ubuntu package does not provide it?

> If you got system crash you should report a critical bug against xorg
> drivers, not agains 3D game or other software, which uses xorg.

I would file a bug against any officially supported package that
depends on openGL support and runs by default.

The reason these bug-reports were not placed in the first place was
because I was paid to install and setup the ubuntu-boxes; not to file
bug-reports. I didn't have the time nor the access to those machines
to perform all kinds of test. If it would have involved anything that
they might want to use, I probably would have had the permission to go
ahead and file bug reports, monitor and assist in the fixing of them.
But they were like: just turn the screensavers off.

Matt Zimmerman (mdz) on 2006-11-24
description: updated
Matt Zimmerman (mdz) wrote :

Rodrigo, could you have a look at this long-standing issue and see if something can be done for Feisty? The upstream bug has an outline of what needs to be done, but it's a low priority for them.

In feisty: It seems by default the screensavers are set to just blank the screen now.

But its been a while since I installed feisty. Can some one confirm this?

Then we can close this bug..
Black screen by default seems a very acceptable solution.
It just means that with a default installation there will be no random freezes when using drivers with flaky opengl support.

Tormod Volden (tormodvolden) wrote :

> Then we can close this bug..
IMO, the bug would still be valid, because if the screensaver is set to "Random" it should not cause extreme CPU utilisation.

Oliver Grawert (ogra) wrote :

gnome-screensaver should currently be set to the floating ubuntulogo screensaver by default ... that fixes the symptom for fresh installs, but indeed the bug is still present ...

You are right.

Yet its a much smaller group of users that even cares or changes the screensaver. At least a freshly installed PC with an 'old' ati card or matrox card won't randomly crash now. I know, the drivers are to blame, but the drivers don't promise stable 3d support.

And well, I wouldn't know which logs to post that will help fix driver issues. Perhaps someone can enlighten me? I still have the same bunch of company pc's running dapper at some clients with old ati and matrox cards. I fear I need to install some special debug version right? Maybe I should just track down what is causing the crashes when opengl is used..

Tormod Volden (tormodvolden) wrote :

> Yet its a much smaller group of users that even cares or changes the screensaver.
I don't agree, I find many people are impressed by the included screensavers, and it's one of the first thing a curious desktop user would like to customize and play with...

Ralf, several 3D-crashing bugs have been fixed lately, or have available workarounds, please have a look at https://wiki.ubuntu.com/Bugs/AtiDriver For instance bug #16773 has a test package for Dapper you might want to try out.

Tormod Volden (tormodvolden) wrote :

Sorry I meant bug #16873 and not 16773.

ubik (janekindred) wrote :

So I see the saga continues, 8.04 is shipped with open-gl screensavers by default, so I constantly have to restart X... (see https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/71030/comments/9)

Changed in gnome-screensaver:
importance: Unknown → Medium
Changed in gnome-screensaver:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.