Ubuntu

[Dapper] gnome-screensaver starts when playing a movie with xine

Reported by Loïc Martin on 2006-02-28
10
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Medium
Oliver Grawert

Bug Description

On Dapper, gnome-screensaver start even though a movie is played using xine. That was not the case on Breezy, with Xscreensaver.

Oliver Grawert (ogra) wrote :

which player exactly, libxine itself has no screensaver code

Changed in gnome-screensaver:
assignee: nobody → ogra
Loïc Martin (loic-martin3) wrote :

I've just installed gxine on Dapper since totem-xine conflicts with gstreamer. And gxine is "A GTK media player front end for xine-lib"... :)
But I also installed xine-ui in Dapper and the same problem occurs. I didn't try gxine on Breezy to see if it would also prevent xscreensaver to start but my guess is it would. Any video player that isn't doing that would be considered as quite crippled.

Loïc Martin (loic-martin3) wrote :

Forgot to say that xine-ui was ok in breezy with xscreensaver (if it wasn't for the dumb christmas logo at startup :D ).

Oliver Grawert (ogra) wrote :

ok, will look at these two, thanks for checking :) (totem is fixed upstream since a while)

Loïc Martin (loic-martin3) wrote :

>(totem is fixed upstream since a while)

I should have said totem-gstreamer conflicts with totem-xine, sorry for being misleading

Oliver Grawert (ogra) wrote :

thats only the backend behind the player ...

gxine issues ScreenSaverReset through XForceScreenSaver or sends a fake keypress all 40 seconds, this patch adds gnome-screensaver support to that function

Oliver Grawert (ogra) wrote :

the above patch is contained in gxine version 0.5.1-0ubuntu4

Loïc Martin (loic-martin3) wrote :

Thanks a lot. I'll test the patch when they'll be into the updates for Dapper (both for xine and vlc)

Loïc Martin (loic-martin3) wrote :

Man, that sure was faaaaaaast.
gxine doesn't have pb anymore.
OTOH, xine-ui still does.

Oliver Grawert (ogra) wrote :

sorry, xine took a bit longer ... the fix is contained in xine-ui 0.99.4-0ubuntu4

Changed in gnome-screensaver:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers