gnome-screensaver freezes and does not bring up the password prompt if mouse/keyboard activity

Bug #213099 reported by Craig Magina on 2008-04-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-screensaver

Description: Ubuntu hardy (development branch)
Release: 8.04

gnome-screensaver:
  Installed: 2.22.1-0ubuntu1
  Candidate: 2.22.1-0ubuntu1
  Version table:
 *** 2.22.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

I can <Ctrl>+<Alt>+<Del> and the machine will reboot but the password prompt does not come up with normal activity and the screensaver itself appears frozen.

I'm having the same issue here since I've updated to intrepid
I'm running it on a macbook 1.1 and have compiz enabled

cpu: Genuine Intel(R) CPU T2500 @ 2.00GHz
gpu: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

$ dpkg -l gnome-screensaver |awk {'print $2" "$3'}
gnome-screensaver 2.23.3-0ubuntu1

I have to hold the power button to shut down the machine. No mouse/keyboard input seems to work. I don't think the system itself hangs as it responds to ping. Haven't tried logging on remotely though...

Alchera (barrysuridge) wrote :

I just upgraded to a new system and have this issue with the gnome-screensaver after I left it running over night. Normally, I turn off the screen saver and simply turn the monitor off; except for last night.

OS: Linux Ubuntu 8.04 - hardy Kernel: 2.6.24-21-generic, GNU/Linux
CPU: AMD Phenom(tm) 9550 Quad-Core Processor
GPU: ATI Technologies Inc Radeon HD 3200 Graphics

gnome-screensaver 2.22.2-0ubuntu1

Massimo Cora' (pescio) wrote :

I've got this too. Seldomly the screensaver hangs when I want to login back.
It happens with more frequence if I leave an image moving, i.e. not a balck screen.

I'm on an hardy, hp compaq d330 DT.

kernel: 2.6.24-21-generic #1 SMP

Pedro Villavicencio (pedro) wrote :

Thanks for the report, is this still an issue? Do you get the same with Intrepid? Which video card do you have and which driver are you using? Does it happens while you have the visual effects enabled? does it happens without them? Could you provide your X logs? after reproduce the issue? thanks.

Changed in gnome-screensaver:
importance: Undecided → Low
status: New → Incomplete
Alchera (barrysuridge) wrote :

This might actually involve gnome-power-manager.

What occurred with me (above) was a once off but devolved (later) into the monitor going into stand-by mode and being unable to have the system respond to the keyboard or/and mouse whenever gnome-screensaver was enabled.

After much research I did the following:

Open gconf-editor. Open 'apps' and scroll down to gnome-power-manager~actions and set sleep_type_acc to 'nothing'. Reload the desktop.

The problem(s) went away (for me).

OS: Linux Ubuntu 8.04 - hardy Kernel: 2.6.24-21-generic, x86_64 GNU/Linux
CPU: AMD Phenom(tm) 9550 Quad-Core Processor
GPU: ATI Technologies Inc Radeon HD 3200 Graphics

gnome-power-manager 2.22.1-1ubuntu4
gnome-screensaver 2.22.2-0ubuntu1

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Invalid
Zaris (zaris) wrote :

Same (similar?) problem here:
When in screen saver, it allways takes 1 minute to return the login window. Both compiz enabled or not. After display switched off (10 minutes), returns normally. gconf-editor sleep_type_ac setting had no effect.
Running 9.04. Latest ATI driver catalyst-96 from AMD site.
AMD 64 X2 5200+.
GPU: ATI Technologies Inc Radeon HD 3200 Graphics

Changed in gnome-screensaver (Ubuntu):
status: Invalid → Incomplete
Derek (bugs-m8y) wrote :

I'm tentatively thinking this might be the same behaviour I've been experiencing.
Wanted to note I've run into similar reports with wildly different systems while browsing launchpad, in different bugs, that sound the same.
I'm posting in this one since I'm thinking the freeze might not actually be a freeze, and wondering if he tried typing his browser in blindly.

http://groups.google.com/group/mailing.freebsd.ports/browse_thread/thread/17dfe69c76c7eb5a

For example.

In my case, same behaviour. Any OpenGL screensavers cause an invisible password dialog that I can fortunately still type my password into, but the screensaver does appear frozen in the interim.

This doesn't seem hardware dependant to me, perhaps related to some refresh or somesuch that is not being performed since if CTRL-ALT-F1 to a terminal, the dialog instantly appears as switching over, and is still there when ALT-F7 back to the X session.

Running Karmic, Compiz, Gnome, Radeon HD 4670 w/ fglrx 2:8.660-0ubuntu2 but this does seem card independant.

Nothing is reported to dmesg, Xorg.0.log, or xsession-errors.

I'm in fact not totally sure it belongs in this bug, unfortunately, but hesitant to file a new one.

Thomas O. (thomas-tgohome) wrote :

I too am experiencing this bug. I can type my password in blindly for now, and Ctrl-Alt-F1 followed by Ctrl-Alt-F7 fixes it temporarily.

ATI Mobility Radeon HD 3450 on a Dell Studio 15.

Bug is new in Karmic. intrepid and Jaunty did not have this bug.

mithereal (mithereal) wrote :

i was able to extract an error from this issue
i think it has to do with the power management and karmic

steps:
1. i went to system>>preferences>>screensaver
2. Clicked on power management tab and then things started to get wierd.
3. the dialogs on all my open windows dissappeared
4. 45 sec later the whold desktops diaglos dissapeared.
5. i ctl-f1 into the console and the message scrolling was

[1125.027386] << #s change
Ext4-fs error (device sda3): htree_dblock_to_tree: bad entry in directory # 123022: inode out of bounds - offset=0,inode=26673152,rec_len4096,mode_len=45

Neways hope this helps

In Karmic i no longer have this issue

mithereal: that's a corrupted filesystem, you should do an fsck on your sda3

Pedro Villavicencio (pedro) wrote :

thanks for the feedback, closing the bug.

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Invalid
Zaris (zaris) wrote :

I experienced this problem again (unlock dialog is invisible when trying to unlock screensaver). It seems to be a problem only for xscreensaver-gl themes. Maybe also with fast user switching or special effects is contributing to this...

aproposnix (rimez) wrote :

i'm experiencing this issue in Ubuntu 11.04 (64bit). The freezes do not happen every time, it's random. I am not able to enter into a console when this happens either so I have to shutdown the system forcibly.

If I move my cursor around when it freezes, the cursor sometimes turns to a caret. I try to blindly enter my password but it doesn't work.

Dawid Toton (d0) wrote :

Sometimes after my eeepc is awakened, the password prompt is not displayed. i see a blank screen instead.
I can see the mouse cursor moving. I can switch consoles (Ctrl+Alt+F1).
I've noticed that gnome-screensaver eats 100% cpu when I'm waiting for the prompt. Afteer something like minute it comes back OK.

Running Ubuntu 10.04.4 LTS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers