White screen at first preview of "Black screen" screensaver theme

Bug #199112 reported by Yuri Glushkov on 2008-03-06
8
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Fix Released
Low
gnome-screensaver (Ubuntu)
Low
Ted Gould

Bug Description

After running gnome-screensaver-preferences and applying preview with "Black screen" screensaver theme selected, the screen is white instead of black. It happens only at first time, subsequent previews are OK.
Screenshot is attached.

Laptop MSI EX600 (Intel Core2 Duo T7100 1.8 GHz, 2 GB DDR2 667MHz RAM, NVIDIA GeForce 8400M GS, 120 GB HDD), Ubuntu Gutsy Gibbon 7.10 32 bit

Yuri Glushkov (yglushkov) wrote :
Yuri Glushkov (yglushkov) wrote :

The problem persists on Hardy Heron 32 bit.

Trevor Schauls (trevorschauls) wrote :

Affects the preview in Intrepid 8.10 amd64 and gnome 2.23.4. Does not affect the actual screen-saver from showing up properly.

Neil J. Patel (njpatel) wrote :

This is caused because the fullscreen preview window isn't cleared before it's shown. Patch attached, it's a one line change which should work for Hardy + Intrepid.

Pedro Villavicencio (pedro) wrote :

Ted, may you take a look to it? thanks.

Changed in gnome-screensaver:
assignee: nobody → ted-gould
importance: Undecided → Low
status: New → Confirmed
Michael Terry (mterry) wrote :

Here's a debdiff for jaunty.

Changed in gnome-screensaver:
status: Unknown → Fix Released
Changed in gnome-screensaver:
milestone: none → ubuntu-9.04-beta
Daniel Holbach (dholbach) wrote :

Good work, Michael and Neil!

I just updated the debdiff in a few parts:
 - made use of https://wiki.ubuntu.com/UbuntuDevelopment/PatchTaggingGuidelines
 - updated 'hardy' to 'jaunty'
 - reformatted the changelog a bit

Will test and upload in a bit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 2.24.0-0ubuntu4

---------------
gnome-screensaver (2.24.0-0ubuntu4) jaunty; urgency=low

  * debian/patches/07_fix_blank_screen_preview.patch: The blank screen screen
    saver is not consistent in preview and actual mode, clear the preview
    window before showing it. Patch by Neil J. Patel was included upstream.
    (LP: #199112)

 -- Michael Terry <email address hidden> Fri, 16 Jan 2009 14:31:13 -0500

Changed in gnome-screensaver:
status: Confirmed → Fix Released
Sitsofe Wheeler (sitsofe) wrote :

(Just for the record, this is a dup of Bug #105836)

Michael Terry (mterry) on 2009-10-20
tags: added: oem
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
removed: oem
Changed in gnome-screensaver:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.