System freezes after locking screen

Bug #1685141 reported by Markus Schmees on 2017-04-21
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Undecided
Unassigned

Bug Description

When locking the screen or whenever the screensaver starts automatically, I cannot log in again, but my system completely freezes and I have to restart the computer. In most cases I was able to do the restart by pressing Alt-REISUB, in some cases however I had to do a hard reset. This is a new bug in zesty (Ubuntu 17.04). In the previous version everything worked fine. I tested both the upgrade and a fresh new installation on the same computer. Package is gnome-screensaver version 3.6.1-7ubuntu5.

I attach an excerpt from my syslog. Hope this might help to find the bug.

I installed zesty on another computer (laptop) as well and there the bug did not appear. So I assume it has something to do with the installed graphics card or graphics driver. Installed graphics card in this case is: NVIDIA Corporation GF108 [GeForce GT 630] (rev a1).

Update: After a few days the bug now appears on the second computer as well. However, I could unlock the screen and continue working, until suddenly (an hour later or so) the whole system froze. I add the kernel-nullpointer-dereference syslog of this event (syslog2.txt) to the attachments for this bug.

Markus Schmees (markus-schmees) wrote :
Markus Schmees (markus-schmees) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
Mike Clark (mwclark) wrote :

I switched from the open source xserver-xorg-video-nouveau driver to nvidia-375 in the Additional Drivers tab of the Software & Updates application and was able to recover after locking my screen with Ctrl-Alt-L, which was locking up my mouse and keyboard before.

François (jaes) wrote :

Can wonfirm mwclark method. I installed the fitting driver through "ubuntu-drivers autoinstall" and for now it seems to have solved the problem.

Might be more of a nouveau bug then.

François (jaes) wrote :

Well, ignore what I wrote above. The bug occured to me this morning.

I still have the kernel trace in the syslog, but taking a closer look at my logs, it seems it occured earlier and not just when reactivating the screen.

Might be related to the displaying of notification by the locked screen. I'll try to disable that.

Hi, I've been experiencing this bug too.

I'm using nvidia proprietary drivers, v381.

I do have an Optimus laptop, I'll try to see if this also happens with the Intel drivers.

I tried it with the Intel Graphics and it also happens.

I locked and unlocked once without a problem, the second time it froze on me. Had to reboot the PC.

her (herodopman) wrote :

Same happened to me. For whatever reason both Intel Microcode and nvidia proprietary drivers were not used after upgrade from 16.10.

The installation of the nvidia proprietary drivers (alone) didn't solve the problem. But now, after additionally installing microcodes it seems to work.

I will Inform if the lock-screen issue returns.

François (jaes) wrote :

I think I found a workaround. I noticed the traceback I saw in syslog happened a lot before I tried to log back in and I deduced it happened when notification were displayed on my locked screen.

Since I disabled notifications on my lock screen (Notifications > Notifications on lock screen) I haven't encountered the bug anymore.

It seems, using the proprietary NVIDIA-driver works for me.

IA (stoutlaw) wrote :

@jaes I'm not sure how you disabled notifications on the lock screen as I'm unable to find any settings along the lines of what you described on stock 17.04.

Unfortunately I cannot switch to the proprietary Nvidia drivers (v375.39) because using it I am unable to boot :(

The last thing I want to do is downgrade to Ubuntu 16.04 LTS but the current situation is untenable. Does anyone else have any other ideas?

François (jaes) wrote :

@stoutlaw You can disable it through the settings panel in the "Notifications" section.

Paulo Canedo (paulocanedo) wrote :

Also affects me. AMD GPU.

Pépou (yannickw24) wrote :

Also affected by this very annoying bug

-Ordinateur-
Processeur : Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Mémoire : 16319MB (4588MB utilisé)
Machine Type : Notebook
-Affichage-
Résolution : 1920x1080 pixels
OpenGL Renderer : Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Adapteur Audio : HDA-Intel - HDA Intel PCH

Otto (otto11235) wrote :

I also had this problem with AMD64 & Nvidia Geforce, but it doesn't actually freeze the system, you just can't get out of the screen lock.
I solved it by un-checking the option to show notifications on the lock screen - no problems since then.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers