Screen temporarily not locked when coming out of suspend

Bug #1509711 reported by svenmeier on 2015-10-24
296
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
High
Unassigned

Bug Description

When I resume my notebook after suspend, the desktop with all open applications is displayed for about 1-2 seconds until the password prompt finally is shown. This happens every time when resuming in Ubuntu 15.10.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: gnome-screensaver (not installed)
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Oct 24 22:19:07 2015
InstallationDate: Installed on 2015-04-27 (180 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: gnome-screensaver
Symptom: security
Title: Screen not locked when coming out of suspend/hibernate
UpgradeStatus: Upgraded to wily on 2015-10-11 (13 days ago)

svenmeier (sven-meiers) wrote :
information type: Private Security → Public Security
Changed in gnome-screensaver (Ubuntu):
status: New → Triaged
Changed in gnome-screensaver (Ubuntu):
importance: Undecided → High
Harry P (hjwp2) wrote :

I reported the dupe at https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1508148. This bug has been around for a couple of releases I'd say, definitely as far back as 14.04...

svenmeier (sven-meiers) wrote :

The problem does no longer show up with kernel 4.4.0.

@hjwp2: perhaps you could try out the mainline kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/ too?

Harry P (hjwp2) wrote :

Since the upgrade to Xenial, I haven't seen this bug. Unless it affects any other LTS editions, I guess it's ok to close?

svenmeier (sven-meiers) wrote :

I can no longer reproduce this with 16.10, thus it can be closed.

I experience this sometimes (currently running 16.04 LTS), you can easily enlarge the time by:

* high load, have processes running taking 100% CPU
* a lot of used RAM
* slow I/O (hard disk)

E.g., on a netbook, I was regularly even able to type in commands on open shells, start or close programs.
It still happens on a decent machine, but less often and with much shorter "flashing".

Pander (pander) wrote :

This also occurs in Lubuntu 18.10 with xscreensaver, LXQt and sddm

tags: added: cosmic
Pander (pander) on 2018-12-04
tags: added: bionic
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers