[patch] Please display clock in screen lock

Bug #1265610 reported by Michael Vogt on 2014-01-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Wishlist
Unassigned

Bug Description

The current gnome-screensaver will not display the top panel under unity. This is fine as it does not fit with unity, however I really like the clock. Attached is a debdiff (and a updated 17_remove_top_panel.patch) that will show only the clock.

If this looks good to you I'm happy to upload it myself, just want to make sure I don't step on any toes with this change. But I do really like a clock on my screensaver :)

Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

This update will also fix the:
(gnome-screensaver:19385): Gtk-CRITICAL **: gtk_widget_set_visible: assertion 'GTK_IS_WIDGET (widget)' failed

messages that I noticed while testing my patch (note that this message is caused by the original patch, not my version :)

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thanks for the work!

I'm not opposed to have the feature in principle, I'm unsure about the UI
- the clock is centered, would it be better in the top right (closer from what the desktop is doing)?
- on a dual monitor, it's displayed on both screens (where one has the bg/dialog and the other one is all empty otherwise)
- it's orthogonal but we were speaking about making the lock screen closer from the unity-greeter for the LTS

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

I put the clock on the right now and I don't mind if this gets removed in favor of a better lockscreen

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 3.6.1-0ubuntu9

---------------
gnome-screensaver (3.6.1-0ubuntu9) trusty; urgency=low

  * debian/patches/17_remove_top_panel.patch:
    - display time in lock screen (LP: #1265610)
 -- Michael Vogt <email address hidden> Tue, 07 Jan 2014 19:21:20 +0100

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments