No focus to enter password after suspension

Bug #1175717 reported by S. Patrikios on 2013-05-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Gnome desktop 3.8, after latest update 5min ago:

Opening up system after suspension, there is no focuson "Password" field to enter password.
I have to press "Switch user" to be able to log-in.

lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

 apt-cache policy gnome-shell
gnome-shell:
  Installed: 3.8.1-0ubuntu1~raring1.2
  Candidate: 3.8.1-0ubuntu1~raring1.2
  Version table:
 *** 3.8.1-0ubuntu1~raring1.2 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     3.6.3.1-0ubuntu6 0
        500 http://gr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1175717/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-05-03
affects: ubuntu → gnome-screensaver (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 3.6.1-0ubuntu8

---------------
gnome-screensaver (3.6.1-0ubuntu8) trusty; urgency=medium

  * debian/patches/move_not_nuke.patch: When trying to acquire a contentious
    keyboard grab, don't nuke input focus, but instead move it to new grab
    window before taking grab (LP: #1175717)
 -- Iain Lane <email address hidden> Tue, 07 Jan 2014 16:31:45 +0000

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Fix Released

Need that fix for 12.04 gnome-screensaver 3.4.1-0ubuntu1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers