gnome-schedule crashes on start

Bug #419471 reported by Tanath
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Gnome Schedule
Fix Released
Critical
gnome-schedule (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Paul Natsuo Kishimoto

Bug Description

Version: 2.1.0-0ubuntu1
Distro: 9.10

Gnome-schedule window displays briefly, then quits. Output in terminal:

/usr/share/gnome-schedule/mainWindow.py:158: DeprecationWarning: Use the new widget gtk.Tooltip
  tip = gtk.Tooltips ()
/usr/share/gnome-schedule/mainWindow.py:159: DeprecationWarning: Use the new widget gtk.Tooltip
  tip.enable ()
Traceback (most recent call last):
  File "/usr/share/gnome-schedule/gnome-schedule.py", line 74, in <module>
    mainWindow = mainWindow.main(debug_flag, False, pr, manual_poscorrect)
  File "/usr/share/gnome-schedule/mainWindow.py", line 257, in __init__
    self.schedule_reload ()
  File "/usr/share/gnome-schedule/mainWindow.py", line 304, in schedule_reload
    data = self.crontab.read ()
  File "/usr/share/gnome-schedule/crontab.py", line 438, in read
    array_or_false = self.parse (line)
  File "/usr/share/gnome-schedule/crontab.py", line 604, in parse
    success, ver, title, desc, output, display, command_d = self.get_job_data (job_id)
  File "/usr/share/gnome-schedule/crontab.py", line 690, in get_job_data
    return True, ver, title, desc, output, display, command_d
UnboundLocalError: local variable 'display' referenced before assignment

Revision history for this message
GauteHope (eg) wrote :

This happens when you create a one-time task in gnome-schedule 2.0.2 and try to open it in 2.1.0. There is a bug in the parser of the data files.

This has been fixed in upstream and will be included in the next minor release; to manually delete your old tasks. Do in the terminal:

$ atq # to display all tasks, the first number is the job id
$ atd [number] # on all the numbers that showed up in atq

go to the gnome-schedule data dir:
$ cd ~/.gnome/gnome-schedule/at/
$ rm * # delete all files in the directory

- gaute

Changed in gnome-schedule:
status: Unknown → Fix Released
Revision history for this message
Tanath (tanath) wrote :

Actually, it was an hourly task, but thanks. I await the fix.

On a side note, I only wanted to view the task, as it contained a URL I needed, and 'atq' gives me no output (and there's nothing in ~/.gnome/gnome-schedule/at/ to delete).

Revision history for this message
GauteHope (eg) wrote : Re: [Bug 419471] Re: gnome-schedule crashes on start

Sincs it is an hourly task you have to use crontab, to edit your crontab
manually do:

$ crontab -e

To just list it:
$ crontab -l

In fact, just deleting the data files should make gnome-schedule use
some default values. They are located in ~/.gnome/gnome-schedule/crontab

$ cd ~/.gnome/gnome-schedule/crontab/ && rm *

In case that doesn't work you could delete your entire crontab
(scheduled recurrent tasks) with:

$ crontab -d

- gaute

Excerpts from Tanath's message of to. aug. 27 17:29:31 UTC 2009:
> Actually, it was an hourly task, but thanks. I await the fix.
>
> On a side note, I only wanted to view the task, as it contained a URL I
> needed, and 'atq' gives me no output (and there's nothing in ~/.gnome
> /gnome-schedule/at/ to delete).
>

Revision history for this message
Tanath (tanath) wrote :

Deleting the crontab files did the trick. And I didn't lose the task. Thanks. :)

Revision history for this message
GauteHope (eg) wrote :

For the gnome-schedule packagers:

I strongly recommend to upgrade to version 2.1.1 since this bug in 2.1.0 will result in almost all users having this problem when upgrading without a clean crontab.

Thanks, Gaute Hope

Changed in gnome-schedule (Ubuntu):
status: New → Confirmed
Revision history for this message
59chip (schiappetta) wrote :

How do I upgrade to 2.1.1? It is not available in Synaptic Package Manager, only shows version 2.1.0

Revision history for this message
new_tolinux (dutchsupervisor) wrote :

I tried deleting everything in ~/.gnome/gnome-schedule/crontab/
Result: gnome-schedule working again without losing my tasks. Thanks

Revision history for this message
xachin (sachinssharma) wrote :

I deleted everything in ~/.gnome/gnome-schedule/crontab and it worked.

Now I have a task that runs from root, which I added using "sudo gnome-schedule". Where does gnome-schedule store root tasks?

Revision history for this message
GauteHope (eg) wrote :

@xachin:

The datafiles are stored in roots home dir: /root/.gnome/gnome-sche...

The tasks are in roots crontab or at-queue; try sudo su to become root and then try the fix as with a regular user.

- gaute

Revision history for this message
xachin (sachinssharma) wrote :

Thanks Gaute - That worked!

Revision history for this message
Asif Youssuff (yoasif) wrote :

I deleted everything in ~/.gnome/gnome-schedule/crontab and it worked.

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

The quick fix suggested by GauteHope works, but I agree with #5: this needs an SRU. Otherwise, all users who used gnome-schedule 2.0.2 in Jaunty before updating to Karmic will experience this bug. By popularity contest results (http://popcon.ubuntu.com/by_inst), that may be as many as 17000 people.

Revision history for this message
GauteHope (eg) wrote :

On Sun, Nov 1, 2009 at 4:13 PM, 59chip <email address hidden> wrote:
> How do I upgrade to 2.1.1?  It is not available in Synaptic Package
> Manager, only shows version 2.1.0

It isn't in the repositories yet. See:
http://git.gnome.org/cgit/gnome-schedule/tree/README for building from
source.

The tarball can be found at:
http://sourceforge.net/projects/gnome-schedule/files/gnome-schedule-2/gnome-schedule-2.1.1/gnome-schedule-2.1.1.tar.gz/download

- gaute

Changed in gnome-schedule:
importance: Unknown → Critical
Revision history for this message
... (bugs-launchpad-net-pravec) wrote :

i use ver 2.1.1 of gnome-schedule in ubuntu and this message still appears on my machine.

user@host:~$ sudo gnome-schedule
/usr/share/gnome-schedule/mainWindow.py:158: DeprecationWarning: Use the new widget gtk.Tooltip
  tip = gtk.Tooltips ()
/usr/share/gnome-schedule/mainWindow.py:159: DeprecationWarning: Use the new widget gtk.Tooltip
  tip.enable ()

i already deleted files in folder /root/.gnome/gnome-schedule/crontab. after starting crontab as sudo again, i can edit an existing job. after pressing button "anwenden" there will be a file named 1 in this dir again. everything works fine so far, tooltips also work so i will ignore this message but ... something must be wrong.

i don't think this is a critical thing

Revision history for this message
GauteHope (eg) wrote :

The files in .gnome/gnome-schedule should stay there. Don't delete it unless you have the problems described on top! They are necessary for gnome schedule.

The deperactionwarning doesn't have anything to do with it, and is simply because the GTK+ toolkit is changing as it is being developed. It is nothing to be worried about.

Regards, Gaute

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.