Ubuntu

gnome-raw-thumbnailer doesn't do anything

Reported by Cory Maccarrone on 2011-09-18
268
This bug affects 61 people
Affects Status Importance Assigned to Milestone
gnome-raw-thumbnailer (Ubuntu)
Undecided
Unassigned

Bug Description

I have a lot of nikon .nef raw files that I'd like thumbnailed. This worked perfectly in natty. So, I install gnome-raw-thumbnailer. I see it set up the correct gconf entries, and yet, no thumbnails.

Running it by hand revealed that it also doesn't return anything nor create any files. An strace (attached) shows that the source and destination files are never accessed before it returns -1 and exits.

Without this, going through my many hundreds of RAW files will be extremely difficult. Also, again, this was working in Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-raw-thumbnailer 2.0.1-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic-pae 3.0.4
Uname: Linux 3.0.0-11-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Sat Sep 17 17:05:03 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110904)
SourcePackage: gnome-raw-thumbnailer
UpgradeStatus: No upgrade log present (probably fresh install)

Cory Maccarrone (darkstar6262) wrote :
Cory Maccarrone (darkstar6262) wrote :

Adding the strace

sam tygier (samtygier) wrote :

I am also seeing this on oneiric with canon CR2 files.

Also EOG is not rendering my raw files anymore, maybe this is related Bug #860672

dFlyer (ggaribaldi) wrote :

I'm also noticing this on 11.10 with both canon cr2 and sony arw file

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-raw-thumbnailer (Ubuntu):
status: New → Confirmed
Paul d'Aoust (paul) wrote :

Confirmed with Pentax PEF files as well.

ed10vi (ed10vi86) wrote :

I fixed it changing in /usr/share/thumbnailers/raw.thumbnailer the %i for %u

dFlyer (ggaribaldi) wrote :

I didn't have the file /usr/share/thumbnailers/raw.thumbnailer so just copied and pasted this in gedit using sudo and saved the file as raw.thumbnailer. Everything is working now.

The result:[CODE][Thumbnailer Entry]
Exec=/usr/bin/gnome-raw-thumbnailer -s %s %u %o
MimeType=image/x-3fr;image/x-adobe-dng;image/x-arw;image/x-bay;image/x-canon-cr2;image/x-canon-crw;image/x-cap;image/x-cr2;image/x-crw;image/x-dcr;image/x-dcraw;image/x-dcs;image/x-dng;image/x-drf;image/x-eip;image/x-erf;image/x-fff;image/x-fuji-raf;image/x-iiq;image/x-k25;image/x-kdc;image/x-mef;image/x-minolta-mrw;image/x-mos;image/x-mrw;image/x-nef;image/x-nikon-nef;image/x-nrw;image/x-olympus-orf;image/x-orf;image/x-panasonic-raw;image/x-pef;image/x-pentax-pef;image/x-ptx;image/x-pxn;image/x-r3d;image/x-raf;image/x-raw;image/x-rw2;image/x-rwl;image/x-rwz;image/x-sigma-x3f;image/x-sony-arw;image/x-sony-sr2;image/x-sony-srf;image/x-sr2;image/x-srf;image/x-x3f;

Cory Maccarrone (darkstar6262) wrote :

I can confirm, that works for me as well. I also didn't have a raw.thumbnailer file, but creating it fixed the problem.

I notice there's thumbnailer entries in gconf, but they seem to be ignored.

tomjo78 (tommi-johnsson) wrote :

This fix doesn't work on my computer. Ubuntu 11.10 amd 64bit

ed10vi (ed10vi86) wrote :

Maybe you are pasting [CODE]
This is the file that have to ne placed in /usr/share/thumbnailers/

tomjo78 (tommi-johnsson) wrote :

No but "[Thumbnailer Entry]" was missing from a file. I did make copy - paste from a file of yours and now it works fine. Thank you !

Andrew Waldram (awaldram) wrote :

This work around may not work for some cameras as gnome-raw-thumbnailer is not in active development and has not been updated in years.

People wishing to use ufraw for thumbnail duties should amend the exec line to read

exec=/usr/bin/ufraw-batch --embedded-image --out-type=png --size=%s %u --overwrite --silent --output=%o

Giving

[Thumbnailer Entry]
Exec=/usr/bin/ufraw-batch --embedded-image --out-type=png --size=%s %u --overwrite --silent --output=%o
MimeType=image/x-3fr;image/x-adobe-dng;image/x-arw;image/x-bay;image/x-canon-cr2;image/x-canon-crw;image/x-cap;image/x-cr2;image/x-crw;image/x-dcr;image/x-dcraw;image/x-dcs;image/x-dng;image/x-drf;image/x-eip;image/x-erf;image/x-fff;image/x-fuji-raf;image/x-iiq;image/x-k25;image/x-kdc;image/x-mef;image/x-minolta-mrw;image/x-mos;image/x-mrw;image/x-nef;image/x-nikon-nef;image/x-nrw;image/x-olympus-orf;image/x-orf;image/x-panasonic-raw;image/x-pef;image/x-pentax-pef;image/x-ptx;image/x-pxn;image/x-r3d;image/x-raf;image/x-raw;image/x-rw2;image/x-rwl;image/x-rwz;image/x-sigma-x3f;image/x-sony-arw;image/x-sony-sr2;image/x-sony-srf;image/x-sr2;image/x-srf;image/x-x3f;

The genuine fix is all package maintainers repackage all Ubuntu raw thumbnailers to support the current gnome desktop method of producing thumbnails.

Is there anyone that can point to documentation on how exactly this thumbnailer thing works in Gnome3? Because simply dropping the *.thumbnailer file in /usr/share/thumbnailers does not work, so there must be some additional step. Only doc I was able to find was the old, Gconf-based method. Thanks in advance...

(By the way, the mime-type of panasonic rw2 raw files is image/x-panasonic-rw2, not image/x-rw2...)

plmegalo (p-lagarde) wrote :

Copying the file at post #11 to /usr/share/thumbnailers directory worked for me on LinuxMint 12 Lisa 64 bits, with CR2 Canon files. Thanks :D

The Bright Side (me-knowingme) wrote :

Still occurs on my system even after applying all the workarounds listed above. Reinstalled gnome-raw-thumbnailer from the repos again, too. When going into icon mode, I see blank rectangles in Nautilus.

Oddly, it works just swell on my laptop PC. Same distro on both machines: Ubuntu 11.10 64 bit.

sam tygier (samtygier) wrote :

fix in #11 works for me to, with crw and cr2 files.

eros2 (eros2) wrote :

#8 and #13 works for me, when files resides on local file system, but does not work when I attach camera and open it in nautilus. Location is "gphoto2://[usb:001,008]/DCIM/100CANON".

Grzegorz G. (grzesiek1e5) wrote :

On Precise this file works for me: (attachment) But why I had to manually add it to /usr/share/thumbnailers ? It should be added automatically.

tags: added: gnome nautilus precise raw thumbnail thumbnailer
tags: added: packaging
Veit (shoutbox) wrote :

Fix in #20 is working for my Canon .CR2-files on Ubuntu 12.04 64bit. Thank you Grzegorz!

sordoman (sordoman) wrote :

Fixed!!! with #20 post , Camera Canon .CR2 Ubuntu 12.04 64 bit. :)

crazybyte (vlzoltan) wrote :

Both fixes #8 and #13 work for me on Ubuntu 12.04 32bit. Thank you dFlyer and Andrew! :)

Marcel Kolaja (marcel.kolaja) wrote :

For Canon EOS 500D, #8 doesn't work (produces a white thumbnail) but #13 works. Precise 64bit.

Chris Wilson (notgary) wrote :

Thanks a lot for reporting this, however since gnome-raw-thumbnailer doesn't come installed on the default CD, this doe snot qualify as a papercut.

Changed in hundredpapercuts:
status: New → Invalid
Graeme (unit3) wrote :

Fix from comment #20 works for me too, 12.04/x64. Would greatly like to see this make it into the official package for 12.10.

Jose Luis Tirado (txelu70) wrote :

I make it work using the fix from comment #13. If gnome-raw-thumbailer is a dead road I prefer to go with ufraw-batch. In any case, this should work out of the box.

Hi all,

Found that there is an equivalent - almost identical thumbnailer setup for Mate.

Still locate /usr/share/thmbnailers/raw.thumbnailer.

only the Exec line is different in that /usr/bin/thumbnail is used in stead of gnome.

Content >

[Thumbnailer Entry]
Exec=/usr/bin/thumbnail -s %s %u %o

MimeType=image/x-3fr;image/x-adobe-dng;image/x-arw;image/x-bay;image/x-canon-cr2;image/x-canon-crw;image/x-cap;image/x-cr2;image/x-crw;image/x-dcr;image/x-dcraw;image/x-dcs;image/x-dng;image/x-drf;image/x-eip;image/x-erf;image/x-fff;image/x-fuji-raf;image/x-iiq;image/x-k25;image/x-kdc;image/x-mef;image/x-minolta-mrw;image/x-mos;image/x-mrw;image/x-nef;image/x-nikon-nef;image/x-nrw;image/x-olympus-orf;image/x-orf;image/x-panasonic-raw;image/x-pef;image/x-pentax-pef;image/x-ptx;image/x-pxn;image/x-r3d;image/x-raf;image/x-raw;image/x-rw2;image/x-rwl;image/x-rwz;image/x-sigma-x3f;image/x-sony-arw;image/x-sony-sr2;image/x-sony-srf;image/x-sr2;image/x-srf;image/x-x3f;

I hope that helps.

/usr/bin/thumbnail provides same support as /usr/bin/gnome-raw-thumbnailer

confirmed the solution of #8 etc. The problem is in the configuration, not in the executable.

Cory, FYI, I got the same strace of yours. The problem is that the first parameter is supposed to be an uri, while you were probably testing with a file. Trying "gnome-raw-thumbnail file:///path/to/some.NEF out" the out file is generated no problem. The issue is in the configuration.

Frédéric CORNU (fcornu) wrote :

Propsed sultion in post #8 is OK

Confirmed on a fresh 12.04 install + updates, 64 bits with Canon .CR2 files

Noe (noecordmart) wrote :

Confirmed solution #8 on 12.04 x64 using Canon .CR2 RAW files.

Adrien Lamothe (alamo) wrote :

This is also a problem in Ubuntu 12.04.

Paul Barron (paul-barron) wrote :

13 worked for me, 8 didn't,
gnome-raw-thumbnailer 2.0.1-0ubuntu6
Release 12.04 (precise) 64-bit,
Kernel Linux 3.2.0-32-generic,
GNOME 3.4.2, 7.8 GiB,
AMD Phenom(tm) 9850 Quad-Core Processor × 4,
thanks so much photo work with canon CR2 files is going to be so much easier now

Stolen (colin-shaw) wrote :

Just used #8 to get NEF thumbnails working on 12.10.

Chris Wilson (notgary) on 2012-11-05
no longer affects: hundredpapercuts
Miguel Rozsas (marozsas) wrote :

just to confirm that creating the file /usr/share/thumbnailers/raw.thumbnailer with the [Thumbnailer Entry] as above it works on an fresh install of Ubuntu 12.10 64 bits to display thumbnails of NEF files generated by a Nikon D-5100.

klaxian (rgabriel) wrote :

I've tried the ufraw-batch fix here, but I still don't get thumbnails for CR2 files. I have the raw.thumbnailer file set up correctly with the proper ufraw-batch executable. ufraw-batch works fine from the command line, but I don't get any thumbnails. I have restarted without success. I am running Linux Mint 12. Any suggestions? Thanks.

msth67 (msth67) wrote :

I've tried this workaround as described in comment 28 both in Mint 13 Mate and Mint Debian Mate,it doesn't work for me,still no thumbnails whatsoever for raw photo files.

dogmatic69 (dogmatic69) wrote :

Comment 13 has done the trick for me. All works after installing gnome-raw-thumbnailer and adding the config.

msth67 (msth67) wrote :

In reply to comment #28 : does this fix currently work with the Mate desktop environment ? I've been trying with Mint 12,Mint 13 and Mint Debian and I can't see any raw (Cr2) thumbnail at all,furthermore according to this issue https://github.com/mate-desktop/mate-file-manager/issues/21 , Mate *can't* actually -as of now- handle this kind of files,as this excerpt clearly states "Caja [Mate file manager] doesn't have any support for displaying CR2 file thumbnails."
Am I missing something here ? I've been trying to see my CR2 files for a while now,if there's any kind of fix/workaround that actually works I'd be happy to try it.

Justin Solms (justinsolms) wrote :

I tried #20 on Ubuntu 12.10 with Canon CR@ files. Worked for me.

Grzegorz G. (grzesiek1e5) wrote :

Good news! Today I had some time to play with it and I have created a simple, but working patch. It just puts gnome-raw.thumbnailer (see comment #20 ) in /usr/share/thumbnailers/ during install.

I tried to make a PPA for testing, but all this bzr, ppa and package building stuff takes way more than 1 day to understand. I have only managed to build a deb for myself without correct info (like version -> USC won't let you install it, I had to do it by dpkg -i). But if fix in comment #20 works for you, then the patched package should too.

So we just need somebody more experienced to apply my patch to trunk (maybe even upstream) and bug will be fixed in newer versions.

Grzegorz G. (grzesiek1e5) wrote :

I think I have actually managed to set up a PPA. You can use it for testing: https://code.launchpad.net/~grzesiek1e5/+archive/testing

But If someone wants to merge my branch, better don't merge anything else than those three files mentioned in patch above, as it certainly isn't clean, properly documented (debian files) branch. :)

Branch URL: https://code.launchpad.net/~grzesiek1e5/gnome-raw-thumbnailer/raw-thumbnailer-fix

The attachment "gnome3.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch

Post #20 did the trick for me as well.
Ubuntu 12.04 64bit, NEF (Nikon D7000 -should normally work for all models)

Thanks Grzegorz G. !

Daniel Holbach (dholbach) wrote :

It seems like gnome-raw-thumbnailer is now maintained at https://github.com/GNOME/gnome-raw-thumbnailer - could somebody go and forward the patch missing gnome-raw.thumbnailer file there too please? This will make sure that the fix is included upstream as well. Thanks a lot in advance.

Daniel Holbach (dholbach) wrote :

Uploaded with a couple of minor changes. This will take a while to get through the queue, we're currently in freeze.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-raw-thumbnailer - 2.0.1-0ubuntu7

---------------
gnome-raw-thumbnailer (2.0.1-0ubuntu7) raring; urgency=low

  [ Grzegorz G. ]
  * gnome-raw.thumbnailer: added, it's needed in Gnome 3 (LP: #852923)
  * debian/rules: added line for copying above file to /usr/share/thumbnailers
    at install.

  [ Daniel Holbach ]
  * d/rules, d/control, d/copyright: use dh, update FSF address, add
    dh-autoreconf, move thumbnailer file into debian/ directory.
 -- Daniel Holbach <email address hidden> Tue, 02 Apr 2013 09:47:15 +0200

Changed in gnome-raw-thumbnailer (Ubuntu):
status: Confirmed → Fix Released
John McCabe-Dansted (gmatht) wrote :

Could we backport the raring fix to 12.04 LTS?

Grzegorz G. (grzesiek1e5) wrote :

AFAIK no backporting is required, the package just has to be rebuilt for 12.04. But it has to be approved for SRU (stable release update). It should be possible, because it meets the criteria ("Bugs which represent severe regressions from the previous release of Ubuntu. This includes packages which are totally unusable, like being uninstallable or crashing on startup. ")

We must do some stuff if we want it to get SRUed. See https://wiki.ubuntu.com/StableReleaseUpdates .

@dholbach: Can you tell me what minor changes you did? In summer I want to fix other thumbnailers, but I have absolutely no experience with debian packaging.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions