Fails to upgrade from dapper -> edgy

Bug #62993 reported by Crispin Flowerday on 2006-09-29
4
Affects Status Importance Assigned to Milestone
gnome-python-extras (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

I'm upgrading from dapper -> edgy, and got the following:

Preparing to replace python-gnome2-extras-dev 2.14.0-0ubuntu3 (using .../python-gnome2-extras-dev_2.14.2-0ubuntu3_all.deb) ...
U
Unpacking replacement python-gnome2-extras-dev ...
dpkg: error processing /var/cache/apt/archives/python-gnome2-extras-dev_2.14.2-0ubuntu3_all.deb (--unpack):
 trying to overwrite `/usr/include/pygda-1.2/pygdavalue_conversions.h', which is also in package python2.4-gnome2-extras

Perhaps there needs to be a replaces or conflicts or something.

Sebastien Bacher (seb128) wrote :

Thanks for your bug

Changed in gnome-python-extras:
assignee: nobody → desktop-bugs
importance: Undecided → High
Albert Santoni (gamegod) wrote :

I'm also suffering from this bug...

Is there a fix?

remove the python-gnome2-extras-dev package first, then upgrade, then install it again (at least thats what I had to do).

Albert Santoni (gamegod) wrote :

Thanks for the help Crispin, but when I do an "apt-get remove python-gnome2-extras-dev", I get the following:

~$ sudo apt-get remove python-gnome2-extras-dev
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  hal-device-manager: Depends: hwdb-client-gnome but it is not going to be installed
  libvte-cil: Depends: libmono-corlib1.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system1.0-cil (>= 1.0) but it is not going to be installed
  python-glade2: Depends: python-gtk2 (= 2.10.3-0ubuntu3) but 2.8.6-0ubuntu1 is to be installed
  python-gnome2: Depends: python-gtk2 (>= 2.8.6-1) but 2.8.6-0ubuntu1 is to be installed
  python-gnome2-desktop: Depends: python-gtk2 (>= 2.9.2) but 2.8.6-0ubuntu1 is to be installed
  python-gobject-dev: Depends: python-gobject (= 2.12.2-0ubuntu1) but it is not going to be installed
  python-gtk2-dev: Depends: python-gtk2 (>= 2.10.3-0ubuntu3) but 2.8.6-0ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Maybe I just don't know how to use apt-get, but if anyone could point me in the right direction here, it'd be greatly appreciated!
Thanks again!

Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 gnome-python-extras (2.14.2-0ubuntu4) edgy; urgency=low
 .
   * debian/control.in:
     - dropped old Conflicts,Replaces, they are not required
     - python-gnome2-extras-dev Replaces python2.4-gnome2-extras, fix upgrade
       from dapper (Ubuntu: #62993)

Changed in gnome-python-extras:
status: Unconfirmed → Fix Released
Albert Santoni (gamegod) wrote :

Son of a gun, it's fixed!

Thanks a ton!

tarry (tarunbhatt1982) wrote :

hi,
i have DELL studio XPS 1640 laptop, and i have installed ubuntu 9.04(along eith WIndow vista as dual booting). Now i want to run my inbuild webcam, can sb tell me how to do it????
thanx in advance!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers